Problems connecting to SQL Server 2005 after clean install...???

I've just installed SQL Server 2005 and I'm trying to get connected to it so I can play with creating/editing databases.  I open up the SQL Server Management Studio but take a look at what I get: http://angelleye.sytes.net/temp/SQLServer.jpg.  As you can see, the username and password fields are both greyed out and I cannot edit them.  The user name field does have COMPUTERNAME\User Name but the password field is blank.  Then, when I try and connect I get the following error:

TITLE: Connect to Server
------------------------------

Cannot connect to OFFICESERVER.

------------------------------
ADDITIONAL INFORMATION:

Login failed for user 'OFFICESERVER\Drew Angell'. (Microsoft SQL Server, Error: 18456)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=18456&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

Of course the help link doesn't give me any information.  So, any information I can get on how to fix this would be greatly appreciated.  Thanks!
LVL 11
Andrew AngellCo-Owner / DeveloperAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

appariCommented:
try changing the authentication to SQLServer authentication, you can be able to enter username and password.
0
Andrew AngellCo-Owner / DeveloperAuthor Commented:
Ok, I tried that and I used my Windows login information.  With that I get the following error:

TITLE: Connect to Server
------------------------------

Cannot connect to OFFICESERVER.

------------------------------
ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

So then I just literally hit the connect button again and now I get:

TITLE: Connect to Server
------------------------------

Cannot connect to OFFICESERVER.

------------------------------
ADDITIONAL INFORMATION:

Login failed for user 'Drew Angell'. The user is not associated with a trusted SQL Server connection. (Microsoft SQL Server, Error: 18452)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=18452&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------



So now I have a few questions.  I read in a help file somewhere that windows auth. is more secure and should be used whenever possible.  Do I have to be on a domain for that to work or something?  Why would it not be possible in my situation?  Also, how do I setup my user as a trusted SQL Server user so I can connect using SQL auth?  

0
JulianvaCommented:
The user is not associated with a trusted SQL Server connection. (Microsoft SQL Server, Error: 18452)

the above is windows  Authentication error.

You dont need to be on the Domain.
You can create a local system account on the local machine and use that to login in as a windows account.
first create a local system account

then create a login with the same system account.

when you start windows with the login you created then sql server be able to auth you to the account you created

instead of using named pipes as your protocol  use tcp/ip with the windows account.



0
Cloud Class® Course: Microsoft Windows 7 Basic

This introductory course to Windows 7 environment will teach you about working with the Windows operating system. You will learn about basic functions including start menu; the desktop; managing files, folders, and libraries.

Andrew AngellCo-Owner / DeveloperAuthor Commented:
Ok, actually, I've started this stuff over from scratch.  I re-installed Windows Server and went ahead and implemeneted Active Directory just cuz I wanted to play with that anyway.  I'm gonna be installing SQL Server again tonight.  I'll update ya when I get there.
0
Andrew AngellCo-Owner / DeveloperAuthor Commented:
Ok, now I've installed SQL Server on a domain controller machine and selected to use a domain user during install for authentication.  I also installed SP2 (which I'm 99.9% sure I did the first time too because I have to for it to work on Server Longhorn).  Upon installing SP2 it gave me some information about it does not give my user admin rights to SQL server by default and I had to assign groups to the user.  I added both groups that it allowed, which were SysAdmin and one other, but I can't remember what it was called now.

Now when I try and connect i'm getting:

TITLE: Connect to Server
------------------------------

Cannot connect to OFFICESERVER.

------------------------------
ADDITIONAL INFORMATION:

Login failed for user 'AD\Drew Angell'. (Microsoft SQL Server, Error: 18456)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=18456&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

Message ID: 18456
LinkID: 20476

Where do I create logins for SQL Server?  You mentioned creating a mataching one but I can't even get logged into SQL server..??
0
JulianvaCommented:
you configured sql server to use both windows and sql authentication. when you installed sql 2005 it did ask for an SA password

you must first login with the sa account create the windows login l in management studio.
you will see
security tab - expand
logins - right click - new login - search - it will find the domains - then choose your windows account.

then close management studio - open again then login in with windows auth - make sure that you are using the correct instance name of sql server that you installed.





0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Andrew AngellCo-Owner / DeveloperAuthor Commented:
Ok, now I selected SQL Auth and put in SysAdmin for the un and the password I set.  Now I'm getting the following error:

TITLE: Connect to Server
------------------------------

Cannot connect to OFFICESERVER.

------------------------------
ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

Message ID: 233
Link ID: 20476

I thought this was suppose to easier than this..??  :)
0
Andrew AngellCo-Owner / DeveloperAuthor Commented:
I'm actually getting ready to wipe this out yet again, because I just realized that Exchange Server 2007 is only available for 64 bit version of Windows.  I'll come back when I get to this point again.
0
JulianvaCommented:
username = sa
password = password you set
0
Andrew AngellCo-Owner / DeveloperAuthor Commented:
that gave me the same error it did when i used SysAdmin
0
JulianvaCommented:
open sql configuration manager -
click on protocols for sql server - make sure that
shared memory
tcp/ip
named pipes
are all enabled

0
Andrew AngellCo-Owner / DeveloperAuthor Commented:
Ok, I enabled everything in there and then restarted the SQL Server service.  I then tried to login using sa/password and I get the same error:

TITLE: Connect to Server
------------------------------

Cannot connect to OFFICESERVER.

------------------------------
ADDITIONAL INFORMATION:

A connection was successfully established with the server, but then an error occurred during the login process. (provider: Shared Memory Provider, error: 0 - No process is on the other end of the pipe.) (Microsoft SQL Server, Error: 233)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=233&LinkId=20476

------------------------------
BUTTONS:

OK
------------------------------

Message ID: 233
LinkID: 20476

:(
0
JulianvaCommented:
what is the instance name , did you configure it as default instance or a named instance.
if you installed as a named instance then please make sure you are using the correct instance name.

you can find the instance name in the control panel - services - find mssql service.


0
Andrew AngellCo-Owner / DeveloperAuthor Commented:
I used default.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft SQL Server 2005

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.