GP Problem with Proxy settings

Hi experts,

having some issues with GP at the moment we changed from a software firewall using Proxy server to a hardware one which didnt need any proxy settings.

So i gointo the default domain policy and change it from ticked Proxy settings and close and wait.. 4 days later and all the servers say the default domain policy is setting the proxy server to unticked. But if i use (Newly found) the RSoP and check a user out it says that that Proxy settings are set and that it getting it from the default domain policy. All computers have been restarted numberous times (As i say i changed the policy 4+ days ago) so i dont get why its still doing it..

Any suggestions..

Thanks
Stephen
stebennettsjbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

EricCommented:
do a gpupdate /forceupdate to make sure all of the group policies are going through all of the domain controllers.

check to make sure that the client computers are getting the group policy settings, and not using cached credentials and settings.

could it be a dns issue ?
 - ipconfig /flushdns
 - ipconfig /registerdns

that's all i can think of right now.

0
MiahmichnoCommented:
We had a similar situation:
I ended having to create a GPO that was imported.
1) Open Group Policy
2) Go to user configuration | Internet Explorer Maintenance | Connection Settings
3) Choose import ... from current machine. (make sure that you import the settings that you want)
4) (OPTIONAL ONLY), create a registry change push, we use Prism.  Change the registry entries of:
HKCU\SW\MS\Windows\CurrentVersion\InternetSettings\ProxyEnable = 0
HKLM\SW\MS\Windows\CurrentVersion\InternetSettings\ProxyEnable = 0
0
stebennettsjbAuthor Commented:
thanks for the info i will try them both out..

0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

stebennettsjbAuthor Commented:
OK heres the update

tried doing

gpupdate /flush
reboot

on all servers and then on all machines

no joy


ive done the dns /flushdns as well with no joy also..

not sure how this importing GPO works, am i importing on the client or the server?

Thanks for the info and any more ideas welcome..

0
MiahmichnoCommented:
You will use the GPMC (Group Policy Management Console) from Microsoft to make the changes to your Active Directory.  Once GPMC is installed follow these steps:
1) Open Group policy Management
2) Right click on an OU that you want to use, I suggest a test OU to begin with.
3) Click 'Create and link a GPO here...'
4) Give it a name and press enter
5) Find and right click on the new policy, click edit
6) A new window opens labeled group policy
7) Under 'User Conviguration', drill down to 'Windows Settings'-'Internet Explorer Maintenance'-'Connection'
8) Double click 'Connection Settings'
9) Choose 'Import the current Connection Settings from this machine'
10) Click Modify Settings, and make sure that they are correct
11) Click OK, and close GPMC

Now that you have created the policy and linked it to a test OU, put a couple of test users into the that OU.  Log in to a PC with those users, and see your results.

Once you are satified with the results, Edit your default domain policy or link your new IE policy to the top level of your domain.

Good luck
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
MiahmichnoCommented:
The situation I have seen is where previous technician's will set the proxy via a local GP rather than a domain GP.  I can not explain why the domain does not override the local it there are no check marks set for static proxy, but they haven't in my worlds.  

The only way I can explain that the process I outlined above is working, is because it is actually applying an imported setting rather than no setting.  If that makes any sense at all.

The way to apply a registy setting it to either run it from a login script (not recommended)
or as a GP logon:
Part One (Create the reg file)

------  snip ------
Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"ProxyEnable"=dword:00000000
"ProxyAddress"=""
"ProxyPort"=""
[HKEY_Local_Machine\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
"ProxyEnable"=dword:00000000
"ProxyAddress"=""
"ProxyPort"=""

------  snip ------

Part Two: (create new Domain Group Policy like before)
Instead of setting the IE settings do the following:
1) Edit the policy
2) Drill down to 'User Configuration'-'Windows Settings'-'Scripts (Logon/Logoff)
3) Double Click 'Logon'
4) Click Add | Click Browse | Copy files into the newly opened folder
5) Double Click or open new reg file
6) Click OK until you are all the way out

Again, test this on a small group prior to implementing across the network
0
stebennettsjbAuthor Commented:
well a solution has been found.. a wise man came over and toke a look.. and its working now.

He changed:

sysvol\gemdom.gem-a.local\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\USER\Microsoft\IEAK\install.ins

from pointing to servers to this

[Branding]
NoLinks=1
GPVersion=6.0.6000.16414
NoFavorites=1
[DesktopObjects]
[Proxy]
Proxy_Enable=0
[URL]
AutoDetect=0
AutoConfig=0


Thankyou Miahmichno for the help :)

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Browsers

From novice to tech pro — start learning today.