CISCO 2503 Router ethernet 0 Full Duplex?

CISCO 2503 Router

I get a message in cisco 2503 router every few seconds "duplex mismatch discovered on Ethernet0 (not full duplex), with Router
EU FastEthernet0/0 (full duplex)."

How do I change this to be full duplex? What is the command?

Thanks
shiplu44Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

RPPreacherCommented:
#conf t
(config)#interf fa0/0
(config-if)#duplex full
(config-if)#exit
(config)#exit
#write mem
0
shiplu44Author Commented:
Router2503(config-if)#duplex full
                       ^
% Invalid input detected at '^' marker.

Router2503(config-if)#
0
shiplu44Author Commented:
It doesn't recognize DUPLEX as a command
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

RPPreacherCommented:
Are you certain this is a fast ethernet interface and not ethernet?

ethernet is 10 half only.
0
shiplu44Author Commented:
Router2503#show ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
BRI0                       unassigned      YES NVRAM  up                    up
BRI0:1                     unassigned      YES unset  down                  down
BRI0:2                     unassigned      YES unset  down                  down
Ethernet0                  10.12.29.79     YES NVRAM  up                    up
Serial0                    unassigned      YES NVRAM  down                  down
Serial1                    unassigned      YES NVRAM  down                  down
Router2503#
0
RPPreacherCommented:
The error message says "Ethernet0" not FastEthernet0
0
shiplu44Author Commented:
If so then how do I disable that message from appearing on the screen every few seconds?
0
RPPreacherCommented:
Ethernet0 is not a fast ethernet port.

Ethernet ports are half duplex only.
0
RPPreacherCommented:
Whatever it is connected to needs statically set to 10 half.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
shiplu44Author Commented:
Last one ... please post the command to do this?

Whatever it is connected to needs statically set to 10 half.
0
RPPreacherCommented:
What is it connected to?

Trace the cable from the ethernet0 port to the device on the other end.  That device needs configured.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.