How to use PAX command on OSX to perform incrementals. Problem specifying time. PRIORITY!

I'm trying to use PAX (the archive utility) on 10.4.9 OSX Server.   I'm trying to get this set up so that I can archive back to a particular day in order to do incremental backups, but when the backups run, the PAX always gets everything even though I'm setting up the proper date format as far as I can tell from the man pages.    

Here is the command I'm using to try to back up anything that has been modified since March 25, 2007 at midnight.
pax -w -x cpio  -T 0703250000.00/cm -f /Volumes/Backups/OSX/april-Level5-3-26-2007.cpio .

Instead of backing up what was changed from yesterday to today, this command is backing up EVERYTHING on that directory where I'm running it.   So it is probably the wrong date format, although that is how it said to do it in the man page.   yymmddhhmm.ss

Please help, I need this going ASAP.
David


wmitch2535Asked:
Who is Participating?
 
dalesitConnect With a Mentor Commented:
How about if you change the flags on the pax  command?

pax -w -x cpio  -T 0703250000.00/m -f /Volumes/Backups/OSX/april-Level5-3-26-2007.cpio .

and just search on the modification date? Doing this works for me..... The previous test indicates that your modification dates are OK.

Also have a look at http://matt.makalumedia.com/archives/000833.html which gives a nice alternative mechanism for doing backups and archiving.

Cheers,

Joel
0
 
dalesitConnect With a Mentor Commented:
Quick test - can you run

find . -mtime 1 -print

to verify what files are showing up with a modification time of one day.

Are these different from the results you were getting above? ie you have more or less the numbers you would expect?

Cheers,

Joel
0
 
wmitch2535Author Commented:
I tried that find . -mtime 1 -print and it did exactly as I would expect.  Only those files that were modified within the past day were shown while the rest of the files were not.  When you just performed a find. -print, it gave me thousands of files instead of the 100 that it showed me when I ran your command.  

Thanks for the thought!
0
 
wmitch2535Author Commented:
Actually the problem turned out to be the /cm switch on the time command.   The problem was that each night, there is a cron script that copies the data from  one partition to another partition.   This updates the inodes to be all modified from that time they were copied.  The /cm flag therefore caused everything to be selected.   I have since removed the /cm flag and it works great now.

Thank you all for your help!
David
0
All Courses

From novice to tech pro — start learning today.