Solved

BrightStor ARCserve Backup Alerts not working

Posted on 2007-03-26
15
3,722 Views
1 Endorsement
Last Modified: 2008-06-26
Sometime in 2006, the Alerts stopped functioning in ARCserve, and we can't get them to work again.  When we send a test alert, we receive it, but we do not receive a message at night when the backup is complete.  The Alert  Activity Log shows "Sending SMTP Successfully" each night.
Windows Server 2003
BrightStor ARCserve Backup v11.5 SP2 Build 4232
SMTP Settings are administrator@domain.local, Subject "BAB Alert Notification", SMTP Server 127.0.0.1  (domain is our client's domain).
Preflight Check runs fine.  We upgraded them from an older version to 11.5, thinking that would fix it, but there must be another problem?
1
Comment
Question by:johndgriffin
  • 6
  • 5
  • 2
  • +1
15 Comments
 
LVL 22

Expert Comment

by:dovidmichel
ID: 18794199
Well if Alert reports sending the messages, how do you know it is not really sending them?
Perhaps the messages are being sent but something at the other end or in between has changed to prevent their arrival at the destination.

Off the top of my head, check to see that the destination is receiving other SMTP messages.
Perhaps there is some filtering preventing them from reaching the destination.
Try sending an SMTP message from some other application at the same system to see if it reaches the destination.
0
 

Author Comment

by:johndgriffin
ID: 18795741
We are the recipient of the messages.  We receive email from their users to our support inbox daily.  We sent a message from Outlook on that server and received it.
Also, we did delete the job and started from scratch.
Any other ideas?
0
 
LVL 35

Expert Comment

by:ShineOn
ID: 18795884
If the SMTP engine on the BAB server is sending the message to their local domain, then something else is supposed to pick it up from there and send to its destination.  Assuming it's Exchange, I can think of 2 things: 1) The Exchange server is rejecting the message, possibly due to Microsoft security patches or 2) there's a spam or antivirus gateway that's rejecting the message because it hasn't been whitelisted or otherwise exempted from the spam/antivirus gateway's detection criteria.

Internal non-Exchange SMTP traffic is usually considered suspect unless those tools that watch for malware/spambot activity are told otherwise.

Having it suddenly stop functioning souns suspiciously like a Windows Update or Exchange service pack action...
0
Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

 
LVL 35

Expert Comment

by:ShineOn
ID: 18795903
As davidmichael said, you should send an SMTP message from  another app on the same system.  Outlook doesn't send SMTP unless it's pointing at an SMTP server, and then, as an SMTP client.  If you've got Exchange, it's more likely to be sending the message via MAPI.
0
 

Author Comment

by:johndgriffin
ID: 18807574
I don't think there's another application on the server to send an SMTP message, how would I do this?
Also, because I can send the Test Alert and it comes through, that should have gone through SMTP anyway?  If the test goes through, doesn't that foil that theory?
Thanks!
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 18809092
0
 

Author Comment

by:johndgriffin
ID: 18846889
We tested and SMTP is working.
Other thoughts?
0
 

Author Comment

by:johndgriffin
ID: 18958137
Okay, here is another piece of the puzzle, and I'm upping the points...
We do get the messages on after the backups on Friday nights, but not Monday-Thursday.
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 18960821
weird.

Is it the same job for both? Perhaps there is a mistake with the way the Mon-Thurs. job is setup.
0
 

Author Comment

by:johndgriffin
ID: 18961402
Same job, there is only one backup job (there is the pruning job, too).  
The only difference is Monday-Thursday is incremental, Friday is full.
Yes, weird :)
0
 
LVL 22

Expert Comment

by:dovidmichel
ID: 18962506
Sorry but this one has me stumped I'm out of idea, but will keep thinking about it.
0
 

Author Comment

by:johndgriffin
ID: 19241570
I thought I'd increase the points to see if there are any further ideas....we are having the same issue now at another client of ours.  We were getting the messages, then all of sudden they stop.  Test alerts work.  The other client is a little different in that we're running BrightStor ARCserve (v11.5 SP1 Build 4146) from a host computer (using VMware).  The original client that does not send messages, though, is running Windows.
Thanks.
0
 
LVL 22

Accepted Solution

by:
dovidmichel earned 500 total points
ID: 19242495
Did some research and came up with these things that got it working for others.

resolutions: configured Virtual SMTP-server's relay (from server's properties, access, relay) to allow relay from it's own IP-address because that's where Alert Managers SMTP-connections come from
---------------------
I installed the patch Wiedie sugested but still couldn't get the notifications. I then did a tcpdump on the SMTP server and saw that CA doesn't follow the RFC om SMTP.

They use "RCPT TO:my@email.com" and not "RCPT TO:<my@email.com>" as the RFC says. So i then changed the "Address" field in the "SMTP Recipients" to <my@email.com> instead of my@email.com and now it works. So if you have a picky SMTP server you could try this.
----------------------
To get the alerts working you need to logon locally to the server using the agent account that you have setup with a mailbox in your domain. Then you need to run through the Exchange agent configuration whilst logged on as this user. Specify the mailbox and account details for this user during the setup and the configuration will complete succesfully then you should be able to send the test message.

The account will need the right to log on locally, act as part of the OS, log on as a service and I would also add them to the backup operators group.
-----------------------
Yes you are correct SMTP server has to be existing with the machine having alert Manager otherwise it won't work
In case you have more than one Arcserve Server you need to
configure SMTP server for each,CA promised to relase a new version on Alert manager which you can specify the SMTP server,but till this momemmt no new about it.
What we can do is just to wait and accept what CA gives us.
------------------------
Working solution:
Install SMTP service of IIS, set Smart host to be your Exchange server (IP or domain name).
Setup SMTP in Alert Manager, do a test mail and viola..
-------------------------
and this one is from rindi
Also make sure your firewall has port 25 open so that you can send from that port. Some mailing systems require you to authenticate yourself with the mail server to be able to use it to send messages (in outlook you sometimes have to check this option when you setup an account). If this is the case you might have to get the arcserve alerting agent to log on to your mail server first, before you can send alerts.
0
 
LVL 1

Expert Comment

by:Computer101
ID: 20355318
Forced accept.

Computer101
EE Admin
0

Featured Post

Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Storage devices are generally used to save the data or sometime transfer the data from one computer system to another system. However, sometimes user accidentally erased their important data from the Storage devices. Users have to know how data reco…
How to update Firmware and Bios in Dell Equalogic PS6000 Arrays and Hard Disks firmware update.
This tutorial will walk an individual through the process of installing the necessary services and then configuring a Windows Server 2012 system as an iSCSI target. To install the necessary roles, go to Server Manager, and select Add Roles and Featu…
This tutorial will show how to configure a single USB drive with a separate folder for each day of the week. This will allow each of the backups to be kept separate preventing the previous day’s backup from being overwritten. The USB drive must be s…

828 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question