Delayed Write Failed

I'm on XP sp2 connecting to W2K server sp4
Problems started with having issues in Excel doing Save took forever for me to see the folders.  After researching I found out that it was caused by disconnected network drives.  

So from there I noticed that the drives disconnected more often than my other servers. So I made changes per MS KBQ297684 to mirror other servers

Which brings me to my next problem:
Windows - Delayed Write Failed
"Windows was unable to save all data for the file \\path\path\path\path\path\path\path\path.  The data has been lost.  This error may be caused by a failure of your computer hardware of network connection. Please..."

No one else in the department seems to have this problem.  Their drives gets disconnected too, we save to same drives/folders, and we have same make/model equipment.  I've read several threads that now I'm leaning towards a hardware problem?  Could it be that I have a bad hard drive?
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Boot from a Windows CD into Recovery Console:

and run "chkdsk /R" (no quotes)

on each of you partitions - e.g. chkdsk C: /R

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Troubleshooting for IDE drives -

(says for XP - but applies to 2000 as well)
This may apply to you:

If so - contact Microsoft for the update.
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

Brian PiercePhotographerCommented:
More likey that you have a faulty network card I think.

Determine you computer's IP addesss (use ipconfig)

from another machine use Ping -t (where is your machines IP address). The -t pings continuously (to stop use CRTL-C). look for occasional failures that may indicate an intermittent fault.
Brian PiercePhotographerCommented:
... then repeat the process in reverse to check the Network card on the server
LKamokuAuthor Commented:
Some times this error also comes up after the delayed write failed. "Disk Full". Our server has many GB available.  These are large excel files, the file being worked on in particular is 9200kb and growing.  If I save to my local HD saves instantly.

This is only happening to people in accounting dept. They all save to same share drive accessing different files and folders.  path levels seems to be as deep at 8

make model of laptops are HP nc4200 & nc4400 - everyone has 1.5gb - 2gb of RAM - i've disabled disk caching based on MS KB Q330174 (should I also edit the registry as noted in WORKAROUND?)

There are not Event ID 50 so I dont think MS KBQ321733 would apply to me in this case.  All laptops are running XP sp2

2 users are complaining they have run into same issue this same week with Delayed Write Failed w/ a different file.  2 other users complained that opening a particular file takes a very long time but the person next to them can open in in secs. (no error generated) - as a fix for this particular issue,  I'd end process for excel then open excel and click on recovered file and it'll be fine.  Other wise if I wait for excel to open file by double takes over 10-20 to open.

When files is slow to save or open, it takes up all their system resources.  They are always working with several excel files open. This has only been happening the last 2 weeks.

I dont know what else to's a critical time right now for the accounting dept because of QTR end starts next week and I know frustrations will start to flair!!!
LKamokuAuthor Commented:
If I write click on the Hard Drive the Write caching and Safe Removal is greyed out.  I tried loggin in as local admin on machine but it's still greyed out.
Sorry that I couldn't help any more...

Hope you got the problem resolved.

Thanks anyway.
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.