Solved

Application Pool missing from IIS

Posted on 2007-03-26
3
4,444 Views
Last Modified: 2012-08-14
One of the servers I inherited was upgraded from 2000 to 2003.  For reasons that I don't understand, IIS 6.0 on this box does not list a default application pool although all of the websites on this box seem to work fine with the default settings.

I want to upgrade the box from ASP.NET 1.1 to 2.0 but am unclear how to create a separate 2.0 application pool if there is no primary application pool set.  Any suggestions on this one?  I've never seen an instance of IIS 6.0 without an application pool so I'm not sure how to proceed.   I've found lots of resources for installing additional application pools off of the primary, but nothing for my particular situation.  

I'll keep pushing management for a separate box to install our production application on instead and then perhaps reinstalling IIS 6.0 but in the meantime, has anyone even seen this before or have suggestions for addressing?
0
Comment
Question by:jenieh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 7

Accepted Solution

by:
Mikealcl earned 500 total points
ID: 18795982
Interesting problem.  Perhaps someone enabled IIS5 isolation mode on this server??


Right click on a web sites in the IIS MMC hit properties, check services tab and see if run WWW service in IIS5 isolation mode is checked.  If its checked, all you have to do is uncheck and restart IIS and you should be able to see the application pools.

HTH, Mikeal
0
 
LVL 2

Author Comment

by:jenieh
ID: 18800969
Thanks Mikeal!  That looks like the issue!  There were a number of us stumped by this so full kudos to you.  Once I turned of the isolation mode I was able to set up another application pool for our 2.0 install without issue.  

Thank you again!
0
 
LVL 1

Expert Comment

by:IslandsIT
ID: 20974864
Just one minor point. I had the same issue but when I looked at the Service tab, Isolation mode was unchecked.  I  had to check it/Restart IIS then uncheck /Resart IIS before the default application pool was available.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Know what services you can and cannot, should and should not combine on your server.
A phishing scam that claims a recipient’s credit card details have been “suspended” is the latest trend in spoof emails.
A short tutorial showing how to set up an email signature in Outlook on the Web (previously known as OWA). For free email signatures designs, visit https://www.mail-signatures.com/articles/signature-templates/?sts=6651 If you want to manage em…

733 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question