[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 515
  • Last Modified:

Task Scheduler - only runs as system when logged out

Task scheduler does not run (when logged out only) task set under the administrator, only runs taska set under the ystem account.
Is there a way to change this? Is there a way to set tasks to run under system account?
0
Bartley1969
Asked:
Bartley1969
1 Solution
 
caddladyCommented:
It is best to use an appropriate account that matches the scheduled task.  Using the System account gives cart blanch access to the server.

If the task is not running when the user is not logged on, check the password and retype it in and when you look at the properties of the scheduled task, on the Task tab, do you have a check mark in the run only if logged in option?

Good Reading:

http://technet2.microsoft.com/WindowsServer/en/library/573a07f4-3fca-4e95-8c94-b3842b8402731033.mspx?mfr=true
0
 
65tdCommented:
0
 
rjmedinaCommented:
I personally have found that task scheduling when setup via the GUI does NOT run once you are logged out, unless you use a system account.  

When I need a task to run I set it remotely from the command line and I specify the runas command for executing the task.  Of course whatever account you want to use should have the proper permissions to execute the task.

The link below is to another EE PAQ that deals with this issue were I go into detail as to how to remotely schedule the task.

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22128500.html

Hope this helps!
0

Featured Post

SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now