?
Solved

Crystal Reports XI Release 2 Toolbar Images Show up as a Red X When Deployed to Web Server

Posted on 2007-03-27
4
Medium Priority
?
607 Views
Last Modified: 2013-11-26
After deploying Crystal Reports XI Release 2 to a web server, the toolbar images show up as a red x.  I have downloaded and installed the latest files and created the crystalreportviewers115 virtual directory to no avail.  I am using ASP.NET in Visual Studio 2005 and the reports work fine locally.  I have been working on this for several days now and I need to get it working.  Please help!
0
Comment
Question by:pwm001
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
4 Comments
 
LVL 28

Expert Comment

by:bdreed35
ID: 18799431
There are several articles on the BOBJ KBase.  Try searching for "red x" in Crystal Reports.  Once you get the results, you can filter it down to Crystal Reports XI using the links on the right.
Here is one article that may be useful:
http://technicalsupport.businessobjects.com/KanisaSupportSite/search.do?cmd=displayKC&docType=kc&externalId=8157120&sliceId=&dialogID=17884463&stateId=1 0 17882969
0
 
LVL 1

Author Comment

by:pwm001
ID: 18826432
I did search all the Kbase articles and couldn't find anything.  That is why I posted it on here.  I eneded up using their online support and they had me do a couple of different things to get it working.

1.  I had to copy the contents of a zip file they sent me to the root folder of the web site (not the virtual directory I was working with).  It was the content of the aspnet_client folder from the Business Objects folder in Program files.

2.  After that was done, the toolbar icons started showing, but the Print button would not do anything.  They then told me I had to copy the "crystalreportviewers115" folder which is in "C:\Program Files\Business Objects\Common\3.5\" to  the root folder of the website.

This solved my problem so I will close this issue.  Thanks for any help.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 19028208
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Free learning courses: Active Directory Deep Dive

Get a firm grasp on your IT environment when you learn Active Directory best practices with Veeam! Watch all, or choose any amount, of this three-part webinar series to improve your skills. From the basics to virtualization and backup, we got you covered.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Recently while returning home from work my wife (another .NET developer) was murmuring something. On further poking she said that she has been assigned a task where she has to serialize and deserialize objects and she is afraid of serialization. Wha…
Today I had a very interesting conundrum that had to get solved quickly. Needless to say, it wasn't resolved quickly because when we needed it we were very rushed, but as soon as the conference call was over and I took a step back I saw the correct …
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…
The viewer will learn how to synchronize PHP projects with a remote server in NetBeans IDE 8.0 for Windows.
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question