Solved

Crystal Reports XI Release 2 Toolbar Images Show up as a Red X When Deployed to Web Server

Posted on 2007-03-27
4
596 Views
Last Modified: 2013-11-26
After deploying Crystal Reports XI Release 2 to a web server, the toolbar images show up as a red x.  I have downloaded and installed the latest files and created the crystalreportviewers115 virtual directory to no avail.  I am using ASP.NET in Visual Studio 2005 and the reports work fine locally.  I have been working on this for several days now and I need to get it working.  Please help!
0
Comment
Question by:pwm001
4 Comments
 
LVL 28

Expert Comment

by:bdreed35
ID: 18799431
There are several articles on the BOBJ KBase.  Try searching for "red x" in Crystal Reports.  Once you get the results, you can filter it down to Crystal Reports XI using the links on the right.
Here is one article that may be useful:
http://technicalsupport.businessobjects.com/KanisaSupportSite/search.do?cmd=displayKC&docType=kc&externalId=8157120&sliceId=&dialogID=17884463&stateId=1 0 17882969
0
 
LVL 1

Author Comment

by:pwm001
ID: 18826432
I did search all the Kbase articles and couldn't find anything.  That is why I posted it on here.  I eneded up using their online support and they had me do a couple of different things to get it working.

1.  I had to copy the contents of a zip file they sent me to the root folder of the web site (not the virtual directory I was working with).  It was the content of the aspnet_client folder from the Business Objects folder in Program files.

2.  After that was done, the toolbar icons started showing, but the Print button would not do anything.  They then told me I had to copy the "crystalreportviewers115" folder which is in "C:\Program Files\Business Objects\Common\3.5\" to  the root folder of the website.

This solved my problem so I will close this issue.  Thanks for any help.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 19028208
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Master Your Team's Linux and Cloud Stack!

The average business loses $13.5M per year to ineffective training (per 1,000 employees). Keep ahead of the competition and combine in-person quality with online cost and flexibility by training with Linux Academy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article describes relatively difficult and non-obvious issues that are likely to arise when creating COM class in Visual Studio and deploying it by professional MSI-authoring tools. It is assumed that the reader is already familiar with the cla…
This document covers how to connect to SQL Server and browse its contents.  It is meant for those new to Visual Studio and/or working with Microsoft SQL Server.  It is not a guide to building SQL Server database connections in your code.  This is mo…
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…
The viewer will learn how to use and create new code templates in NetBeans IDE 8.0 for Windows.

840 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question