15 Character Passwords on Unix/Solaris.

Is there any functionality issues with a 15 character password on UNIX/Solaris machines – or those that communicate with non UNIX/Solaris machines?
jbowlinAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Kent OlsenDBACommented:
Hello jbowlin,

If you're staying within the unix realm, a 15 character password shouldn't be an issue.  (Though that sounds like overkill to me.....)

Some applications, particularly some IBM products, require shorter passwords.


Good Luck,
Kent
0
TintinCommented:
By default Solaris (and most other Unix flavours) will only recognise the first 8 characters of a password.

So if you set your password to

abcdefgh123

You could type in

acbdefgh38udsfkhsfksfu

or

abcdefgh

and your password would be accepted.

You can increase the maximum length of passwords on Solaris =>9 systems to 255 characters, by editing /etc/security/policy.conf and set

CRYPT_ALGORITHMS_ALLOW=1,2a,md5
CRYPT_ALGORITHMS_DEPRECATE=__unix__
CRYPT_DEFAULT=1
0
yuzhCommented:
For Solaris you can edit /etc/default/passwd file to have longer password length
PASSLENGTH=x

But keep in mind, many application has a limit to 8 char for
password, eg the old Solstice adm suit for NIS+ etc.
0
Do You Have a Trusted Wireless Environment?

A Trusted Wireless Environment is a framework for building a complete Wi-Fi network that is fast, easy to manage, and secure.

jbowlinAuthor Commented:
This is for Solaris 8.
It is a mandated by a Government Agency no choice in the matter.
0
TintinCommented:
With Solaris 8, you are stuck with a maximum recognised password length of 8.
0
yuzhCommented:
You can set:
PASSLENGTH=15
to require passwords to be a minimum of 15 charts (if you are using /etc/passwd /etc/shadow files) but soem other app
might not like it.  (It can become an app issure, not the OS issue).
0
TintinCommented:
yuzh.

Setting PASSLENGTH to 15 is pretty pointless when the last 7 characters of the password are going to be ignored.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
chris_calabreseCommented:
BTW this was fixed in Solaris 10
0
TintinCommented:
Chris.

Wasn't really "fixed" in Solaris 10.  Solaris =>9 has the option to set MD5 passwords (as used on BSD/Linux) in /etc/security/policy.conf, which has a maximum password length of 255.

Setting PASSLENGTH without changing this setting, still won't make any difference.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
OS Security

From novice to tech pro — start learning today.