Reverse DNS issue

Finally figured out that our mail to AOL is being blocked due to incorrect reverse DNS config.  Spoke with our ISP yesterday and partially resolved the issue.

Our mail server - 66.76.1.149 - now shows up correctly when using dns dig:
-----------------------------------------------------------------------------------
;; ANSWER SECTION:
149.1.76.66.in-addr.arpa.  3h57m6s IN PTR  mail.athomehealth.org.
-----------------------------------------------------------------------------------

However, our MS Exchange mail server is not named "mail", but "exchange".

Now, at DNSReport.com, I'm getting the error about "mail server host name in greeting",
-----------------------------------------------------------------------------------------------------
mail.athomehealth.org claims to be non-existent host exchange.athomehealth.org:
220 exchange.athomehealth.org Microsoft ESMTP MAIL Service, Version: 6.0.3790.1830 ready at Tue, 27 Mar 2007 09:55:05 -0500
-----------------------------------------------------------------------------------------------------

Now, we can't change the name of our server (because we have many internal laptop clients pointing to "exchange" as the mail server in Outlook), and yet I don't think it would be correct to have our ISP change the PTR to "exchange" instead of "mail", would it?

I'm sure there's a wise solution out there, but it escapes me at the moment.
itatahhAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

CGretskiCommented:
Try setting up a CNAME record in forward DNS to point mail. to exchange.
0
itatahhAuthor Commented:
But would that prevent our mail server from ID'ing itself as "exchange.athomehealth.org" instead of the correct "mail.athomehealth.org"?
0
itatahhAuthor Commented:
Increasing points - we've got outgoing mail to AOL piling up - need a solution.
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

SembeeCommented:
The reverse DNS needs to resolve and match what the server announces itself as.

Therefore you either need to change what the server announces itself as, or get the ISP to change the reverse DNS. Personally I would change what the server announces itself as.
http://www.amset.info/exchange/dnsconfig.asp

If email for AOL continues to pile up, use an SMTP Connector to push it through the ISPs server: http://www.amset.info/exchange/smtp-connector.asp

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cyclops3590Commented:
Don't forget AOL, along with many now, are getting quite picky.  the PTR record needs to match what your server announces itself as.  But the A record for its fqdn need to match the same IP that it connects with.
0
itatahhAuthor Commented:
Great solutions; thanks!

Our ISP indeed was mapping to the incorrect domain, and then I change our exchange server's FQDN to mail.athomehealth.org.   Also added a CNAME record.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.