Link to home
Get AccessLog in
Avatar of Harold
HaroldFlag for United States of America

asked on

Windows 2003 server permissions

I have applied the following Permission structure(yes this has been posted several times before).
As *share* permissons, give the Everyone group Full Access.
For the time being, create four local groups on the file server hosting the share (if your domain is running in Windows 2000 native mode or higher, you can create domain local groups as well):
* L-WHC-C
* L-WBAL-Fin-C
* L-FBAL-Fin-C
* L-SAL-Fin-C
Change the permissions, first the WHC folder:
In this folder, give (local) Administrators and the System account Full permissions, and give the L-WHC-C group Change permissions; replace the permissions on child objects.
On the "Finance" subfolders of each folder, go the Advanced security tab, uncheck "Inherit permissions", check "Replace permissions", and copy the current permissions when asked. Remove the L-WHC-C group, add the L-xxxx-Fin-C group with Change permissions, leave Administrators and System with Full Access.
Create two global groups, G-Role1 and G-Role; Role1 for users with no access to the Finance folder, Role2 for users with access to all folders; you can use existing groups if they contain the correct users, and you can of course name them according to the roles the users have.
Add the G-Role1 group to the L-WHC-C group only.
Add the G-Role2 group to the L-WHC-C group and the L-xxxx-Fin groups.
Finally, add all users with no access to the finance group to the G-Role1 group, add all users with access to the finance folder as well to the G-Role2 folder.
From then on, you only need to add users to the respective global groups to give them permissions on the folders they need.

My problem is I have 3 users in the G-Role2, 1 user can open the files in Financial folder, the other 2 are still Read-Only Access, Why?
1) How or why is that all 3 are in the same group, but only 1 has access?
2) When this FINALLY works, how do you set the Financial folder so that restricted users have NO access, so they can not even VIEW files? Right now they have Read-Only. I want them BLOCKED.


Avatar of Brian Pierce
Brian Pierce
Flag of United Kingdom of Great Britain and Northern Ireland image

The final question first. If you want some people to have no access to the folder make sure the groups to which they belong do not appear in the security list. make sure that you remove the 'Everyone' and/or Users groups and any others that have no access rights.

As for the first bit, if all three are in the same group but only one has access he must be getting the permissions from sonewhere else. Check this with effective permissions option
User added to global groups need to log off and then back in to get group group changes.
Local groups, user only have to disconnect then reconnect to changes applied.
Avatar of Harold

ASKER

"effective permissions option" where do I see this? I looked at the user profile and Member of <tab> they are members of the same groups.
Avatar of Harold

ASKER

OK, I found Effective Permissions and went through the Driectory Structure down to the restricted folder and the 3 users have the same Permissions down to the restricted folder. The folder that only the 3 users should have access and the 1 user has Read and Change, the other 2 users, just Read.

I removed Domain Users, so to blocked all other users from Read-only. How do I figure where they are dropping the Read permission, like the working user has?
ASKER CERTIFIED SOLUTION
Avatar of oBdA
oBdA

Link to home
membership
This content is only available to members.
To access this content, you must be a member of Experts Exchange.
Get Access
Avatar of Harold

ASKER

Sorry, it was just Users, not Domain Users. I was trying to stop the general users from Viewing the restricted folder and content. I will run this and test it.
Are you removing these groups (Users, Domain Users, etc..) from the ACLs or are you checking deny?
Avatar of Harold

ASKER

OMG!!! I have been working on this for a 9 months and it is FINALLY right!!  oBdA, that was what I needed. Anthony, no I was not removing these groups. After I ran the .cmd and it created everything in the Test environment, I saw exactly what it was.
1) I had not removed the other Groups, as questioned.
2) I just left the L-xxx-Fin-C Groups with Special Permissions. So after checking the Modify permission, it was done.
I logged in as the Administrative users,  perfect. I logged in as restricted Users, perfect.

oBdA, I can not THANK YOU enough!
Muchos Gracias mi amigo!