Solved

ASA 5505 Client VPN

Posted on 2007-03-27
22
16,063 Views
Last Modified: 2012-08-14
OK Doing some testing set up client VPN access - the client connects and says connected - but no traffic passes and the client cannot ping any network resources,

: Saved
: Written by enable_15 at 12:22:11.604 UTC Tue Mar 27 2007
!
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password xxxxxxxxxxxxxxxxencrypted
names
name 10.254.254.10 DC01
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 10.254.254.254 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address dhcp setroute
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd xxxxxxxxxxxxxxx encrypted
boot system disk0:/asa722-k8.bin
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list inbound extended permit tcp any any eq 3389
access-list inbound extended permit icmp any any echo-reply
access-list inbound extended permit icmp any any time-exceeded
access-list inbound extended permit icmp any any unreachable
access-list inbound extended permit tcp any any eq smtp
access-list inbound extended permit tcp any any eq https
access-list inbound extended permit tcp any interface outside eq www
access-list outbound extended permit ip any any
access-list RemoteVPN_splitTunnelAcl standard permit 10.254.254.0 255.255.255.0
pager lines 24
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool VPNPool 10.254.254.85-10.254.254.90 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0
static (inside,outside) tcp interface 3389 DC01 3389 netmask 255.255.255.255
static (inside,outside) tcp interface www DC01 www netmask 255.255.255.255  dns
static (inside,outside) tcp interface smtp DC01 smtp netmask 255.255.255.255
static (inside,outside) tcp interface https DC01 https netmask 255.255.255.255
access-group outbound in interface inside
access-group inbound in interface outside
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
group-policy RemoteVPN internal
group-policy RemoteVPN attributes
 wins-server value 10.254.254.10
 dns-server value 10.254.254.10
 vpn-tunnel-protocol IPSec
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value RemoteVPN_splitTunnelAcl
 default-domain value petenetlive.com
username user1 password xxxxxxxxxxxxxxxxxxxx encrypted privilege 0
username user1 attributes
 vpn-group-policy RemoteVPN
http server enable
http 10.254.254.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map outside_dyn_map 20 set pfs
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
tunnel-group RemoteVPN type ipsec-ra
tunnel-group RemoteVPN general-attributes
 address-pool VPNPool
 default-group-policy RemoteVPN
tunnel-group RemoteVPN ipsec-attributes
 pre-shared-key thisisthepresharedkey
telnet 10.254.254.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:e91dababc138ef9559edb2fb5ca05a1d
: end


VPN was set up from the ASDM Wizard?
0
Comment
Question by:Pete Long
  • 12
  • 4
  • 3
  • +1
22 Comments
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18804533
        Would you please post some syslog outputs for us to see if al phases of VPN connection is completed or not. And you dont have "no nat" nat 0. Following link may help
http://www.experts-exchange.com/Security/Misc/Q_21885843.html
0
 
LVL 25

Expert Comment

by:Cyclops3590
ID: 18804820
one problem is that your vpn pool overlaps your internal network.  problems arise with routing due to this
change:
ip local pool VPNPool 10.254.254.85-10.254.254.90 mask 255.255.255.0
to this:
ip local pool VPNPool 10.254.154.1-10.254.154.254 mask 255.255.255.0

then to add to MrHusy's comment about the no nat
access-list nonat permit ip 10.254.254.0 255.255.255.0 10.254.154.0 255.255.255.0
nat (inside) 0 access-list nonat
then
clear xlate
to ensure the translation table is good and re vpn in
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18806303
Thanks

>>vpn pool overlaps your internal network

I got onto that one last night by reading other posts ive changed the VPNPool entry it now reads

ip local pool VPNPool2 10.254.250.1-10.254.250.10 mask 255.255.255.0
tunnel-group RemoteVPN general-attributes
 address-pool VPNPool2

But the problem remained :(

OK Now adding (As Per Cyclops Post)

access-list nonat permit ip 10.254.254.0 255.255.255.0 10.254.250.0 255.255.255.0
nat (inside) 0 access-list nonat

Now clearing the tranlations..................... cl xl

Now retrying access....................................
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18806311
Pants - Still no joy hang on Ill get some syslogs......

0
 
LVL 57

Author Comment

by:Pete Long
ID: 18806351
here we go

Mar 27 18:20:27 local Listening for Syslog messages on IP address: 10.254.254.10
Mar 27 18:20:27 local Listening for Syslog messages on IP address: 10.254.254.11
Mar 27 18:24:09 local Listening for Syslog messages on IP address: 10.254.254.10
Mar 27 18:24:09 local Listening for Syslog messages on IP address: 10.254.254.11
Mar 27 18:29:57 local Listening for Syslog messages on IP address: 10.254.254.10
Mar 28 08:51:28 local Listening for Syslog messages on IP address: 10.254.254.10
Mar 28 08:54:51 10.254.254.254 Mar 27 2007 23:50:02: %ASA-5-111008: User 'enable_15' executed the 'logging trap notifications' command.
Mar 28 08:54:51 10.254.254.254 Mar 27 2007 23:50:02: %ASA-5-111008: User 'enable_15' executed the 'logging facility 19' command.
Mar 28 08:55:22 10.254.254.254 Mar 27 2007 23:50:33: %ASA-5-713130: Group = RemoteVPN, Username = user1, IP = 217.123.123.123, Received unsupported transaction mode attribute: 5
Mar 28 08:55:22 10.254.254.254 Mar 27 2007 23:50:33: %ASA-3-713119: Group = RemoteVPN, Username = user1, IP = 217.123.123.123, PHASE 1 COMPLETED
Mar 28 08:55:22 10.254.254.254 Mar 27 2007 23:50:33: %ASA-5-713075: Group = RemoteVPN, Username = user1, IP = 217.123.123.123, Overriding Initiator's IPSec rekeying duration from 2147483 to 28800 seconds
Mar 28 08:55:22 10.254.254.254 Mar 27 2007 23:50:33: %ASA-5-713049: Group = RemoteVPN, Username = user1, IP = 217.123.123.123, Security negotiation complete for User (user1)  Responder, Inbound SPI = 0xe31a85ad, Outbound SPI = 0xe7a03331
Mar 28 08:55:22 10.254.254.254 Mar 27 2007 23:50:33: %ASA-5-713120: Group = RemoteVPN, Username = user1, IP = 217.123.123.123, PHASE 2 COMPLETED (msgid=7ba8cf18)
Mar 28 08:55:44 10.254.254.254 Mar 27 2007 23:50:54: %ASA-4-713903: Group = 217.123.123.123, IP = 217.123.123.123, Can't find a valid tunnel group, aborting...!
Mar 28 08:55:44 10.254.254.254 Mar 27 2007 23:50:54: %ASA-3-713902: Group = 217.123.123.123, IP = 217.123.123.123, Removing peer from peer table failed, no match!
Mar 28 08:55:44 10.254.254.254 Mar 27 2007 23:50:54: %ASA-4-713903: Group = 217.123.123.123, IP = 217.123.123.123, Error: Unable to remove PeerTblEntry
Mar 28 08:55:50 10.254.254.254 Mar 27 2007 23:51:00: %ASA-4-713903: IP = 217.123.123.123, Header invalid, missing SA payload! (next payload = 4)
Mar 28 08:56:00 10.254.254.254 Mar 27 2007 23:51:10: %ASA-4-713903: Group = 217.123.123.123, IP = 217.123.123.123, Can't find a valid tunnel group, aborting...!
Mar 28 08:56:00 10.254.254.254 Mar 27 2007 23:51:10: %ASA-3-713902: Group = 217.123.123.123, IP = 217.123.123.123, Removing peer from peer table failed, no match!
Mar 28 08:56:00 10.254.254.254 Mar 27 2007 23:51:10: %ASA-4-713903: Group = 217.123.123.123, IP = 217.123.123.123, Error: Unable to remove PeerTblEntry
Mar 28 08:56:06 10.254.254.254 Mar 27 2007 23:51:16: %ASA-4-713903: IP = 217.123.123.123, Header invalid, missing SA payload! (next payload = 4)
Mar 28 08:56:16 10.254.254.254 Mar 27 2007 23:51:26: %ASA-4-713903: Group = 217.123.123.123, IP = 217.123.123.123, Can't find a valid tunnel group, aborting...!
Mar 28 08:56:16 10.254.254.254 Mar 27 2007 23:51:26: %ASA-3-713902: Group = 217.123.123.123, IP = 217.123.123.123, Removing peer from peer table failed, no match!
Mar 28 08:56:16 10.254.254.254 Mar 27 2007 23:51:26: %ASA-4-713903: Group = 217.123.123.123, IP = 217.123.123.123, Error: Unable to remove PeerTblEntry
Mar 28 08:56:22 10.254.254.254 Mar 27 2007 23:51:33: %ASA-4-713903: IP = 217.123.123.123, Header invalid, missing SA payload! (next payload = 4)
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18806614
- Note Im quite happy to blow the config way in its entirity if someone has working commands I can paste in - this is just a testing process :)
0
 
LVL 29

Assisted Solution

by:Alan Huseyin Kayahan
Alan Huseyin Kayahan earned 100 total points
ID: 18807119
    Hi Pete
          It is not usual to read the line below in a successful VPN connection
             *Can't find a valid tunnel group, aborting
        Following command might be useful
             tunnel-group RemoteVPN ipsec-ra    
            *If possible, reset the config and set VPN by using VPN wizard of ASDM.      
0
 
LVL 79

Assisted Solution

by:lrmoore
lrmoore earned 100 total points
ID: 18807205
Pete, I don't see any nat0 entry, and you really should use a different IP subnet than your local LAN

no ip local pool VPNPool 10.254.254.85-10.254.254.90 mask 255.255.255.0
ip local pool VPNPool 10.254.255.85-10.254.255.90 mask 255.255.255.0

access-list nat_zero permit 10.254.254.0 255.255.255.0 10.254.255.0 255.255.255.0
nat (inside) 0 access-list nat_zero

Also add these entries:
 crypto isakmp identity address
 crypto isakmp nat-traversal  20
group-policy RemoteVPN attributes
  pfs disable

0
 
LVL 25

Accepted Solution

by:
Cyclops3590 earned 300 total points
ID: 18807218
on the client after the vpn is built, run this
route print

at any rate, here is mine that works, just subbed with your info where applicable

access-list splitvpn standard permit 10.254.254.0 255.255.255.0
access-list nonat extended permit ip 10.254.254.0 255.255.255.0 10.254.250 255.255.255.0
nat (inside) 0 access-list nonat
ip local pool VPNPool 10.254.154.1-10.254.154.254 mask 255.255.255.0
group-policy remotevpn internal
group-policy remotevpn attributes
 dns-server value 10.254.254.10
 ipsec-udp enable
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value splitvpn
 split-dns value petenetlive.com
sysopt connection tcpmss 1200
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map dynmap 20 set transform-set ESP-3DES-SHA
crypto map outside_map 64553 ipsec-isakmp dynamic dynmap
crypto map outside_map interface outside
crypto isakmp identity hostname
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group remotevpn type ipsec-ra
tunnel-group remotevpn general-attributes
 address-pool vpnpool
 default-group-policy remotevpn
tunnel-group remotevpn ipsec-attributes
 pre-shared-key *

0
 
LVL 57

Author Comment

by:Pete Long
ID: 18807980
>> MrHusy  tunnel-group RemoteVPN type ipsec-ra

Thats allready in there m8 :)

>>If possible, reset the config and set VPN by using VPN wizard of ASDM.

It was built using the ASDM :(

>>lrmoore  - Pete, I don't see any nat0 entry, and you really should use a different IP subnet than your local LAN

We caught that one :) thanks to Cyclops.

>>on the client after the vpn is built, run this

F:\Users\pete.CONISTON>route print
===========================================================================
Interface List
 17 ...00 05 9a 3c 78 00 ...... Cisco Systems VPN Adapter
 12 ...00 16 41 7b 1d 2e ...... Bluetooth Device (Personal Area Network)
  9 ...00 13 02 61 b2 47 ...... Intel(R) PRO/Wireless 3945ABG Network Connection

  8 ...00 15 60 c7 8a 1f ...... Broadcom NetXtreme Gigabit Ethernet
  1 ........................... Software Loopback Interface 1
 10 ...02 00 54 55 4e 01 ...... Teredo Tunneling Pseudo-Interface
 31 ...00 00 00 00 00 00 00 e0  Microsoft ISATAP Adapter
 16 ...00 00 00 00 00 00 00 e0  isatap.{B1228F0C-D4F0-416B-B3D2-C573C8998469}
 13 ...00 00 00 00 00 00 00 e0  isatap.{EC549247-B6B2-4497-8168-FA0520D684CA}
 30 ...00 00 00 00 00 00 00 e0  Microsoft ISATAP Adapter #4
===========================================================================

IPv4 Route Table
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       10.1.0.254       10.1.0.212     20
         10.1.0.0      255.255.0.0         On-link        10.1.0.212    276
       10.1.0.212  255.255.255.255         On-link        10.1.0.212    276
         10.1.1.1  255.255.255.255         On-link        10.1.0.212    100
     10.1.255.255  255.255.255.255         On-link        10.1.0.212    276
     10.254.250.0    255.255.255.0         On-link      10.254.250.2    276
     10.254.250.2  255.255.255.255         On-link      10.254.250.2    276
   10.254.250.255  255.255.255.255         On-link      10.254.250.2    276
     10.254.254.0    255.255.255.0     10.254.250.1     10.254.250.2    100
     {the ASA Im going to}  255.255.255.255       10.1.0.254       10.1.0.212    100
        127.0.0.0        255.0.0.0         On-link         127.0.0.1    306
        127.0.0.1  255.255.255.255         On-link         127.0.0.1    306
  127.255.255.255  255.255.255.255         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link         127.0.0.1    306
        224.0.0.0        240.0.0.0         On-link        10.1.0.212    276
        224.0.0.0        240.0.0.0         On-link      10.254.250.2    276
  255.255.255.255  255.255.255.255         On-link         127.0.0.1    306
  255.255.255.255  255.255.255.255         On-link        10.1.0.212    276
  255.255.255.255  255.255.255.255         On-link      10.254.250.2    276
===========================================================================
Persistent Routes:
  Network Address          Netmask  Gateway Address  Metric
          0.0.0.0          0.0.0.0   10.254.254.254  Default
===========================================================================

IPv6 Route Table
===========================================================================
Active Routes:
 If Metric Network Destination      Gateway
  1    306 ::1/128                  On-link
  8    276 fe80::/64                On-link
 17    276 fe80::/64                On-link
 30    281 fe80::5efe:10.1.0.212/128
                                    On-link
  8    276 fe80::e4d5:9236:d59b:5437/128
                                    On-link
 17    276 fe80::e8a1:e00f:eae7:95cc/128
                                    On-link
  1    306 ff00::/8                 On-link
  8    276 ff00::/8                 On-link
 17    276 ff00::/8                 On-link
===========================================================================
Persistent Routes:
  None

>>at any rate, here is mine that works, just subbed with your info where applicable


Ding dong - Cheers M8, Give me half an hour - to roll the ASA back and add it in :)
0
 
LVL 25

Expert Comment

by:Cyclops3590
ID: 18808150
I guess I don't look at routing tables that often, but this one looks odd to me
     10.254.254.0    255.255.255.0     10.254.250.1     10.254.250.2    100

does anyone else think that shouldn't be there?  I believe it should be
     10.254.254.0    255.255.255.0     10.254.250.2     10.254.250.2    100
0
How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
ID: 18808327
If you set as
 10.254.254.0    255.255.255.0     10.254.250.2     10.254.250.2    100
        then you set the ip of NIC as gateway ip. And it will redirect the packets adresses to 10.254.254.0, to itself.
      Forgive me if i think wrong but I dont see any 10.254.250 statement in PIX. If you set different ranges later, then you should run arp -d few times.
0
 
LVL 25

Expert Comment

by:Cyclops3590
ID: 18808898
>>then you set the ip of NIC as gateway ip. And it will redirect the packets adresses to 10.254.254.0, to itself.

actually it uses the vpn tunnel as the gateway then the asa does the routing after that.  i'm not sure of the setup in this scenario, but every ra vpn I've done has the IP of the vpn client as the gateway for every route that is to go thru the vpn tunnel
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18809070
Pete,  you may find this useful. Has a complete, working config with both VPN client and SSL VPN client working.
http://www.experts-exchange.com/Hardware/Networking_Hardware/Firewalls/Q_22451662.html#a18731154
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18809533
Cheers guys - sorry for the late follow up - I've been up to my ears in Catalysts today - (no Cisco for months then all the jobs come in at once - Im going to redo the config this evening)

>>:lrmoore Ive finally got my partner access to Cisco and can download things - took long enuf!!

Pete
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18811488
http://www.petenetlive.com/Tech/Firewalls/Cisco/c2svpn.htm

Is how I set it up originaly (note thats a very BETA page thats not linked!)
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18811572
http://www.experts-exchange.com/Security/Software_Firewalls/Enterprise_Firewalls/Cisco_PIX_Firewall/Q_22476083.html#a18807218

Pasted Cyclops code in and the VPN came up quicker than a bulimics breakfast? - Now I'm going to compare Cyclops code to the one generated by the ADSM and try and see where I went wrong.
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18811753
had to change a couple of IP addresses but this is the code that worked


access-list splitvpn standard permit 10.254.254.0 255.255.255.0
access-list nonat extended permit ip 10.254.254.0 255.255.255.0 10.254.250.0 255.255.255.0
ip local pool VPNPool 10.254.250.1-10.254.250.254 mask 255.255.255.0
nat (inside) 0 access-list nonat
group-policy remotevpn internal
group-policy remotevpn attributes
 dns-server value 10.254.254.10
 ipsec-udp enable
 split-tunnel-policy tunnelspecified
 split-tunnel-network-list value splitvpn
 split-dns value petenetlive.com
username user1 password IzFIX6IZbh5HBYwq encrypted privilege 0
username user1 attributes
 vpn-group-policy remotevpn
sysopt connection tcpmss 1200
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto dynamic-map dynmap 20 set transform-set ESP-3DES-SHA
crypto map outside_map 64553 ipsec-isakmp dynamic dynmap
crypto map outside_map interface outside
crypto isakmp identity hostname
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
crypto isakmp nat-traversal  20
tunnel-group remotevpn type ipsec-ra
tunnel-group remotevpn general-attributes
 address-pool vpnpool
 default-group-policy remotevpn
tunnel-group remotevpn ipsec-attributes
 pre-shared-key thisisthepresharedkey
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18812265
Ahaa! I see what I did wrong! spot the obvious mistake

http://www.petenetlive.com/Tech/Firewalls/Cisco/c2gvpn/00014.jpg
0
 
LVL 79

Expert Comment

by:lrmoore
ID: 18812637
10.254.254.0 is an INside network
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18815888
Indeed! At least now I know what I did wrong :)

Thanks All

Pete
0
 
LVL 57

Author Comment

by:Pete Long
ID: 32644747
0

Featured Post

Highfive + Dolby Voice = No More Audio Complaints!

Poor audio quality is one of the top reasons people don’t use video conferencing. Get the crispest, clearest audio powered by Dolby Voice in every meeting. Highfive and Dolby Voice deliver the best video conferencing and audio experience for every meeting and every room.

Join & Write a Comment

Have you experienced traffic destined through a Cisco ASA firewall disappears and you do not know if the traffic stops in the firewall or somewhere else? The solution is the capture feature. This feature was released in 6.2(1) and works in all firew…
I recently updated from an old PIX platform to the new ASA platform.  While upgrading, I was tremendously confused about how the VPN and AnyConnect licensing works.  It turns out that the ASA has 3 different VPN licensing schemes. "site-to-site" …
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…
This tutorial demonstrates a quick way of adding group price to multiple Magento products.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now