?
Solved

Network printer tcp/ip port reverts to original setting after it is changed

Posted on 2007-03-27
5
Medium Priority
?
407 Views
Last Modified: 2010-04-12
On Windows xp, on a library's public access network, there has been a problem changing the port for a networked printer.  I go to modify the TCP/IP port and change it from the original port of 192.168.1.11 to 192.168.1.15, but soon after that the port changes back to the original ip address of 192.168.1.15.
0
Comment
Question by:bazianm
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 
LVL 27

Accepted Solution

by:
michko earned 1000 total points
ID: 18803817
Is there still a printer at the .15 address?  If so your best bet is to delete the old printer.  Run the install for the .11 printer and connect to that address.
0
 
LVL 54

Expert Comment

by:b0lsc0tt
ID: 18804636
If a router is involved then it may be set to give the .11 address to that printer's MAC.  If you need help checking that let us know more about the network, especially what handles DHCP.

What is the make and model of the printer?

Let me know if you have a question or need more info.

bol
0
 
LVL 38

Expert Comment

by:hdhondt
ID: 18805882
I suspect the printer is running DHCP. That is not suitable for printers as the DHCP server may give out different addresses at at different times. If that's your problem, there are 2 ways to fix it.

1. Give the printer a static (manual) address. Make sure it's well away from the router's DHCP range though to avoid future conflicts.

2. Some routers can be set up to always assign the same DHCP address to a device (specified by its MAC address). If your router can do that, set it up that way.
0
 
LVL 21

Expert Comment

by:wyliecoyoteuk
ID: 18806485
hdhondt is probably right, but one thing to watch out for, some networked printers allow you to specify an address, BUT THEY DO NOT AUTOMATICALLY SWITCH OF DHCP.
You may have to select noautoip or a similar setting the model number of the printer would help.
0
 
LVL 38

Expert Comment

by:hdhondt
ID: 18806843
And wyliecoyote hinted at another possibility. Some printers use AutoIP to select an IP address if no DHCP server is available. They grab an unused IP address within the subnet they're plugged into. In that case you should also disable AutoIP.
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
When you start your Windows 10 PC and got an "Operating system not found" error or just saw  "Auto repair for startup" or a blinking cursor with black screen. A loop for Auto repair will start but fix nothing.  You will be panic as there are no back…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
This video Micro Tutorial shows how to password-protect PDF files with free software. Many software products can do this, such as Adobe Acrobat (but not Adobe Reader), Nuance PaperPort, and Nuance Power PDF, but they are not free products. This vide…

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question