?
Solved

Exchange 2007 - Outlook Error 0x80040610 message size exceeds limit

Posted on 2007-03-27
7
Medium Priority
?
16,544 Views
Last Modified: 2010-05-18
I have a new install of Exchange 2007 on a new install of Windows 2003 64-bit server (obviously) and I'm using Outlook 2003.  I am getting the following error when trying to send an e-mail with an attachment larger than 10 MB (from any account):
error (0x80040610) : 'The message being sent exceeds the message size established for this user.'
The e-mail doesn't even really try to send, it just sits in the outbox.  Outlook is setup in Exchange server cached mode.  I have searched the Internet and found advice on checking/changing the following values in the new Exchange Management Shell (the command line tool for managing Exchange 2007):

get-sendconnector shows the send connector has a MaxMessageSize of 100MB
(which I changed from the default setting of 10MB)
get-recieveconnector shows both the default (port 25) and client (port 587) recieve connectors have a MaxMessageSize of 100MB (which I also changed from the default of 10MB)
get-transportconfig shows MaxSendSize and MaxReceiveSize are unlimited.
get-Mailbox shows MaxSendSize and MaxReceiveSize are unlimited.

I've restarted the MS Exchange Transport Service twice, which had no effect and then I've also rebooted the server.  I can receive file attachments larger than 10 MB sent from the Internet (outside of the exchange server, not user to user within), so that limit change from 10MB to 100MB seems to have taken effect.  

I've read the other 2 post threads here with the same error but in Exchange 2003 with Outlook, but Exchange 2007 is completely different for where to look for these settings.  In my search, I found one person saying that these 4 settings - receive connector, send connector, transport config and mailbox -  are the only 4 places where any e-mail file size restrictions are.  (and what a pain it is that these settings aren't in the Exchange Management Console, but that's another thing....)

Does anyone out there have any advice on what to check next?  Is there something in Outlook 2003 that can "remember" what the original settings for file size limits are?  Having asked that, I now wonder if I created a new profile in Outlook if it would work.  I'll try that and report back.  Meanwhile if anyone can help I'd appreciate it.  Thanks.  -Steve
0
Comment
Question by:sfosmire
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
7 Comments
 
LVL 1

Author Comment

by:sfosmire
ID: 18816228
Here's an update:  I decided to change the Mailbox limits from "unlimited" to an actual limit and see if that made a difference, and it did.  In the Exchange Management Console (the GUI tool) I went to the Recipient COnfiguration area and then to the Mailboxes.  I edited the properties of one user and went to the "Mail Flow Settings" tab.  Highlight the "Message Size Restrictions" and click the properties button.  Now, the Sending Message SIze and Receiving Message Size "Maximum Message Size in KB" were unchecked, hence the get-Mailbox report of MaxMessageSize = unlimited.  I checked both boxes and entered 102400 (100 MB in KB) and saved.  I didn't even restart the transport service or anything and voila!  I was able to send files larger than 10 MB.  I then changed all the users the same way (there's probably a global way to do this, but I only have 15 users.)  Now get-Mailbox in the Exchange Management Shell shows 100 MB on all mailboxes.  I still don't understand why not setting a limit and get-mailbox showing unlimited isn't actually unlimited, but there's probably a twisted Microsoft logic to it somewhere.  I guess that makes this question asked and answered by myself, but if someone has an actual different answer with the mailboxes not limited at all, please fill me in and I'll award points.
-Steve
0
 

Expert Comment

by:dslturbo
ID: 18822921
This was a life saver, I had done all of what you had done, including the upgrade.  I set each mailbox, and I did have to reboot and now our issue with attachment size is also fixed.  Thanks for posting this, after 2 days it was a real save.
0
 
LVL 1

Author Comment

by:sfosmire
ID: 18897604
Another update:  On another MS Exchange Forum elsewhere someone suggested a different way to do this same thing.  Instead of individually changing the send and receive file size on each mailbox, just change the TransportConfig to a size, instead of it being "unlimited"  Thankfully I only had 15 users or so to change, so I didn't get to the point where I would have thought of that, but it's more elegant for changing everyone to the same size.  I didn't try it myself having spent the time doing them all individually,  but I believe that it would work in the same way, changing from "unlimited" (or really "there is no limit defined") to an actual number.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 19338287
PAQed with points refunded (500)

Computer101
EE Admin
0
 
LVL 1

Expert Comment

by:light-blue
ID: 20016979
This worked for me in 4 steps (without modifying individual user settings):

1. [PS] C:\Documents and Settings\Administrator>set-transportserver "EX01" -Exte
rnalDsnMaxMessageAttachSize:30MB

2. [PS] C:\Documents and Settings\Administrator>set-transportserver "EX01" -Exte
rnalDsnMaxMessageAttachSize:30MB

3. [PS] C:\Documents and Settings\Administrator>set-transportconfig -MaxReceiveS
ize:30MB -MaxSendSize:30MB -MaxRecipientEnvelopeLimit:30MB

4. Restart Microsoft Exchange Transport, then Microsoft Exchange Information Store. Resend.
0
 
LVL 1

Expert Comment

by:ssnyds
ID: 22377204
Ok light-blue,

So now after your 4 steps, My transport server will not restart... Did you run into this at all and how did you resolve please?? I also noticed that steps 1 and 2 above are the same???
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In-place Upgrading Dirsync to Azure AD Connect
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question