Solved

Cannot ping LAN using Cisco vpn client

Posted on 2007-03-27
14
480 Views
Last Modified: 2010-04-12
I have PIX 501 with vpn clients connecting via the cisco vpn client ver 4. I can access email, network resources and able to use rdp. There is one problem though - I am not able to ping anything on the LAN behind the firewall, or visa versa. I have worked on this for a while now with no resolution to the problem.
I have pasted my PIX config below. Any help is greatly appreciated.

fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list VPN permit ip 10.175.1.0 255.255.255.0 any
access-list VPN permit ip 10.179.1.0 255.255.255.128 any
access-list in_ou_nat0 permit ip 10.175.1.0 255.255.255.0 10.179.1.0 255.255.255.128
access-list outside_cryptomap_dyn_20 permit ip any 10.179.1.0 255.255.255.128
pager lines 24
logging on
logging timestamp
logging trap informational
logging device-id ipaddress outside
mtu outside 1500
mtu inside 1500
ip address outside 72.54.xxx,xxx 255.255.255.248
ip address inside 10.175.1.1 255.255.255.0
ip verify reverse-path interface outside
ip audit name attack-policy info action alarm drop reset
ip audit name info-policy info action alarm drop reset
ip audit interface outside attack-policy
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 10.179.1.1-10.179.1.10
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list in_ou_nat0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 72.54.xxx.xxx 10.175.1.2  netmask 255.255.255.255 0 0
access-group 202 in interface outside
route outside 0.0.0.0 0.0.0.0 72.54.xxx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.175.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5 ESP-DES-MD5 ESP-AES-128-SHA ESP-3DES-SHA ESP-DES-SHA ESP-AES-256-MD5 ESP-AES-256-SHA ESP-AES-192-MD5 ESP-AES-192-SHA ESP-AES-128-MD5
crypto map outside_map_1 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map_1 client configuration address respond
crypto map outside_map_1 client authentication LOCAL
crypto map outside_map_1 interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn address-pool VPN
vpngroup vpn dns-server 10.175.1.2
vpngroup vpn wins-server 10.175.1.2
vpngroup vpn default-domain xxx.local
vpngroup vpn split-tunnel VPN
vpngroup vpn idle-time 1800
vpngroup vpn password ********
telnet 10.175.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
management-access inside
console timeout 5
0
Comment
Question by:jbaxley2
  • 5
  • 4
  • 2
14 Comments
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
Comment Utility
access-list 202 permit icmp any any
access-group 202 in interface outside

access-list 201 permit icmp any any
access-group 201 in interface inside
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
Comment Utility
access-list VPN permit icmp any any
0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Caution - do not apply acl 201 to the inside interface. Due to the implicit "deny all" at the end of the acl, you will block ALL outbound traffic except icmp.
You do need to explicitly permit the icmp echo-replies back in the outside interface since ICMP is a stateless protocol.

I suggest limiting to only the specific icmp types you want to allow:
 access-list 202 permit icmp any any echo-reply
 access-list 202 permit icmp any any unreachable

>access-group 202 in interface outside
I see that you have ACL 202 applied to the interface, but I don't see acl 202 defined in your configuration. We're just assuming that you have it defined somewhere and you can simply add these lines to it.

0
 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
>I am not able to ping anything on the LAN behind the firewall
Of course not, because you're using dynamic NAT. I don't think you want to allow pings from outside to inside, unless you want to be able to ping the one host that you have a static xlate for...
0
 

Author Comment

by:jbaxley2
Comment Utility
MrHusy -
>access-list 202 permit icmp any any
>access-group 202 in interface outside
>access-list 201 permit icmp any any
>access-group 201 in interface inside
>access-list VPN permit icmp any any

Thank you for the suggestions, but i applied these commands with no success. Can you think of anything else.
0
Why You Should Analyze Threat Actor TTPs

After years of analyzing threat actor behavior, it’s become clear that at any given time there are specific tactics, techniques, and procedures (TTPs) that are particularly prevalent. By analyzing and understanding these TTPs, you can dramatically enhance your security program.

 
LVL 79

Expert Comment

by:lrmoore
Comment Utility
Please read my posts above..
0
 

Author Comment

by:jbaxley2
Comment Utility
lrmoore -
Thank you for the suggestions

>access-list 202 permit icmp any any echo-reply
>access-list 202 permit icmp any any unreachable
I tried this and it didn't work either.

>Of course not, because you're using dynamic NAT. I don't think you want to allow pings from outside to inside, unless you want to be able to ping the one host that you have a static xlate for...
How do i fix this?

>I see that you have ACL 202 applied to the interface, but I don't see acl 202 defined in your configuration. We're just assuming that you have it defined somewhere and you can simply add these lines to it
See below a complete sanitized config:
PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 0MEz1s2qhcUYG/py encrypted
passwd f78hjgEhJ54gH84X encrypted
hostname PIX
domain-name xxx.xxx
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list 202 permit tcp any host 72.54.xxx.xxx eq https
access-list 202 permit tcp any host 72.54.xxx.xxx eq smtp
access-list VPN permit ip 10.175.1.0 255.255.255.0 any
access-list VPN permit ip 10.179.1.0 255.255.255.128 any
access-list in_ou_nat0 permit ip 10.175.1.0 255.255.255.0 10.179.1.0 255.255.255.128
access-list outside_cryptomap_dyn_20 permit ip any 10.179.1.0 255.255.255.128
pager lines 24
logging on
logging timestamp
logging trap informational
logging device-id ipaddress outside
mtu outside 1500
mtu inside 1500
ip address outside 72.54.xxx.xxx 255.255.xxx.xxx
ip address inside 10.175.1.1 255.255.255.0
ip verify reverse-path interface outside
ip audit name attack-policy info action alarm drop reset
ip audit name info-policy info action alarm drop reset
ip audit interface outside attack-policy
ip audit info action alarm
ip audit attack action alarm
ip local pool VPN 10.179.1.1-10.179.1.10
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list in_ou_nat0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) 72.54.xxx.xxx 10.175.1.2 netmask 255.255.255.255 0 0
access-group 202 in interface outside
route outside 0.0.0.0 0.0.0.0 72.54.xxx.xxx 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 10.175.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5 ESP-DES-MD5
crypto map outside_map_1 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map_1 client configuration address respond
crypto map outside_map_1 client authentication LOCAL
crypto map outside_map_1 interface outside
isakmp enable outside
isakmp nat-traversal 20
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption 3des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
vpngroup vpn address-pool VPN
vpngroup vpn dns-server 10.175.1.2
vpngroup vpn wins-server 10.175.1.2
vpngroup vpn default-domain xxx.xxx
vpngroup vpn split-tunnel VPN
vpngroup vpn idle-time 1800
vpngroup vpn password ********
telnet 10.175.1.0 255.255.255.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
management-access inside
console timeout 5
terminal width 80
: end
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 500 total points
Comment Utility
access-list 202 permit icmp any any echo-reply
access-list 202 permit icmp any any unreachable
access-list 202 permit icmp any host 72.54.xxx.xxx echo

Re-apply the acl to the interface
 access-group 202 in interface outside

Done.
Some rules of icmp and PIX:
* You cannot ping the outside interface IP from inside hosts. Ever.
* You must explicitly permit the icmp types via acl (or conduit)
* "icmp" commands only affect how the referenced interface itself responds to icmp
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
Comment Utility
          What info appear in your syslog when you try to ping inside?
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
Comment Utility
               *Did you try disabling the windows firewall of the client you are pinging?
0
 
LVL 29

Expert Comment

by:Alan Huseyin Kayahan
Comment Utility
           Hi keith
                  I recommend
                      Accept: lrmoore {http:#18815601}

Regards
0

Featured Post

Highfive Gives IT Their Time Back

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article offers some helpful and general tips for safe browsing and online shopping. It offers simple and manageable procedures that help to ensure the safety of one's personal information and the security of any devices.
Let’s list some of the technologies that enable smooth teleworking. 
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

10 Experts available now in Live!

Get 1:1 Help Now