Solved

Your System has no paging file, or the paging file is too small - after I installed .NET framework Version 2

Posted on 2007-03-28
16
873 Views
Last Modified: 2012-06-27
Limited Virtual Memory
Your System has no paging file, or the paging file is too small

I started getting these after I installed .NET framework Version 2, which I needed to install ATI Catalyst Control Centre.

What happens now is that Windows XP loads up and I am faced with the login screen, I log in and I hear a beep - this beep is a pop-up messasge displaying either the above message or a similar virtual memory message - however I do not always see it, I think it is prompting me to click OK before continuing because after a wait of at least five minutes, XP starts OK and the message is no longer there.  Perhaps there is a default time-out for pop-pup messages.

The problem I am faced with is as follows -

I go into the advanced tab under performance settings and I get the following message -

"Windows created a temporary paging file on your computer because of a problem that occured with your paging file configuration when you started your computer"

I OK this and the Virtual Memory, total paging file for all drives is 0Mb

I click change and it is set to custom size (which is 384mb initial and 768mb max)

If I change this to system managed and click OK and restart my computer, when I log back on again the same thing happens.

I go back into the VM settings and low and behold VM is still 0mb and the setting is still set to System Managed.  If I then set a custom size again, same thing happens and I go around in circles.

I have since disabled the Catalyst Control centre at startup.  I am thinking this is related to .NET - I do not think it has anything to do with RAM because it was fine before I installed this, though I have never had this issue before with .NET.
0
Comment
Question by:fuzzyfreak
16 Comments
 
LVL 32

Assisted Solution

by:and235100
and235100 earned 300 total points
ID: 18807043
I would recommend powering down your pc - re-seating your ram chip(s), then setting the Virtual Memory settings to "Windows managed"

Or - you might have to boot into Recovery Console - and delete any existing pagefile.sys that is there in your system volume/partition.

0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18807123
Thanks for your reply.  OK, so I have booted into recovery console and logged into Windows.  How do I find the pagefile.sys ?  I cannot seem to go up a folder to c:\ - thanks
0
 
LVL 59

Accepted Solution

by:
LeeTutor earned 150 total points
ID: 18807192
This article tells you how to remove the restrictions on Recovery Console so that you can access any directory or I/O device:

http://www.informationweek.com/story/showArticle.jhtml?articleID=187000225
0
Simplifying Server Workload Migrations

This use case outlines the migration challenges that organizations face and how the Acronis AnyData Engine supports physical-to-physical (P2P), physical-to-virtual (P2V), virtual to physical (V2P), and cross-virtual (V2V) migration scenarios to address these challenges.

 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18807955
Actually, this was all I needed - will post again when rebooted -

http://support.microsoft.com/kb/255205

0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18808057
Nope, getting exactly the same problem.
0
 
LVL 32

Expert Comment

by:and235100
ID: 18808083
Did you get to deleting pagefile.sys?
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18808235
Yes, thanks
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18809370
Well, I thought I had found the answer - this article refers to my problem -

http://support.microsoft.com/kb/315270

However, both System and Administrators already have full control and this is a new build - I haven't touched security!  Either way, this did not resolve my problem.  does anyone have any further ideas here?  Can I reset the permissions on pagefile.sys individually?
0
 
LVL 32

Expert Comment

by:and235100
ID: 18809865
Did you re-seat the ram?

You could also look for a bios update for your motherboard.
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18810878
Yes, I reseated the RAM but I am not convinced it is a hardware issue.  I'll phone MS tomorrow and get to the bottom of it and post here.
0
 
LVL 32

Assisted Solution

by:and235100
and235100 earned 300 total points
ID: 18811210
Do you still have a pagefile.sys after a reboot?

If so - change the permissions on the file so they are set to Full Control for your user.

Now change the pagefile size - and after a reboot - the pagefile should remain constant.
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18811244
Well, if you see my previous post, I asked if I can change the permissions on the pagefile.sys individually.  How would I do this, seeing as the actual file cannot be seen or manipulated in any way?
0
 
LVL 32

Assisted Solution

by:and235100
and235100 earned 300 total points
ID: 18811289
If you go to Control Panel, Folder Options, View tab - uncheck "Hide protected operating system files (Recommended)"

Now browse to C:\ (by default)

You should see a file called pagefile.sys

Try changing the permissions on that...
0
 
LVL 5

Assisted Solution

by:usacadena
usacadena earned 50 total points
ID: 18820154
Select no pagefile for c drive say yes eben though you get warning about creating dubug log.  Create pagefile on another parition if available or if you have more 1GB you might not even need it.

Also try going to your hard drive manugacturer's website and download free Hard drive test software to see if any mad sectors on your hard drive.

Lastly, you might want to defragment your drive.
0
 
LVL 4

Author Comment

by:fuzzyfreak
ID: 18822159
Hi guys, thank you all very much for your assistance.  I have now resolved it, see the following article -

http://support.microsoft.com/kb/316528/en-us

I shall award points fairly, based on the validity of assistance received.

Many thanks.
0
 
LVL 32

Expert Comment

by:and235100
ID: 18822234
Glad I could assist you. Good work finding the right answer!
Thanks.
0

Featured Post

Three Reasons Why Backup is Strategic

Backup is strategic to your business because your data is strategic to your business. Without backup, your business will fail. This white paper explains why it is vital for you to design and immediately execute a backup strategy to protect 100 percent of your data.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Migration of Exchange mailbox can be done with the ExProfre.exe tool. But at times, when the ExProfre.exe tool migrates the Exchange Server user profile, it results in numerous synchronization problems. Synchronization error messages appear in the e…
cPanel is a Unix based web hosting control panel that provides a graphical interface and automation tools designed to simplify the process of hosting a web site. cPanel utilizes a 3 tier structure that provides functionality for administrators, rese…
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question