Solved

Public folder expansion error 80090308

Posted on 2007-03-28
5
4,215 Views
Last Modified: 2012-05-05
I recently installed a new version of sbs 2003 r2 and when i switched our exchange server to native mode, it bombs when i try and expand the public folders in esm. The error is "80090308: the token supplied is invalid".  

I have looked all over the internet for this and i have tried a bunch of different things that people have suggested to do, but nothing seems to fix the issue. Does anyone have any idea how i might fix this problem?
0
Comment
Question by:skaface69
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 7

Expert Comment

by:december41991
ID: 18807878
Not sure if you had a failed installation. Did you have a SSL cert installed here.

Anyway try this if its applicable to you as this KB is more relavant

http://support.microsoft.com/kb/324345

Dominic
www.exchangeserverinfo.com
0
 

Author Comment

by:skaface69
ID: 18807941
I have a third party cert installed in the default website in IIS.  The cert is through godaddy.  

in regards to the KB article, when it says to publish the cert with the FQDN, what exactly does that mean?  I am only using it for mail.mydomain.com/exchange.  our main website is hosted off site.
0
 
LVL 7

Expert Comment

by:december41991
ID: 18808064

FQDN , : Full qualified domain name .. like name of your public folder.domain.com
well, also
try this :
This can be caused if the HTTP keep-alive setting is not checked on the virtual web
site that hosts the exadmin virtual directory.

To remedy this:
1. Right click on the Virtual Web site that hosts the 'exadmin' virtual directory
and click Properties.
2. On the Web Site tab, make sure to check the "HTTP Keep-alives Enabled" box.
3. Click OK.

More information:
This happens because HTTP Keep-alives are required for NTLM (Windows Integrated
Authentication) to work, and the Exadmin virtual directory uses NTLM authentication
by default.

0
 
LVL 7

Expert Comment

by:december41991
ID: 18808076
or best remove the requirement on the public folders virtual directory to require SSL.
0
 
LVL 104

Accepted Solution

by:
Sembee earned 500 total points
ID: 18809402
Firs thing I would check is that you do not have require SSL enabled on either /exadmin or /public virtual directories in IIS manager. That can cause this sort of problem.
If it continues, remove the certificate (you will still have the certificate on the system so you can put it back). After removing it, drop in to a command prompt and type iisreset.
Does the problem go away then?

If it does, put the certificate back and see what happens if you make no further changes.

Simon.
0

Featured Post

Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How to resolve IMCEAEX NDRs in Exchange or Exchange Online related to invalid X500 addresses.
If you troubleshoot Outlook for clients, you may want to know a bit more about the OST file before doing your next job. IMAP can cause a lot of drama if removed in the accounts without backing up.
In this video we show how to create a Shared Mailbox in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Recipients >> Sha…
This video discusses moving either the default database or any database to a new volume.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question