Solved

Cisco AP throwing mismatch errors

Posted on 2007-03-28
11
2,778 Views
Last Modified: 2013-11-09
I have a couple Cisco Aironet  1200 APs on my network.  I keep getting the same error message over and over on these and can't figure out why.

The error is: %CDP-4-DUPLEX_MISMATCH: duplex mismatch discovered on FastEthernet0 (not half duplex), with SPR-SPL Ethernet1/0 (half duplex).

"SPR-SPL" is the hostname of my Cisco 3600 router for my P2P.  I have checked and Ethernet1/0 is set to full duplex and not auto.  I don't understand why this error is being thrown from the AP anyway as they are both plugged into switches and not into each other.  The AP is plugged into an edge switch that goes to the core and the router is directly into the core.
0
Comment
Question by:mcsween
  • 6
  • 2
11 Comments
 
LVL 21

Author Comment

by:mcsween
ID: 18808291
~~~~~~~~~~Router's running Config~~~~~~~~~~~~~~~
sho run
Building configuration...

Current configuration : 2291 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug datetime msec
service timestamps log datetime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname SPR-SPL
!
logging buffered 50000 debugging
logging rate-limit console 10 except errors
!
!
!
clock timezone EST -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
!
!
no ip domain-lookup
!
no ip dhcp-client network-discovery
!
!
!
!
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
 full-duplex
!
interface Serial1/0
 ip address 192.168.254.1 255.255.255.0
 ip helper-address 192.168.1.5
 ip directed-broadcast
 no ip route-cache
 no ip mroute-cache
 no fair-queue
 service-module t1 clock source internal
 service-module t1 timeslots 1-24
 ip rtp header-compression
!
interface Serial1/1
 ip address 192.168.253.1 255.255.255.0
 shutdown
!
router eigrp 1
 network 192.168.1.0
 network 192.168.254.0
 no auto-summary
 no eigrp log-neighbor-changes
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.2

no ip http server

!
call rsvp-sync
!
voice-port 0/0/0
 description connection to PBX trunk
 operation 4-wire
 type 2
!
voice-port 0/0/1
 description Connection to PBX trunk
 operation 4-wire
 type 2
!
voice-port 0/1/0
 description connection to PBX
 operation 4-wire
 type 2
!
voice-port 0/1/1
 description connection to PBX
 operation 4-wire
 type 2
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
dial-peer voice 5 pots
 destination-pattern 2..
 port 0/0/0
 prefix ,2
!
dial-peer voice 6 pots
 destination-pattern 2..
 port 0/0/1
 prefix ,2
!
dial-peer voice 25 voip
 destination-pattern 1..
 session target ipv4:192.168.254.2
 ip qos dscp cs5 media
!
dial-peer voice 7 pots
 destination-pattern 2..
 port 0/1/0
 prefix ,2
!
dial-peer voice 8 pots
 destination-pattern 2..
 port 0/1/1
 prefix ,2
!
!
line con 0
line aux 0
 exec-timeout 0 0
 modem InOut
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 password terminal
 login
!
!
end

SPR-SPL#
SPR-SPL#sho int ethernet1/0
Ethernet1/0 is up, line protocol is up
  Hardware is AmdP2, address is 0050.7309.5731 (bia 0050.7309.5731)
  Internet address is 192.168.1.1/24
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 69000 bits/sec, 28 packets/sec
  5 minute output rate 9000 bits/sec, 12 packets/sec
     24444 packets input, 5815780 bytes, 0 no buffer
     Received 15080 broadcasts, 0 runts, 0 giants, 0 throttles
     220 input errors, 83 CRC, 43 frame, 0 overrun, 137 ignored
     0 input packets with dribble condition detected
     9421 packets output, 2144473 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 3 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
LVL 20

Expert Comment

by:RPPreacher
ID: 18808293
Are the ports on your switch set static as well?  They need to be.

0
 
LVL 21

Author Comment

by:mcsween
ID: 18808325
~~~~~~~~~~~~~~~~~~~~~AP Running Config~~~~~~~~~~~~~~~~~~~~
sho run
Building configuration...

Current configuration : 1789 bytes
!
! Last configuration change at 11:38:49 EDT Fri Mar 16 2007
! NVRAM config last updated at 11:38:50 EDT Fri Mar 16 2007
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname NRAP28
!
enable secret 5 $1$odd1$mjRwiW6DckUK9fbgnl6An0
!
clock timezone EST -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00
ip subnet-zero
!
!
no aaa new-model
!
!
!
!
bridge irb
!
!
interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode wep mandatory
 !
 !
 speed basic-1.0 2.0 5.5 6.0 9.0 11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
 bridge-group 1 spanning-disabled
!
interface FastEthernet0
 no ip address
 no ip route-cache
 duplex auto
 speed auto
 bridge-group 1
 no bridge-group 1 source-learning
 bridge-group 1 spanning-disabled
!
interface BVI1
 ip address 192.168.1.28 255.255.255.0
 no ip route-cache
!
ip default-gateway 192.168.1.2
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
snmp-server community spgsnmpread RO
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
 transport preferred all
 transport output all
line vty 0 4
 password 7 14031719010D242A28
 login
 transport preferred all
 transport input all
 transport output all
line vty 5 15
 login
 transport preferred all
 transport input all
 transport output all
!
end



NRAP28#sho int fastethernet0
FastEthernet0 is up, line protocol is up
  Hardware is PowerPC405GP Ethernet, address is 0015.63e5.0101 (bia 0015.63e5.0101)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Full-duplex, 100Mb/s, MII
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 2/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 12000 bits/sec, 22 packets/sec
  5 minute output rate 2000 bits/sec, 3 packets/sec
     23273644 packets input, 2477692675 bytes
     Received 18880068 broadcasts, 0 runts, 0 giants, 32 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 13 ignored
     0 watchdog
     0 input packets with dribble condition detected
     1406823 packets output, 280437337 bytes, 0 underruns
     0 output errors, 0 collisions, 2 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out
0
 
LVL 21

Author Comment

by:mcsween
ID: 18808335
Yes, I have forced the switch port to full-duplex as well and I'm still seeing the errors
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 20

Expert Comment

by:RPPreacher
ID: 18808366
10 full?  Don't allow the speed to auto negotiate either.

0
 
LVL 21

Author Comment

by:mcsween
ID: 18811626
The Core Switch and 3600 Router (SPR-SPL) have been forced to 10 full.  The switch and router are showing that interface at 10/full but the wireless AP is still crying about a duplex mismatch.  I don't understand why the AP even cares.  It isn't directly connected to the router so why should it care if it's fastethernet port has the same duplex settings as the router's ethernet port?  Does anyone know why/how the AP is even seeing this "mismatch"?  Does anyone know how to turn off this network snooping?
0
 
LVL 21

Author Comment

by:mcsween
ID: 18811636
FYI - I have done a reload on both Cisco devices in the event they needed a restart after their settings change.
0
 
LVL 21

Accepted Solution

by:
mcsween earned 0 total points
ID: 18816126
It looks like this may be my issue:

Note: Cisco Discovery Protocol version 2 (CDPv2) can report an Ethernet Interface as half-duplex, even though it has been configured as full-duplex. This issue is documented in Cisco bug ID CSCdp48362 (registered customers only) . You can resolve this issue by upgrading the system software to the Cisco IOS software release not affected by the bug.

http://www.cisco.com/en/US/products/hw/routers/ps259/products_tech_note09186a00800ad3cc.shtml
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
small, multi network, problem 3 83
Connecting LAN to a new leased line 2 46
voice vlan on meraki using 3CX 3 59
Read-only SNMP string example ? 7 75
In the hope of saving someone else's sanity... About a year ago we bought a Cisco 1921 router with two ADSL/VDSL EHWIC cards to load balance local network traffic over the two broadband lines we have, but we couldn't get the routing to work consi…
I recently attended Cisco Live! in Las Vegas, a conference that boasted over 28,000 techies in attendance, and a week of hands-on learning hosted by a solid partner with which Concerto goes to market.  Every year, Cisco displays cutting-edge technol…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

867 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now