Solved

Terminal Server - Active Sessions?

Posted on 2007-03-28
22
482 Views
Last Modified: 2013-12-05
I have a Windows 2K server running Terminal Server.  I have an application that the Terminal Server is being used for.  The client does not need to be connected all day, they just connect periodically during the day to do some tasks on one application.  The issue that I am having is that when the user connects to the session, it asks if they want to be connected to an already active session.  There are usually at least two sessions to pick from.  When the user selects the session and then connects when they try to access the application, it tells them that there is already another user using the application.  I think that this is because the sessions are not really teminating hwen they close the terminal server.  How do I make sure that the session ends and is no longer active when the client closes the terminal server?  What is the proper way for the user to end the session.  Right now, I know that sometimes they hit Start - logoff and sometimes they just hit the X at the top of the session.  Can this be causing the problem?
0
Comment
Question by:suzanne2003
  • 9
  • 7
  • 6
22 Comments
 
LVL 26

Expert Comment

by:lnkevin
ID: 18811167
The proper way to close the session is start --> log off. Closing by hitting X button is the same with locking the session (same way with Ctrl+Alt+Del -->Enter). You want to lock the session if you are running some program or download, but you don't want to view it through your PC.

To terminate a session, you can go to the Domain controller then start--> program--> administrative tools--> Terminal service manager --> action--> connect to computer then drill down the session all terminate it.

K
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18812587
A couple of options to resolve:
-you can force reconnection to the same session by going to; terminal services configuration | server settings | restrict user to one session | set to -yes
-if the application can only be run by one user, you would be better making sure they are logged off. To do so got to: terminal services configuration | connections | right click on RDP-Tcp and choose properties | Sessions | enable 2nd "override user settings" and choose When a session limit is reached or a connection is broken "End Session"
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 18815121
RobWill,
If I am not mistaken, the options that you offered did not exist in W2K Server. It would be nice to have one at that time :)

K
0
 

Author Comment

by:suzanne2003
ID: 18816346
Thanks for all the help.  I have changed the settings and when I log on as the user and have tested it, it seems to be working now.  The regular user is off until Monday.  I will et you guys know by end of day Monday if she is still having the issue.  Again, thanks for all the help.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18816497
Very welcome. Glad to hear.
Cheers !
--Rob

@ lnkevin
I don't have a 2K server to check at this time, but you may be right about the first option, I'm getting old and senile, however I am sure the second exists.
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 18816728
Rob,
That's telling me you are still young and sharp. Yep, second option is existed. I forgot to mention.
Thanks,

K
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18816904
:-)
Cheers !
0
 

Author Comment

by:suzanne2003
ID: 18837460
Okay...this is what is happening.  I had no trouble all morning.  The user was able to log off and log back on and was able to get into the application with no problem.  Now all of a sudden it is not working again.  I did not change either option on the terminal server configuration tab because I looked for both and did not see either.  Are you saying that the second option does exist?   What I did do was go into the sessions tab on the users and had the session end after being disconnected for one minute.  Any other suggestions as to how I can correct this?
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 18837968
Suzanne,
In order to go for Rob second option, you need to go to "terminal service configuration" instead of "terminal service manager". Here is the replication from Rob:
Start --> Program--> Admin Tools--> Terminal Service Configuration--> connections--> Right click on RDP-Tcp and choose properties-->enable 2nd override user settings and choose When a session limit is reached or a connection is broken End Session.

K
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18837983
Did you change in active directory on the user's session tab ?
The sessions tab in Terminal services configuration will override this if set. It does exist on Server 2000 or at least the one I just checked.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18837991
Whoops sorry lnkevin, I should have refreshed before posting.
0
How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

 
LVL 26

Expert Comment

by:lnkevin
ID: 18838085
That's OK, Rob. I do that sometime. :)
0
 

Author Comment

by:suzanne2003
ID: 18850443
I changed it on the users tab, but did not change it in under terminal server configuration.  I will try that.  It seems to work fine first thing in the morning, but then it stops working in the afternoon.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18855064
>>"It seems to work fine first thing in the morning, but then it stops working in the afternoon."
Very odd. Are these sessions that are connected all day or is this happening with some that have just connected in the afternoon as well ?

The "terminal server configuration" will override the other configs, so likely the best option.
0
 

Author Comment

by:suzanne2003
ID: 18855735
The user connects and then disconnects when not using the application.  When they need to get back in they reconnect.  So the users can be disconnecting and reconnecting a few times during the day.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18857242
Very odd that the server behavior changes through the day.
There isn't a "number of sessions" limit set is there (limit as to the # of simultaneous connections) ? Though this shouldn't affect how they rejoin, I'm just wondering what is changing.
0
 

Author Comment

by:suzanne2003
ID: 18857391
Not that I know of.  Where do I check this?
0
 
LVL 26

Accepted Solution

by:
lnkevin earned 260 total points
ID: 18857466
I will need to sumarize all questions since I am almost lost here
Q
How do I make sure that the session ends and is no longer active when the client closes the terminal server?  What is the proper way for the user to end the session........
A
start--> program--> administrative tools--> Terminal service manager --> action--> connect to computer then drill down the session --> right click --> loggoff
Q
Right now, I know that sometimes they hit Start - logoff and sometimes they just hit the X at the top of the session.  Can this be causing the problem?
Yes, proper way is logoff. Do not hit X to close. It does not terminate the session.
Q
The issue that I am having is that when the user connects to the session, it asks if they want to be connected to an already active session....
A
Your users oviously hit X to close TS. Retraining them to logoff the session. Unless you have multi licenses, if not, you should logoff to make avail session for other users.
Q
The user connects and then disconnects when not using the application.  When they need to get back in they reconnect.  So the users can be disconnecting and reconnecting a few times during the day...
A
Yes, they should. Otherwise, contact Microsoft to obtain more licenses. If your session is idle for a limit of time, it will timed out and still occupy your license until you log it off or it will drop out automatically (for a few days) I saw one session sit there for 72 hours. I suggest to purchase more license to avoid this headache if you want to idle the session.

Bottom line, you need to either retrain your staffs or spend money to solve this problem. Please read carefully my sumary and let me know if you still have other question.

Good luck,

K





0
 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 240 total points
ID: 18857624
>>"Where do I check this?"
On 2003 (I don't have a 2000 here but believe it is the same);
terminal services configuration | connections | right click on RDP-Tcp and choose properties | network adapter | unlimited connections/maximum connections
Unlimited is the default
You can also set in Group policy:
Computer Configuration | Administrative Templates | Windows Components | Terminal Services |Limit number of connections

Forgot earlier about checking here for the session disconnect options. Perhaps group policy is being refreshed through the day and changing you other configs. Sorry I overlooked that:
Computer Configuration | Administrative Templates | Windows Components | Terminal Services | Sessions |

If you suspect licensing you can check the licensing manager, but I wouldn't think they would be able to reconnect if this wast the case,
0
 

Author Comment

by:suzanne2003
ID: 18868319
After much research and calling microsoft, it was determined that the application that we are using which uses a Pervasive database doesn't release the database connection when the terminal server connection is disconnected so when the user tries to get back into the application it sees the old database connection and does not allow the user to get back into the application.  It is strange because all of the users that use the application on the local network do not have this issue.  I have a tech support ticket in with the software vendor to see how to resolve this.  Thanks for all of your help.
0
 
LVL 77

Expert Comment

by:Rob Williams
ID: 18868379
Thanks Suzanne.
Glad to hear it looks like eventually you will at least have an explanation and hopefully a solution. Sorry we were not more help. Appreciate the update.
Cheers !
--Rob
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 18892600
Thanks for the update. I would definitely want to see the resolution from the ticket that you created.

K
0

Featured Post

Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

Join & Write a Comment

##the calculator has been updated to version 1.6 please download the use the updated version## Hi there, After the previous post of the original version of the calculator here : http://www.experts-exchange.com/articles/OS/Microsoft_Operatin…
1. Boot PC and press F10, select storage options and change the compatibility from “AHCI” to “IDE”, save and exit 2. Boot PC and press F12 3. Upon PXE display of searching for DHCP server, press Pause break to obtain MAC address 3. Open Configu…
Internet Business Fax to Email Made Easy - With eFax Corporate (http://www.enterprise.efax.com), you'll receive a dedicated online fax number, which is used the same way as a typical analog fax number. You'll receive secure faxes in your email, fr…
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

18 Experts available now in Live!

Get 1:1 Help Now