Solved

I'm trying to connect via windows remote desktop

Posted on 2007-03-28
10
222 Views
Last Modified: 2013-12-23
OS: Windows XP Pro

I'm trying to connect via windows remote desktop.
PC at work:
IP: 87.x.x.x
Mask: 255.225.0.0
Gate: 87.x.x.x
DNS1: 87.x.x.x
DNS2: 0.0.0.0
Domain: xxxxxxxxx

PC at home: IP:10.x.x.x
Mask: 255.225.0.0
Gate: 10.x.x.x
DNS1: 196.x.x.x
DNS2: 196.x.x.x
Workgroup: xxxxxxxxx
Workgroup:xxxxxxx

I configured my PC at work so i can connect from anywhere, but when i try to connect via internet:http://87.x.x.x:1123/tsweb i cant connect
0
Comment
Question by:diegomolineaux
10 Comments
 
LVL 3

Accepted Solution

by:
jhoop2002 earned 100 total points
ID: 18811292
1st, do you have a corporate firewall that is blocking the connection?
2nd, home firewall?
3rd, local pc firewall on either computer?

Remote desktop is enabled correct (control panel -> system -> remote tab), and you can connect from other computers at work?

Your work pc will also have to internet accessible, which isn't something i would recommend.  Meaning you could have NAT running at your office, and your companies IP address may not be configure to route remote desktop connections to your computer.
0
 
LVL 3

Assisted Solution

by:jannepm
jannepm earned 100 total points
ID: 18811515
There might be many many different reasons, mostly you can not connect to your work-PC from home because of network problems, like a router config, etc.

Also you are connecting via web-browser, have you set up your host-pc with IIS?

So:
1.Open Control Panel click Add or Remove Programs, and then click Add/Remove Windows Components.

2. Click Internet Information Services, and then click Details.

3.In the Subcomponents of Internet Information Services list, click World Wide Web Service, and then click Details.

4.In the Subcomponents of World Wide Web Service list, select the Remote Desktop Web Connection check box, and then click OK.

If you still can't access, you need to "tunnel" your connection between your work-PC and home-PC.
0
 
LVL 10

Assisted Solution

by:bbrunning
bbrunning earned 100 total points
ID: 18811978
You need forwarding setup to your work pc from the work router first of all. Then you need to find out the public IP address you're work network is on. Just checking the IP address on the computer at work won't do it because that's a private IP address. To check your public IP address go to www.whatismyip.com

Once the router is forwarded properly and the firewalls are setup correctly you'll connect.
0
Free camera licenses with purchase of My Cloud NAS

Milestone Arcus software is compatible with thousands of industry-leading cameras for added flexibility. Upon installation on your My Cloud NAS, you will receive two (2) camera licenses already enabled in the software. And for a limited time, get additional camera licenses FREE.

 
LVL 77

Assisted Solution

by:Rob Williams
Rob Williams earned 100 total points
ID: 18812435
>>"http://87.x.x.x:1123/tsweb"
You are trying to connect using the TSWeb client as opposed to the standard remote desktop client. This works well but the TSWeb client is not installed or configured by default. If this was not done have a look at the following articles.
Also you are using port 1123. Has this been forwarded to the correct internal port? The router need to have both ports 80 and 3389 forwarded to the XP machine for TSWeb. You can use different external ports if they are mapped with the router to the internal port #.

http://www.microsoft.com/windowsxp/downloads/tools/rdwebconn.mspx

http://www.microsoft.com/windowsxp/using/networking/expert/northrup_03may16.mspx
0
 
LVL 5

Assisted Solution

by:drtoto82
drtoto82 earned 100 total points
ID: 18812835
Follow these steps :
1. You should connect by the RDP to the EXTERNAL IP Address of your home network (external gateway)
2. on the router on your home , make Port Forwarding  for the TCP port 3389 to your home pc IP Address (this is what we call PAT : Port Address Translation ) . Mostly this is the missing part of your configuaration .
3. Of course , make sure that your firewalls and routers aren;t blocking the traffic at 3389 .
0
 
LVL 10

Expert Comment

by:bbrunning
ID: 18812963
You have it backwards drtoto82, he wants to connect to his office network, not home network.
0
 
LVL 5

Expert Comment

by:drtoto82
ID: 18814178
sorry ..
make the port forwarding on your office network :)
0

Featured Post

Are your corporate email signatures appalling?

Is it scary how unprofessional your email signatures look? Do users create their own terrible designs and give themselves stupid job titles? You can make this a lot easier for yourself by choosing an email signature management solution from Exclaimer today.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Join Greg Farro and Ethan Banks from Packet Pushers (http://packetpushers.net/podcast/podcasts/pq-show-93-smart-network-monitoring-paessler-sponsored/) and Greg Ross from Paessler (https://www.paessler.com/prtg) for a discussion about smart network …
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
With the advent of Windows 10, Microsoft is pushing a Get Windows 10 icon into the notification area (system tray) of qualifying computers. There are many reasons for wanting to remove this icon. This two-part Experts Exchange video Micro Tutorial s…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…

895 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now