• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1393
  • Last Modified:

Cannot create Odbc connection to sql server 2k from one windows XP machine to another XP machine running sql server 2000 in the same LAN

I have a small Lan with 4 machines running windows XP prof. One of them has sql server 2000 installed on it. I had two machines connect to sql server 2k using ODBC connection and they work fine. I recently bought a new dell computer and then tried to use Odbc to connect to sql server just like the other computers using the same sql driver, sql server username and password but it does not connect.
The servername shows up in "Microsoft Sql server DSN configuration window" but when I go to next and then put Login ID and password and say Next, it does not connect. Any ideas what may be going wrong or where to check?

0
uzairp
Asked:
uzairp
2 Solutions
 
jrosengrCommented:
Use IP address to connect to sql server
0
 
uzairpAuthor Commented:
How can I know the ip address?
0
 
uzairpAuthor Commented:
I used the ip address of the machine (instead of machine name) in the odbc connection window but I still got the same error. Here is the error I receive;
connection failed: 01000
sql server error: 10060
Microsoft odbc driver tcp/ip sockets, connection open connect()
connection failed: sql state: 08001
sql server error: 17
microsoft odbc sql server driver tcp/ip socket sql server does not exist or access denied.
0
 
jhshenCommented:
A few things you may need to do to identify the cause of this problem.
1. Ensure the 2 PCs' IP addresses belong to the same subnet mask. For example, 192.168.0.100, 192.168.0.101. subnet mask: 255.255.255.0
2. In your Winxp machine, open DOS command prompt and type the following command:
telnet 192.168.0.101 1433
Here the 192.168.0.101 is an example of your SQL 2K server IP address
If you saw some error message, please check your SQL2K server and WinXP firewall setting see if the SQL server port 1433 is not allowed.
Also, please check your SQL 2K server, Start Menu->Microsoft SQL Server->Server Network Utility
Ensure "TCP/IP" protocal is in Enable protocols list

Let's try to figure out the problem cause first. :-)
0
 
palvinCommented:
Hi uzairp,
Please apply the SQL2000 service pack 4 patches. i will resolved your issue. i hit the problem before due with not apply SQL2000 patches
0

Featured Post

2018 Annual Membership Survey

Here at Experts Exchange, we strive to give members the best experience. Help us improve the site by taking this survey today! (Bonus: Be entered to win a great tech prize for participating!)

Tackle projects and never again get stuck behind a technical roadblock.
Join Now