Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17


SMS Advertisements not getting to client's

Posted on 2007-03-29
Medium Priority
Last Modified: 2013-11-21
Here is my senario. I am running Windows Server 2003, SMS 2003, and SQL 2000.
I am only running one server for everything. Everything was running fine
until last week. I was able to create packages, programs and advertise the
programs to clients and they would install fine. Last week I upgraded to
Windows Server 2003 Service Pack 2 and SMS Service Pack 2. Now I have created
a package to push out Quicktime upgrades and the package installs to the
distribution point but the advertisements never get pushed out to the
clients. The status viewer continues to show: 0 for received, failures,
programs started, programs success, etc. I am confused at what I am missing.

Question by:TKGreen
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
LVL 33

Expert Comment

ID: 18815195
I would be more suspect of Windows 2003 SP2 causing this problem.  I would start my troubleshooting by looking in the SMS administrator console.

Do you see any problems in the "System Status"?

I would guess that if you advertisements are showing 0 recieved that you Management Point is not functioning properly.  The Management Point is what gives policy information (like...hey, there is a new advertisement) to the client machines.

You can test you management poiint by start run --> (and paste this):

http://SMSSITESERVERNAMEHERE/sms_mp/.sms_aut?mplist     <enter>

(You should get a blank page in Internet Explorer if you MP is working)

http://SMSSITESERVERNAMEHERE/sms_mp/.sms_aut?mpcert     <enter>

(You should get a string of letters and numbers in IE if your MP is working)

I would also reboot the SMS server...and check for all SMS and SQL services that they are started.

Author Comment

ID: 18815610
I am getting error 5436 MP Control Manager detected MP is not responding to HTTP requests. The http error is 12152.
Neither one of the above links get me what I should see. I am getting "The Page cannot be displayed"

Author Comment

ID: 18815632
Also when I rebooted there were several services that didn't start.  SMS_SITE_COMPONENT_MANAGER, SMS_SERVER_LOCATOR_POINT, AND SMSAgent Host
Office 365 Training for IT Pros

Learn how to provision tenants, synchronize on-premise Active Directory, implement Single Sign-On, customize Office deployment, and protect your organization with eDiscovery and DLP policies.  Only from Platform Scholar.

LVL 33

Expert Comment

ID: 18815907
At least you are finding the problem....

Now, you will have to start going through logs...

MPcontrol.log is important in your case...  but there might be other clues in the other logs.  
LVL 33

Expert Comment

ID: 18815910

Author Comment

ID: 18817724
These are theerrors I am getting in the mpcontrol.log file:

Failed to receive http response. Error 12152
Http verification .sms_aut (port 80) failed with no header received

Author Comment

ID: 18835754
Nothing new. I found a blog telling me to reinstall the MP and IIS. I also have WSUS running on this server. If I reinstall IIS will it mess up my setting on my existing virtual directories?


Author Comment

ID: 18853834
Am going to reinstall the Server completely. Everything I have tried will not allow me to re-install the management point successfully.

Expert Comment

ID: 19565074
I had the same problem on a clients site. Ended up removing MP and ran ccmclean /all . Then reboot add the MP role back in and everything worked fine.

Author Comment

ID: 19565120
Thanks for the comments but I have already uninstaled and reinstalled and everything worked fine. The clients automatically picked back up without haveing to do anything.


Accepted Solution

Computer101 earned 0 total points
ID: 20355304
PAQed with points refunded (500)

EE Admin

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Welcome to my series of short tips on migrations. Whilst based on Microsoft migrations the same principles can be applied to any type of migration. My first tip Migration Tip #1 – Source Server Health can be found listed in my profile here: http:…
On July 14th 2015, Windows Server 2003 will become End of Support, leaving hundreds of thousands of servers around the world that still run this 12 year old operating system vulnerable and potentially out of compliance in many organisations around t…
Sometimes it takes a new vantage point, apart from our everyday security practices, to truly see our Active Directory (AD) vulnerabilities. We get used to implementing the same techniques and checking the same areas for a breach. This pattern can re…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question