motorola Q

I have exchange 2003 and want to configure it so a motorola Q can access the email from outside the office.  can you guys assist on the necessary steps to complete this action?
dtooth71Asked:
Who is Participating?
 
SembeeConnect With a Mentor Commented:
Sync using ActiveSync on a PC isn't really valid. The only internal sync that is valid is one that goes across the network. If you are using the emulator and are NOT docking the device with ActiveSync on the PC (So the device can browse the internet etc on its own) then that would be a valid test.
If that works, then a firewall would be something to look at as being the cause of the sync failures.

Simon.
0
 
LeeDerbyshireCommented:
This will show you how to set up Exchange Server ActiveSync:

http://direct.motorola.com/ENS/q-email-setup-activesync.asp?Country=USA&language=ENS&productid=30419

ignore the 'Desktop' part at the bottom.
0
 
dtooth71Author Commented:
I saw that thanks.  after entering the information about the exchagne server I press the sync button and get an error that reads; (this is after about 3-4 minutes)

the server could not be reached.  THis could be caused by temporary network conditions....
0
Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

 
dtooth71Author Commented:
support code 0x80072EFD
0
 
LeeDerbyshireCommented:
It sounds like it can't even reach the server.  You are doing this from the Internet, I guess?  If so, is there a firewall protecting your LAN?  Does it have ports 80 and 443 forwarded to your Exchange server?
0
 
dtooth71Author Commented:
ya, I agree.  surely there is a firewall.  it does however allow 80/443.....
0
 
LeeDerbyshireCommented:
Have a look in your Exchange Server's IIS Log (the most recent file in C:\Windows\System32\Logfiles\W3SVC1 ).  Can you see any requests going to Microsoft-Server-ActiveSync at around the time you last tried to sync (note that the logged times are in GMT)?
0
 
dtooth71Author Commented:
o I sure do  not.  I did a find and it did not find anything...
0
 
LeeDerbyshireCommented:
Can you reach OWA on this server from the Internet?
0
 
dtooth71Author Commented:
yes I sure can .  thoses logs I saw in the IIS log
0
 
dtooth71Author Commented:
I checked the SSL option on the Q and now I am getting a support code 0x80072F17
0
 
LeeDerbyshireCommented:
This:
http://www.pocketpcfaq.com/faqs/activesync/exchange_errors.php
suggests that you might have a wildcard SSL cert on the server.  Windows Mobile doesn't support wildcard SSL.
0
 
dtooth71Author Commented:
ok I will check that out.  now my status says
the security certificate on the server is invalid.  
0
 
dtooth71Author Commented:
I did not make any changes in IIS.  I do have a certificate on the server for rpc-http but this is a good certificate> I also verified on the exchange box in mobile device that the properties options were selected(by default). so this is good...
0
 
LeeDerbyshireCommented:
Is it a wilcard cert, though?  Is it issued in the name of *.yourdomain.com ?
0
 
dtooth71Author Commented:
ya, I was just reading this article you sent .  the certificate is issued by Equifax for the rpc-http is why I got this.  I am not sure how to determine if this is a wildcard cert or not.  not even sure what that means.  the certi is issued in the form of mail.domain.com
0
 
LeeDerbyshireCommented:
A wildcard cert means that you can use it to verify any computer in a domain, so it gets issued to *.domain.com .  It doesn't sound like that's what you have.

Equifax should be okay according to this:
http://support.microsoft.com/kb/915840

Although maybe Motorola didn't include it, for some reason.  See if you can use that KB article to add the cert yourself.
0
 
dtooth71Author Commented:
Ill give that a read.  I actually purchsed the cert through rapidssl.com but the issuer is Equifax? what do you make of that?>
0
 
LeeDerbyshireCommented:
RapidSSL owns the Equifax root, so that is okay.
0
 
dtooth71Author Commented:
man, that did not work either.  I saw equifax in the root certificate of the device so it was in there already.  I think I may call in/write to to q people????
0
 
LeeDerbyshireCommented:
For a quick test, try turning off the requirement for SSL on the MicroSoft-Server-ActiveSync VDir on the Exchange Server, and uncheck the SSL checkbox on the device.  Just to verify that it is definitely an SSL problem.  It sounds like it probably is, but AS isn't known for giving correct error descriptions.
0
 
SembeeCommented:
RapidSSL's root certificate is not in the Windows Mobile devices. You will have to import the root certificate in to the device yourself.

You can confirm this using OMA... if you browse to https://host.domain.com/oma and get a certificate prompt, then that is your problem.

There are a couple of ways of getting the certificate in to the device, I usually use the cabinet file method which I have here: http://www.amset.info/pocketpc/certificates.asp

Simon.
0
 
dtooth71Author Commented:
I just received word back from the motorola Q guys and they say that the rapidssl certi is not compatible and they are recomending purchasing one that is.    If I import the root cert into the device then it will be good you say>?

when I open OWA I do not see a certificate prompt, I do however have to use the https://
0
 
LeeDerbyshireCommented:
Importing it has to be worth a try, before buying something else.  I can't imagine that it is not really compatible.
0
 
dtooth71Author Commented:
ya, I hear ya and agree.  this guy is saying that imprting will not work and purchasing another certificate will be the only workable solution>??
0
 
LeeDerbyshireCommented:
That sounds really odd.  I would still try it, though, just to make sure that he actually knows this for sure.  Does he mean purchase another kind of cert from them?
0
 
SembeeCommented:
I haven't had any problems with importing the certificate via the cabinet file method. The root certificates on the Moto Q you will find are all the expensive ones. Verisign and the like.

Simon.
0
 
dtooth71Author Commented:
ya I took alook at those in there.  he wants me to buy a Geotrust cert.  this is one he says is compatible with teh Q.

simon, have you had luck with the rapidssl importing into the Q?
0
 
SembeeCommented:
The Q isn't available in the UK, so I haven't used it myself. However I have suggested it to others on this site and have been told that it works.

Simon.
0
 
dtooth71Author Commented:
I see.  I plan to try tomorrow, I will post back afterwards//
0
 
dtooth71Author Commented:
good day Simon/  when doing part three of you instructions, does it matter where the file is dropped on the Q ?  I saw yesterday when I hooked the device to a pc I was able to open what appeared to be the root drive. will this do or does this file need to be opened in a specific place/
0
 
SembeeCommented:
It doesn't matter where it goes, as you will be selecting it for installation. Once installed you can delete the cabinet file.

Simon.
0
 
dtooth71Author Commented:
ok cool.  I am going to test now.  will post back
0
 
dtooth71Author Commented:
so I opened the device on the pC and copy/pasted the file.cab to the device.  when I opened I just got a dialog box, it did not look like anyhting was installed and aI am still getting the cert error?? am I instaalling this incorrectly>
0
 
dtooth71Author Commented:
ok, I got it installed I was using the PC to attempt to install and not the device.  It installed and I can now view it in the root cert of the device.  Unfortunatley, I am still getting the cert error.....have you any more idea?
0
 
SembeeCommented:
If you browse to the site on https://host.domain.com/oma which element is causing the error?

Simon.
0
 
dtooth71Author Commented:
do you want me to browse here on a pc or the Q?
0
 
dtooth71Author Commented:
simon,  after looking into OMA a bit on google, this appears to be a config that needs to be done on exchange? is this correct?  If so I have not done this unless it is there by default.
0
 
dtooth71Author Commented:
thi si the error I get while typing in https://host.domain.com/oma

A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator

the event log on the server is MSExchangeOMA eventid 1503
0
 
SembeeCommented:
You need to do the test browsing on the device, doing it on the PC isn't much use.

If you are using a single Exchange server with SSL and forms based authentication then there is a change that needs to be made, either by following KB 817379 or my guide here: http://www.amset.info/exchange/mobile-85010014.asp

Simon.
0
 
dtooth71Author Commented:
ok, thanks.

when I browse from the Q I get a error; A system error has occured while processing your request. Please try again . If the problem persists, contact your administrator.

I do only have a single Exchange server.  it is set up for rpc-http /  SSL is configured, dont htink I have forms  based auth, how can I verif.  anyway I will take a look at the link and post back.
0
 
LeeDerbyshireCommented:
You can tell if you have FBA enabled if you see a blue login page, rather than the grey popup dialog, when you use OWA.
0
 
dtooth71Author Commented:
these changes listed above womt effect the workings of OWA or RPC-HTTP, or the workings of exchange  period will they?  I dont have forms based authetication.
0
 
LeeDerbyshireCommented:
Not sure which changes you mean.  Are you referring to the KB817379 article?  If so, then no, it won't affect your Exchange installation.
0
 
dtooth71Author Commented:
ok guys, I have completed the KB817379 article and now I am getting a active sync error 85010014.  have you had experience with this one?
0
 
LeeDerbyshireCommented:
Did you remove SSL from the Exchange VDir before you did it?  The article doesn't actually mention this, but A/S has to be working before you do follow it.  I assume you now have a VDir named exchange-oma ?  Make sure that SSL is not required on it.
0
 
dtooth71Author Commented:
heyu Lee..

I did not remove the SSL from exchange before I made the copy, but after I made the new dir in IIS, I removed the SSL in step 15 of the KB article.  A/S?
should I redo and remove prior to making the copy??
0
 
LeeDerbyshireConnect With a Mentor Commented:
A/S = ActiveSync.  Remember that the article is no use if ActiveSync was not working in the first place.  I would undo all the steps, and try to get it working with the normal Exchange VDir first, before adding the complication of the registry entry and the new VDir.
0
 
dtooth71Author Commented:
oh man, this was not working prior to me making the changes. man, I dont know what else to do here other than getting a new cert. and be done with it.
0
 
dtooth71Author Commented:
http://hardware.mcse.ms/archive35-2005-12-262517.html

what do you guys think about this?  I am getting the 3005 ActiveSync error in my server logs, but only after I made the KB change.
0
 
LeeDerbyshireCommented:
That describes how to remove the A/S VDir in ESM.  It's a safe enough to do, if you want to try it.
0
 
SembeeCommented:
I have inherited a few sites where it just hasn't worked.
What I have done is remove the registry key, then reset all of the virtual folders using this article:
http://support.microsoft.com/default.aspx?kbid=883380

Once that is done I then do 817379, but my own variant of it which I have outlined here: http://www.amset.info/exchange/mobile-85010014.asp

Simon.

0
 
dtooth71Author Commented:
I was able to sync "internally" but when I go outside it does not work.  Do you think that there is a firewall issue.
0
 
SembeeCommented:
How are you testing it internally? Connected to a PC?

Simon.
0
 
dtooth71Author Commented:
yes, I used my PC and synced (which I was unable to do prior to the KB) and I downloaded Microsofts emulator program.
0
 
dtooth71Author Commented:
I ended up purchasing another certificate that was compatible with the root of the mobile device.
http://www.geotrust.com/products/ssl_certificates/quick_ssl_premium.asp

after I out the cert in the Q sync'd immediatley.  thanks for all your ideas and assistance.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.