• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 260
  • Last Modified:

trouble sending file to ftp site

I'm having trouble with this ftp code, the files are not there.  Please help...
My login is anonymous and password must contain a valid email address

Send to: ftp://ftvmu1/VVG/jax/FTL
My file location is on a share directory: K:\\ftlgg01\dept\ftl\"PRogram1"

In the same location, I have a .scr (lextract.scr) file that contains the following:
cd VVG/jax/FTL
put K:\\ftlgg01\dept\ftl\"PRogram1"

In the same location, I have a .bat (fromshell.bat) file that contains the following:
ftp -s:c:\lextract.scr

I schedule a task to run the .bat file or just manually execute the file.

  • 3
  • 2
1 Solution
Alan Huseyin KayahanCommented:
           That ftp address looks incorrect. Have you ever made successfull connection or copy to that specified address?
Alan Huseyin KayahanCommented:
       If you map this ftp address as a drive to your computer, your script will work better/with minimum fault.

Its possible to configure a machine to map to a FTP server as a drive (for instance the Microsoft site) providing the machine runs both NetBEUI and TCP/IP. Perform the following:

Example below is for microsoft.com. You would change the values with yours and map the drive for your ftp.

Perform a NSLOOKUP for the FTP site, e.g.
nslookup ftp.microsoft.com
make a note of the IP address
Edit the LMHOSTS file (in %systemroot%\system32\drivers\etc)
Add line
<ip address> MicrosoftFTP #PRE
e.g. MicrosoftFTP #PRE
Save the file
Open a CMD.EXE session. Enter command:
nbtstat -R
This purges and reloads the name table cache
Type command:
net view \\MicrosoftFTP
You should see information on the site
Now map a drive (to share data)
net use * \\MicrosoftFTP\data /user:anonymous
All done. It will pass a drive letter for the connection
smcfarlaAuthor Commented:
i added this line in the lmhosts, i just put it where the other <ip> #PRE commands were.
I saved the file
I type net view \\MicrosoftFTP and got an error msg:
System error 53 has occurred
The network path was not found.

When i did the ip lookup i also got the server name...
Alan Huseyin KayahanCommented:
       Don't use Microsoft. It is just an example. Change them with your own settings.
smcfarlaAuthor Commented:
Now that i have the ip address, is there an easier way?  I'm getting the same error message when i try to net view \\ftsmur1
This is the section where i put the ip address (see where i typed <HERE>>>>>>>):

# The following example illustrates all of these extensions:
#     rhino         #PRE #DOM:networking  #net group's DC
#    "appname  \0x14"                    #special app server
#    popular            #PRE             #source server
#    localsrv           #PRE             #needed for the include
#          ftsmur1 #PRE <HERE>>>>>>>>>>
# #INCLUDE \\localsrv\public\lmhosts
# #INCLUDE \\rhino\public\lmhosts
# #INCLUDE \\ftsmur1\public\lmhosts <HERE>>>>>>>>>>
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now