Stuck at Applying Computer Settings

OKay,

So heres my problem, I have a user who's NIC is acting very strange:

Here is whats happening:

When the PC boots up, it gets stuck on the applying new settings screen, the only way to get around this, it to disconnect the network cable. Once the cable is out, the pc goes to the ctrl+Alt+Del. They sign on with the cable out, when we plug the cable in, it comes up with this error.

"Generic Host Process For Win32 services has encountered a problem, we are sorry for the inconvinience."

I went to services and realized that the following services were disabled and I had to start them again.
TCPIP
Workstation
Server
DHCP Client
I then went to release the ip then renew, it does not change, I can't get on the internet, knowone can contact  the machine. I can ping it ok, but thats it.

I took out the cable, restarted the pc - -logged in - - and the 4 services were turned off again.

I had them ping the server from that machine, and they were successful.

NE help would be greatly appreciated



thx

Dakeys
dakeysAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnb6767Commented:
start>run>cmd

Yank the NIc out of the device manager, and then do the following. Only the first   really applies to this solution, but it never hurts to reset the rest after the stack.....

netsh int ip reset reset.log
netsh winsock reset
netsh firewall reset

Hopefully this will give you a start.....
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
johnb6767Commented:
And of course the obvious, have you done a thorough scan with AV and spyware tools?
0
and235100Commented:
Do you get any errors in the event log?

If so - post them here.

Try this:

http://www.snapfiles.com/get/winsockxpfix.html

Do you have AV installed? If so - can you disable the auto-protect (or similar) service - and see if it happens at the next boot?
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

Alan Huseyin KayahanCommented:
           * Download and run winsock xp fix. And make sure that the "DNS!" server address specified in TCP/IP settings is working.
0
johnb6767Commented:
Just an FYI, the results of the winsockxpfix should have already been achieved with the "netsh winsock reset" command.

Rebuilds the Winsock2 key in the registry automatically, without the need for any downloads....
0
Alan Huseyin KayahanCommented:
            *I have personally encountered many issues that winsockxp utility fixed, while netsh winsock reset command couldn't or worked untill computer restart, in my network environment.
0
johnb6767Commented:
Was only adding more clarification for people that may not have known what it was, wasnt trying to step on your toes on the post....  :)

I have actually had a few instances where it broke things worse.....Sometimes they work, sometimes they dont.
0
and235100Commented:
I agree with jonb6767 (the netsh command should sort it) but - the winsockxpfix should only be used as a last resort. It is for advanced users only. (I know I suggested - but as with everything else - all advice given on this site is to be used at your own risk)

I must admit though - the winsock download has worked for me more times - even if the netsh command does more or less the same thing - it is just that for novice users the download is easier to apply than running the commands...

0
and235100Commented:
Sorry, misspelt - johnb6767
0
johnb6767Commented:
NP...    :)
0
dakeysAuthor Commented:
Thank you all for your responses.
I ended up doing the following:

I unplugged the cable from the network signed onto the machine then ran a system restore.
the 1st restore did not work so I had to go to an older date. Once I got a good restore the machine
booted up fine and I was able to get what I needed off the machine. Looks   like it was a virus. So I ended up backing up the data and just imaging over it.

thx again

Dakeys
0
DebinskiCommented:
I had three servers fail simultaneously last night. the cause is unknown. I would unplug the nic, and the machine would start up, plug the nic back in and the machine would hang.

My fix for all 3 servers was:

(Note: I've did steps 1 and 2 in "safe mode with networking" on a blade server where I could not unplug the nic)

1. Unplug the network from the nic and start normally
2. Set nic to DCHP (hopfully your network allows dhcp)(remember your static address)
3. Plug the network back into the nic
4. Right-click on nic icon and run "repair"
5. Reboot normally
6. Set IP address back to original static settings
7. Right-click on nic icon and run "repair"
8. Reboot. (just to make sure and test results)

Hope this helps somebody.

0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.