Can ping the server from the laptop but not the other way around.

I have a Windows 2003 Server and a laptop running Windows XP Pro.  From my laptop I can ping the Windows 2003 Server but from the Windows 2003 Server I cannot ping my laptop.  I have not set up any domains - the network is just a workgroup.
LVL 1
James CochraneB2B FINTECH WRITER/Technology WriterAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

LauraEHunterMVPCommented:
Is your laptop running Windows XP Service Pack 2?  If so, is the Windows Firewall enabled?  This will disable incoming ICMP (ping) traffic by default.  If that functionality is required for troubleshooting, you can enable it through the Windows Firewall Control Panel applet on your laptop - it's under the Advanced tab, I believe.

Hope this helps.

Laura E. Hunter - Microsoft MVP: Windows Server - Networking
0
theProfessaCommented:
Is Windows Firewall running by any chance?
0
James CochraneB2B FINTECH WRITER/Technology WriterAuthor Commented:
Windows Firewall was running so I turned it off completely (just for a test).  I am on a LinkSys router that is also a firewall but I don't remember making changes to allow or not allow machines.  I'll double check.
0
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

James CochraneB2B FINTECH WRITER/Technology WriterAuthor Commented:
Hi, there doesn't seem to be anything in the LinkSys firewall settings that would prevent the server from seeing the laptop.

Thanks
0
theProfessaCommented:
Also, so you don't run into this problem in the future, you said you were using W2K3.  If this is the case you can set a group policy setting to disable windows firewall from running

Here's a step by step:
Start - Run - type in "GPEDIT.MSC"
Expand the “Computer Configuration” section.
Expand the “Administrative Templates” section.
Expand the “Network” section.
Expand the “Networks Connections” section.
Expand the “Windows Firewall” section.
Select “DOMAIN PROFILE”
Double click the “Windows Firewall: Protect all network connections”
Select Disable

Hope this helps
0
johnb6767Commented:
Additionaly,

start>run>cmd

netsh firewall reset

just in case the firewall was corrupted....
0
romlopezCommented:
Not a good thing to disable the firewall ;)
0
romlopezCommented:
Windows Firewall -> Advanced -> ICMP -> "Check" Allow incoming echo request

Scripted version (If you want it to run on multiple machines):
netsh firewall set portopening protocol = TCP port = 445 name = "Ping" mode = ENABLE scope = subnet

GPO version:
Computer config -> Admin templates -> Network -> Network connections -> Windows firewall.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
LauraEHunterMVPCommented:
Agreed with RomLopez.  Temporarily disabling the WF as a troubleshooting step is one thing, but I wouldn't summarily turn it off under almost any circumstance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Server 2003

From novice to tech pro — start learning today.