computer can ping but not connect to web

Posted on 2007-03-29
Last Modified: 2008-02-10
A particular computer on the network can’t connect to the internet via Internet Explorer or FireFox. Tried a variety of websites with no luck. I am able to ping the websites from DOS, and even ping –a their IP’s to translate their host names, however the browser never connects to the pages. Windows Firewall is off and the settings obtained via DHCP to this computer are the same as other computers on the network that are working online with no problem.

I’ve ran full scans with Symantec AntiVirus and nothing found, ran ccleaner, ran ad-aware, ran spyboy, ran dell troubleshooting utilities and nothing. Tried repairing connection and nothing.

Every time it tries to connect to a website through Internet Explorer, it does indeed show the IP address in the status bar but then quickly changes and says “Connecting to” and never loads a web page.
Question by:jqsolara
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
  • 2
  • +6
LVL 70

Expert Comment

ID: 18820273
Check the IP settings. The Default Gateway should be set to your router. From your description I think tink this wll be ok I susoect your DNS settings are not correct. Perhaps the DNS server is set on the client rather than being allocated by DHCP. Check that the DNS server is set to point to your internal DNS Server.
LVL 66

Expert Comment

ID: 18820293

netsh winsock reset

Then reboot, and retest. Could easily be a corrupted Winsock catalogue.....

Author Comment

ID: 18820463
The DNS server is set to be obtained automatically like all the other systems. I also tried netsh winsock reset and a reboot but no luck there either
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

LVL 22

Accepted Solution

orangutang earned 500 total points
ID: 18821173

Expert Comment

ID: 18821689
Check in Internet Options that what is the proxy? If u r using proxy then check the correct address if not then uncheck it.

Expert Comment

ID: 18821831
What happens if you enter an IP address in your browser, such as ( If the web page appears when you do this, then the problem is with name resolution.

Expert Comment

ID: 18821876
Its a gud question frm Tree. Try in this way also.
LVL 22

Expert Comment

ID: 18821880
Well, if pinging the IP did work and it was a name resolution problem, how would you fix it?

Author Comment

ID: 18823194
yeah we tried entering the IP of sites it still never worked.

not sure what happened but the problem went away.

Expert Comment

ID: 18831228
Dear friend,

I had similler issue before. I disable all the activeX controls from internet explorer which are unknown, and remove all the additional toolbars solve the issue.

try the same way.


LVL 22

Expert Comment

ID: 18832537
Do you have Norton Internet Security? Try opening your control panel, double-click "Administrative Tools", double-click "Services", check to see if a service that sounds something like "Norton Network Proxy" is running. Or check your task manager for "ccProxy.exe".
LVL 17

Expert Comment

ID: 18849594
spyware doctor installed on your pc....?If yes then Uninstall and check for website browsing and you are using the IE7.0 ..? what is the O/S...?Can you try with static IP address and put the ISP DNS address or Internal DNs server local IP address.


LVL 66

Expert Comment

ID: 18850583
Also, if it is IE7, there is an option to reset IE...

IE>Tools>Options>Programs(pretty sure it is programs but it is the second tab from the right) Reset

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Public DNS  Vs BGP 20 77
Round robin for Exchange 2013 4 53
What is a standalone domain controller? 8 52
DNS issue. Can't add a server to a domain 23 203
It is only natural that we all want our PCs to be in good working order, improved system performance, so that is exactly how programs are advertised to entice. They say things like:            •      PC crashes? Get registry cleaner to repair it!    …
I've written instructions for one router type, but this principle may be useful for others of the same brand and even other brands of router. Problem: I had an issue especially with mobile devices that refused to use DNS information supplied via…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…
Exchange organizations may use the Journaling Agent of the Transport Service to archive messages going through Exchange. However, if the Transport Service is integrated with some email content management application (such as an antispam), the admini…

732 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question