Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Setup cisco soho dhcp, connect to broadband device

Posted on 2007-03-30
6
Medium Priority
?
513 Views
Last Modified: 2013-12-14
I have a cisco soho 91. It has 2 interfaces, e1 is the outside ethernet port, e0 is the inside ethernet "port" that is actually an inline 4 port switch. I need to configure the device to have e1 receieve it's ip address via dhcp, I'll be testing with a verizon ev-do router, but I'll want to use it with a cable modem as well. I need e0 to hand out dhcp to the 4 clients that will be connecting to it, and have them be able to access the internet. the config I have so far is this, but it can be easily changed:

version 12.3
service config
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip subnet-zero
!
no crypto isakmp enable
!
interface Ethernet0
 no ip address
!
interface Ethernet1
 ip address dhcp
 duplex auto
!
ip classless
ip http server
no ip http secure-server
!
control-plane
!
line con 0
 no modem enable
 transport preferred all
 transport output all
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
!
end

A show version gives me this:

Cisco IOS Software, SOHO91 Software (SOHO91-K9OY6-M), Version 12.3(7)T1, RELEASE SOFTWARE (fc2)
Compiled Thu 22-Apr-04 09:59 by eaarmas
ROM: System Bootstrap, Version 12.2(8r)YN, RELEASE SOFTWARE (fc1)
System returned to ROM by power-on
System image file is "flash:soho91-k9oy6-mz.123-7.T1.bin"
Cisco SOHO91 (MPC857DSL) processor (revision 0x300) with 29492K/3276K bytes of memory.
Processor board ID AMB08190SEX (3569983407), with hardware revision 0000
CPU rev number 7
2 Ethernet interfaces
128K bytes of NVRAM.
8192K bytes of processor board System flash (Read/Write)
2048K bytes of processor board Web flash (Read/Write)
Configuration register is 0x2102

The router is getting it's ip through dhcp, for e1, but I can't ping anything. If I use the same connecting device connected directly to my laptop, I can ping and have internet access. I'm not sure how to setup e0 to hand out dhcp. Let me know if you need any other info. I've tried a few cisco doc's, but couldn't get it working, so I'm starting from scratch...
0
Comment
Question by:ptuttle1319
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
6 Comments
 

Author Comment

by:ptuttle1319
ID: 18823323
I've added the following commands. It looks like dhcp is handing out address to the clients now. Now I just need the outside interface to get it's ip through dhcp, and also, the inside clients will need access to the outside...

ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool insidehosts
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 4.2.2.1 4.2.2.2

interface Ethernet0
 ip address 10.10.10.1 255.255.255.0

service dhcp
0
 
LVL 10

Accepted Solution

by:
Sorenson earned 2000 total points
ID: 18823336
If the outside already gets an address (e1), you need to add a route to show it how to get to the internet, add an address to the inside (e0) and configure a dhcp pool for it.  The configure nat translation to allow the internal addresses to hide behind the external addresses.


!
ip route 0.0.0.0 0.0.0.0 ethernet1
!
int e1
 ip nat outside
!
int e0
 ip address 192.168.100.1 255.255.255.0
 ip nat inside
 no shut
!
access-list 1 permit 192.168.100.0 0.0.0.255
ip nat inside source list 1 interface Ethernet1 overload
!
service dhcp
ip dhcp excluded-address 192.168.100.1
ip dhcp pool dhcpaddr
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
dns-server x.x.x.x x.x.x.x
!

0
 
LVL 10

Expert Comment

by:Sorenson
ID: 18823345
didn't see your reply.

Looks like you just need the default route and the nat commands.

0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 

Author Comment

by:ptuttle1319
ID: 18823568
That worked, thanks Sorenson!
0
 
LVL 10

Expert Comment

by:Sorenson
ID: 18823584
no problem / have a great day
0
 

Author Comment

by:ptuttle1319
ID: 18823591
Here's the final config, if anyone is interested....

version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip subnet-zero
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool insidehosts
   network 10.10.10.0 255.255.255.0
   default-router 10.10.10.1
   dns-server 4.2.2.1 4.2.2.2
!
no crypto isakmp enable
!
interface Ethernet0
 ip address 10.10.10.1 255.255.255.0
 ip nat inside
!
interface Ethernet1
 ip address dhcp
 ip nat outside
 duplex auto
!
ip classless
ip http server
no ip http secure-server
ip nat inside source list 1 interface Ethernet1 overload
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
control-plane
!
line con 0
 no modem enable
 transport preferred all
 transport output all
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
!
end
0

Featured Post

Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In the world of WAN, QoS is a pretty important topic for most, if not all, networks. Some WAN technologies have QoS mechanisms built in, but others, such as some L2 WAN's, don't have QoS control in the provider cloud.
How to set-up an On Demand, IPSec, Site to SIte, VPN from a Draytek Vigor Router to a Cyberoam UTM Appliance. A concise guide to the settings required on both devices
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

618 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question