Exchange RCP over HTTP not able to connect.

I am trying to get RPC over HTTP working with Microsoft Exchange 2003.  When I connect from the LAN (using the Exchange Server's public address) it works fine.  As soon as I leave the public network, I get the following error:

"The Exchange server is unavailable."

I am running my own Certificate Authority, and requiring SSL to the server.  I have installed the certificate in the "Trusted Certificate Authorities" store, and no longer get the certificate warning when browsing to OWA.

Any help greatly appreciated.
climberboyAsked:
Who is Participating?
 
SembeeCommented:
I strongly suggest using a commercial certificate rather than a home grown certificate. With commercial certificates I can have RPC over HTTPS working in less than 30 minutes without fail. With home grown certificates I have struggled for hour, or had clients struggle for hours.

Are you sure that it is working inside? It can appear to be working, but what has really happened is that Outlook has failed back to TCP/IP connections.

Make sure that you have met the requirements (Exchange 2003 or higher on Windows 2003 with at least one Windows 2003 GC/DC. Clients need to be Windows XP Sp2 with Outlook 2003 or higher).

Normally it comes down to registry entries - there are various versions of this, my version is at http://www.amset.info/exchange/rpc-http.asp

Simon.
0
 
climberboyAuthor Commented:
Sembee,

This is a tough nut to crack.  I may have to take your advice on the certificate.  First and foremost, yes, it is failing back over to the TCP/IP connection, per the /rpcgiag startup switch mentioned on your site (thanks!).  So it isn't working, period.

However, the rpcping utility shows a good connection with no errors.

The certificate is installed and trusted on the test client machine.  If I browse to OWA on the server, I no longer get a certificate warning, so my gut says that isn't the problem, but then that may be why I am stuck.

Can I provide you a Remote Desktop login to an email address and let you peek around on the two exchange servers?  I see how helpful you have been to everyone, and feel comfortable that you are not going to destroy anything.

Thanks,

Eric.
0
 
climberboyAuthor Commented:
Oh yea... I tried the registry entries on your site, to no avail.  Something else is at work.  I'm at a loss as to what.

Growing pains...
0
 
SembeeCommented:
Using tools outside of the site is not allowed under the rules.

I would suggest that you reset the process.
Remove the RPC Proxy element from add/remove programs and then delete the /rpc and /rpc-with-cert virtual directories from iis manager.
Then drop in to a command prompt and type

iisreset

Then put it back in again and do the registry settings.
If you want to try with the commercial certificate then get a trial certificate from RapidSSL before paying out for the full certificate.

Simon.
0
 
climberboyAuthor Commented:
Still working on this as other items took priority.  I will keep you posted...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.