How do I share files on network without requiring other computers to enter username and password

I have 4 computers on a network all setup with basic sharing.  I have a desktop and wireless notebook with vista.  I have a desktop and notebook with xp.  I want the xp desktop to share it's folders and it does however it requires the other three computer to enter a username and password.  The xp desktop can access all the other computers without anyproblems.  All of the computers can share with each other without anyproblems.  The xp desktop share permissions are set up to share with everyone to do everything.  HELP!!!!!!! I have never encountered anything this bizarie and would greatly appreciate a genius right now.  thanks.
jhunker1878Asked:
Who is Participating?
 
r-kConnect With a Mentor Commented:
Good luck. You could try that option of "different user name" just because it takes a few seconds....

 I suspect there is a Registry Entry on the XP computer that is blocking file sharing, but I can't recall which one.

Reinstall should fix it.
0
 
pkutterCommented:
On the computer that you are sharing from you need to add the users from the other computers with the exact same passwords. then it should work just fine.
0
 
Nick DennyCommented:
To elaborate on pkutter's post, add a common user on all machines with a password.
You do not have to be logged in as this user so long as it exists on all PC's.
Then use these credentials in the password info.

Also, beware of sharing everything if you have an internet connection.

If you are using the "everyone" setting, limit the shares to directories you actually want to share.
0
SMB Security Just Got a Layer Stronger

WatchGuard acquires Percipient Networks to extend protection to the DNS layer, further increasing the value of Total Security Suite.  Learn more about what this means for you and how you can improve your security with WatchGuard today!

 
jhunker1878Author Commented:
well how do you add the user?  do you add it useing the standard account setup.  or do you go into the administrator tools and add the user there.  i have never had this problem before and can't understand why this particular computer is choosing to do this...
0
 
Nick DennyCommented:
Control Panel > User Accounts > Add user
0
 
jhunker1878Author Commented:
all the user names on all 4 computer are named "E.D. Woods Lumber Co"  and all have the same generic password.  For some reason the xp is the only one that isn't cooperating.  
0
 
jhunker1878Author Commented:
I have checked all the users and given all access to all permissions and user names ect.  the only thing i can think to do now is to completly format and reinstall windows on the desktop.  
0
 
jhunker1878Author Commented:
those options have worked in the past however for some reason or another it is not responding to any of them.  This is the second time i am going to have to format and reinstall windows in order to try and fix this problem unless someone can suggest another solution.  
0
 
pkutterCommented:
XP home (I assume) is horrible for doing this, and doesn't have the computer management > users control panel (which is a little more advanced) like XP Pro. If you setup the account and then change the password, and probably a few other things that  I haven't been able to determine yet then this happens. You could try creating  a new user and password on another computer and the main computer and test it. If you install Pro on the main computer this may make it a little easier (it would be much more preferable if all were pro).
0
 
r-kCommented:
You should not need to reinstall Windows to fix this problem. Can you clarify whether you have XP Home or XP Pro?

Are you trying to share an entire drive, or a specific folder?
0
 
Michael FrederickRegional IT Manager IIICommented:
Just a question, but do you have the firewall on the XP machine turned on?
0
 
jhunker1878Author Commented:
The firewall is turned off and im just trying to share my shared documents and my documents
0
 
jhunker1878Author Commented:
also i have xp pro
0
 
jhunker1878Author Commented:
I have set it up to share with everyone and i have even set up specific accounts which work however when I restart the computers i must re-enter the username and password
0
 
Michael FrederickRegional IT Manager IIICommented:
What do you mean you have to re-enter the username and password? You get a login screen after windows starts or the users that you have created are gone and you have to re-create them.

0
 
r-kCommented:
I would suggest the following:

On the XP Pro machine (I assume this is the one you're having trouble connecting to):

 Windows Explorer (or My Computer) -> Tools -> Folder Options -> View
Scroll down the list and un-check "Use Simple File Sharing"
Click OK etc. and see if you are now able to connect from the other machines.

As already suggested, log-in on the other machines with an account that has the same name/password on the XP machine.
0
 
jhunker1878Author Commented:
I have done this and every computer has the same name and password to get into windows.  I have already un-checked simple file sharing.  

Tekwazoo-  when i look at the computers on my network i can see the xp-pro desktop however when i double-click on it to see it's shared documents it asks for a user name and password to gain access.  
0
 
Michael FrederickRegional IT Manager IIICommented:
You are lactualy loging in to everymachine with the same username /password. Not just adding the user name/password to everymachine, but you are logged in?
0
 
jhunker1878Author Commented:
TEKWAZOO:  yes

I am now getting a message saying
"DPEEK is not accessible...you may not have permission to use this network resource."
"Logon failure user has not been granted the requested logon type at this computer"

I'm no genius but im no idiot either.  this is a very bizare problem and have never had this problem before.
Thoretically i should be able to run the network wizard share it under the same workgroup and then when shareing the folders under "permissions" i would make sure that the users im shareing to are "everyone" and then give them full access.  

Maybe there is a corrupt file or something.  is there a way to rebiuld the network setup on the xp-pro desktop?  without running some windows repair or reinstallation
0
 
Michael FrederickRegional IT Manager IIICommented:
You are correct, from what everything that you are telling us, it should work. I hate the wizards, I end up having more problems with them then without. If I can avoid using the wizard, I do. As far as rebuilding the network modules, you rebuild the IP stack, but that would only help if it was an IP issue.

I know you are frustrated, and we know your not an idiot. It is most likely an MS issue that we need to figure out.

You said earlier that you might rebuild this machine again. Did this problem haooen before and you rebuilt it hoping it would solve the problem, but after the rebuild you still had the problem?
0
 
r-kCommented:
How are you trying to connect to the shared folder on the XP machine?

Try the following (from one of the other machines):

 Windows Explorer (or My computer) -> Tools -> Map network Drive
 In the "Folder" field type in \\DPEEK\share-name
 then click Finish
 (where DPEEK is the name of the XP machine, and share-name is the share name you gave to the folder that is shared on the XP machine.

Does that work?
0
 
jhunker1878Author Commented:
no sorry... It seem as though now I have done something now that would keep me from even getting the user name and password prompt it keeps giving me the...

"DPEEK is not accessible...you may not have permission to use this network resource."
"Logon failure user has not been granted the requested logon type at this computer"
0
 
r-kCommented:
Check this (on the DPEEK XP computer):

Start Regedit, then browse to:

 HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

Look for the item named "restrictanonymous" and make sure its value is set to 0 (zero).
0
 
r-kCommented:
Also, while in the "Map Network Drive" dialog, you can click on the "different user name" link and specify the username/password on the XP computer explicitly.
0
 
jhunker1878Author Commented:
r-k           yea restrictanonymous is set to 0
0
 
jhunker1878Author Commented:
well i think im out of time...i have got to have this computer ready by tomorrow so it looks like I have to reinstall windows in a last desperation move to fix this problem.  if that doesn't work then i know its the router setup or the account setup on the other computers.  thanks for all yalls help
0
 
jhunker1878Author Commented:
holy hell that worked
0
 
jhunker1878Author Commented:
I changed the name to login to windows and it works now no sweat!!!!

You just gave me a goods night sleep.
0
 
r-kCommented:
Excellent! Very glad it worked. Possibly the non-standard username may have something to do with it....
0
 
jhunker1878Author Commented:
yea thanks alot
0
All Courses

From novice to tech pro — start learning today.