Local Smartphone sync with Exchange using Activesync

A client is running SBS 2003 with Exchange.  We are trying to sync his Smartphone with activesync.  I keep getting in a loop with the server saying it is not available, then it will say the cert names do not match.

The user does not have data service on his phone and attempting to sync through USB.  The exchange server is used only for internal messaging and calendaring.  At this time no outside access is available.  From another machine I have tested OMA by going to http://servername/oma and it works perfectly.

All I need is a local sync. I am sure I will have to provide more details, I will not be back on the client site until next week, but any assistance to get me a head start would be appreciated.  Blackberrys are so much easier.
jbmos2333Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

czcdctCommented:
Blackberry's aren't any easier, in fact they can be between 16 and 40 times worse (trust me)
Doing what you want is a bit of a pain but the part about the certificate names is interesting at the moment. Does the name on the certificate actually match the URL you're using? IIRC the SBS installs a self signed cert so unless you have done it you won't have the certificate on the device so it's not going to sync.

Best thing to do at the moment is to untick the SSL whilst you're testing inside the network.
0
jbmos2333Author Commented:
I did initially uncheck using SSL. That was what I was hoping to do.  Then I recieve the user does not have appropriate permissions.  Research here led me to believe that SSL was absolutely necessary.

0
czcdctCommented:
You don't need to SSL secure it. It's a Mobile thing rather than an Exchange thing on its own so I'll try and drag through my favourites for you to get the URL you need.
0
jbmos2333Author Commented:
I appreciate the help.
0
SembeeCommented:
You should be using SSL if you are going to sync over the air, otherwise your usernames and password will be sent in the clear.
If you don't have data service and want to use local sync then simply change the configuration in ActiveSync to use Outlook rather than an Exchange server.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Peripherals

From novice to tech pro — start learning today.