Windows 2003 domain can't ping host names in Windows 2000 domain

I have a Windows 2003 domain trying to ping hosts in a Windows 2000 domain (2 different forests) My goal is  talk to the old domain using non FQDN host names.  Do not want WINS.  I can ping successfully when using the FQDN.  I can also perform an nslookup using the non FQDN host name.  I can not ping and client machines in the new domain can not talk to applications servers in the old domain.   How do I talk to the old domain using non FQDN host names then?  Under Windows 2003 DNS we have configured Conditional Forwarding to the old domain.   Also  tried adding the old domain as a secondary forward lookup zone.  On the Windows 2000 DNS have a delegation record for the new domain.  Tried adding the new domain as a secondary zone on the old domain as well.  This is a migration that might take a while.  
Who is Participating?
LauraEHunterMVPConnect With a Mentor Commented:
If I understand you correctly, you have a 2003 forest (let's call it and a 2000 forest (let's call it From a machine in the forest, you want to be able to ping by simply issuing the command "ping server1"?  Have I understood your question correctly?

If so, you need to add "" to the DNS suffix search list of your clients in the forest. You can do this via Group Policy under Administrative Templates\Network\DNS Client\DNS Suffix Search List .

What this will do is as follows:

[1] User types "ping server1"
[2] Workstation will first attempt to resolve "", since is the DNS suffix of the workstation itself.
[3] If does not respond, workstation will then attempt to ping ""

(You can see how having a "" and a "" would present inconsistent behaviour.  A WINS server would enforce uniqueness of these "single-label" names across both forests; if you do not wish to use WINS as you've stated, enforcing the uniqueness of these names will be something you will need to handle manually/procedurally.)

If I have misunderstood your question, please re-state and/or provide additional details so that I can attempt to help you resolve your issue.

Hope this helps.

Laura E. Hunter - Microsoft MVP: Windows Server - Networking
rlmethodAuthor Commented:
Well, just before you replied we did some more testing.  We are using the GPO to set the suffix search order and there is something wrong there.  We turned off the GPO and added the entries manually.  Now everything works.  LOL.  We'll take another look at the GPO next.  THANK YOU FOR YOUR REPLY!!
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.