• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 815
  • Last Modified:

After enabling Windows Firewall on XP, I can no longer force a remote shutdown using PSSHUTDOWN.

After enabling Windows Firewall on XP, I can no longer force a remote shutdown using PSSHUTDOWN. The message I receive is:
"If COMPUTER NAME is already performing a shutdown operation you must
abort it before issuing a different command.". After disabling WF, no problems.
Not sure if PSSHUTDOWN uses a specific port, or which exception I should include.
Thanks,
Chris
0
qwert5905
Asked:
qwert5905
2 Solutions
 
r-kCommented:
I would think you need to open port 445 on the remote machine.
0
 
LeviDailyCommented:
Or dont use Windows XP Firewall....
0
 
bikvi_sibroCommented:
You could also use the shutdown command.  Just go to Start>Run, type in "cmd" and hit enter.  When in the command prompt, type in "shutdown -f -m \\computername".

Here is a link to find out more about it: http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/shutdown.mspx?mfr=true
0
 
Alan Huseyin KayahanCommented:
           *Start>Settings>Cotrol Panel.
            *Locate Windows Firewall and double-click it.
            *Click exceptions tab
             *Click add port. Write shtdwn to name and 445 to TCP port. Then add the value
            *Click add program, then click browse. Locate the psshutdown.exe and shutdown.exe (usually %windir%\system32\shutdown.exe) in your computer and then click ok.
            *Restart the Windows Firewall service in services. (Start>Run>services.msc)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now