Solved

Use multiple DSL circuits on the same network

Posted on 2007-04-01
3
469 Views
Last Modified: 2012-06-27
I have a probably simple networking question for those individuals who are Cisco experts.  From my initial Internet research, I know most everyone's first solution to this will be to buy a device that allows me to plug two ADSL circuits into it and share them equally.  I stress, BUYING NEW EQUIPMENT IS NOT AN OPTION FOR ME.

I am going to install a LAN that provides ADSL service to approximately 100 people.  There is no fiber going between the ISP and the MDF where the ADSL circuits will be terminated in.  

Unfortunately, this limits us to home circuits that the ISP recommends for no more than 5 people.  One good thing, however, is that I can get 6 of these home ADSL circuits to the building with the LAN.  Realistically, each circuit should be able to service 15-20 people adequately so bandwidth should not be an issue using all 6 circuits.

Each user must be on the same network to facilitate a web application and printing.  The ADSL circuits are evenly distributed on the 4 walls of the building (it’s an open gym) and I can use as many switches as I need to for the LAN drops.  The ADSL routers provide the DHCP for the clients.  Each ADSL router defaults to a 192.168.0.X/24 subnet with the ADSL router being the gateway.  Essentially it gives this configuration:

IP Address <RANGE> 192.168.0.2 - 192.168.0.33
Subnet 255.255.255.0
Gateway 192.168.0.1 <ADSL ROUTER>
DNS Server - 192.168.0.1 <ADSL ROUTER>

I have pretty new Cisco equipment and can bring a 3700 series router (2 FastEthernet ports) and 3750 Layer 3 switches to provide LAN connectivity to the users.  (I could also bring a 6509 if this equipment does not cut it.

Here is my plan.  Leave one ADSL router with the default subnet.  Change the configuration of the other 5 routers to different subnets.  (Each DHCP range will be changed accordingly like the 192.168.1.X example below):

192.168.1.X/24 DHCP <RANGE> (192.168.1.2 - 192.168.1.33)
192.168.2.X/24                                        
192.168.3.X/24
192.168.4.X/24
192.168.5.X/24

Each router will service a section of the building.  However, each switch from each subnet will be connected.  I will put a router on the network to route between these subnets in order to facilitate the web application and printing mentioned above.  

Question 1:  Is this a good plan?

Question 2:  If this IS a good plan, then how should I configure the router?  I’m guessing I need to use router on a stick since I only have 2 FastEthernet ports on the router?

Question 3:  Was I smoking crack when I came up with this plan?  If so, can someone suggest a better setup?

Thanks,
0
Comment
Question by:jettaboy71
  • 2
3 Comments
 
LVL 79

Expert Comment

by:lrmoore
ID: 18831702
1. It can work.
2. If you have a 3750, you don't need a router. What you need to do is setup vlans on the switches with each group on their own VLAN with their own DSL router. The 3750 switch VLAN IP would be the default gateway, not the dsl router. The 3750 can be the DHCP server for each vlan also. This gives you the flexibility to designate the gateway IP where the dsl router may only provide itslef as the gateway.
Depending on the DSL routers, you might be able to use a dynamic routing protocol like RIP between them and the 3750 switch and then you can use the dsl routers as dhcp and gateway.

3. You have to do what you have to do...
0
 

Author Comment

by:jettaboy71
ID: 18831784
All right.  Thanks for the quick response.  I figured VLAN's would also fit into the equation somehow.  Just one quick question.

What is the command on the 3750 to set it up as a DHCP server?  I have scoured the Internet and could not find any 3750 DHCP instructions other than how to set it up as a DHCP forwarder.
0
 
LVL 79

Accepted Solution

by:
lrmoore earned 125 total points
ID: 18832070
3750 DHCP server config is same as a router.
Example:
interface vlan1
  ip address 192.168.0.2
!
  ip dhcp pool VLAN1
   network 192.168.0.0 /24
   domain-name <domain>
   dns-server 192.168.0.xx
   default-router 192.168.0.2
!
interface vlan2
 ip address 192.168.1.2
ip dhcp pool VLAN2
 network 192.168.1.0 /24
 domain-name <domain>
 dns-server 192.168.0.xx
 default-router 192.168.1.2

access-list 101 permit ip 192.168.0.0 0.0.0.255 any
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 103 permit ip 192.168.2.0 0.0.0.255 any
route-map yourmap permit 10
 match address 101
 set ip default next-hop 192.168.0.1  <== dsl router
route-map yourmap permit 20
 match address 102
 set ip default next-hop 192.168.1.1  <== dsl router
route-map yourmap permit 30
 match address 103
 set ip default next-hop 192.168.2.1

ip local policy route-map yourmap


0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

This article is a step by step guide on how to create a basic PTP link using Ubiquiti airOS devices. This guide can be used on the following Ubiquiti AirMAX devices. Nanostation, Bullets, AirBridge, Nanobeam, NanoBridge to name a few. Please review …
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
In this tutorial you'll learn about bandwidth monitoring with flows and packet sniffing with our network monitoring solution PRTG Network Monitor (https://www.paessler.com/prtg). If you're interested in additional methods for monitoring bandwidt…

746 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

8 Experts available now in Live!

Get 1:1 Help Now