Running Xwindows on remote machine through firewall using VPN

I have a Suse 10.2 machine running on my company's network.  I access the company's network using Cisco VPN client from my Windows based computer at home.  I use Putty (ssh client) and Xming (free xhost server) on my computer at home.  

I want to run x-windows applications on my work computer and display them on my home computer.  Here is what I do (1) VPN into corporate network (2) use PUTTY to ssh into machine (3) load Xming and disable access control (4) run "export DISPLAY=XXX.XXX.XXX.XXX:0.0  (5) then I run "xemacs test.xt".  

The windows never appears on my home computer, and there are no error message .  I do not have this problem when I use a Linux machine on my home network.  Any suggestions?  I have a feeling it has something to do with VPN.  

Thank you for any help!
cs76737Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

PowerITCommented:
Does the VPN concentrator have the necessary port open to the internal network or the suse machine?
- TCP & UDP 6000 and up (each time one higher for each additional display)
- TCP & UDP 177 for XDCMP
Also, are those ports open on the Suse box itself?
Is remote display manager enabled on the Suse box? I know I had to do this on our suse 9.2 boxes. It's hidden deep in Yast. See: http://linuxplanet.com/linuxplanet/reviews/5679/5/screenshot3183/

J.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
slyongCommented:
Hi cs76737,

Try this:
(1) VPN into corporate network
(2) Run Xming uisng this command: "C:\Program Files\Xming\Xming.exe" :0 -clipboard -multiwindow
(3) In the main configuration window of Putty (you get it when you start Putty), select Connection section, then SSH, then X11, and make sure you tick the Enable X11 Forwarding option.
(4) Run "xemacs test.txt"

Reference: http://solaris.reys.net/english/2006/04/x11_forwarding
0
cs76737Author Commented:
I was traveling last week, so I apologize for delay.  Will try first thing tomorrow.
0
Do You Have a Trusted Wireless Environment?

A Trusted Wireless Environment is a framework for building a complete Wi-Fi network that is fast, easy to manage, and secure.

cs76737Author Commented:
I tried the suggestion for slyong, and it still does not work.  Any other ideas?
0
slyongCommented:
hmm.. those instruction should get it going.  When you start some program (e.g. xclock) what does it say?
0
cs76737Author Commented:
I execute xclock on the remote machine.  The xclock window just never appears on my machine.  Eventually the process on the remote machine fails.
0
slyongCommented:
can do you:

$ echo $DISPLAY

and see what it say?
0
cs76737Author Commented:
I just tried your instructions on a machine at home.  They work.  I VPN into the work machine, and it doesn't work.  I followed the link you sent, and I made sure that /etc/ssh/sshd_config has X11forwarding enabled.  Do not understand why it isn't working!
0
cs76737Author Commented:
When I do printenv DISPLAY, it shows "localhost:10.0" or something like that.  It says the same thing on the machine at home (where the process works) and the machine at work (where it fails).
0
slyongCommented:
Hi,

The $DISPLAY is correct.  I am not sure why your office machine is not working.  This method uses standard ssh x-forwarding.  So as long as you can reach a machine using ssh (port 22) it should work.  When you run xclock, the fact that is doesn't complaint about "cannot find display" (or something like that), the x-forwarding should be working.

However, I am not sure why it failed.  Another thing is that if you connect and check the netstat, it should show something like:

tcp        0      0 localhost:x11-ssh-offset    *:*                         LISTEN      -                  
0
gheistCommented:
Use "xdpyinfo" instead of xclock.

That will show display server attributes and diagnostics without even showing a window.

0
cs76737Author Commented:
Problem is not solved, but I am convinced that it is specific to my corporate network.  I've tested solutions by PowerIT and slyong on other networks, and they work fine.  Since their solutions work in theory and I am not getting more replies, I am closing the ticket and splitting points.  
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.