Solved

BSODs, crashing. Baldness.

Posted on 2007-04-01
32
874 Views
Last Modified: 2008-01-09
Having an issue with my computer, not entirely sure what is the cause.
This has been a long reoccuring issue, so I can't remember what exactly what would have sparked it, but there have not been any hardware upgrades made recently.

I'm getting BSOD's and crashing almost constantly. It doesn't occur when i use a particular program, as it seems to stop on me whilst idle, using games or another apps.

The primary BSOD error message is: IRQl IS NOT LESS OR EQUAL.
Doing a bit of research i found this problem is usually linked to RAM or video cards. Reseated RAM chips, replaced them, removed video card etc. Same problem persists.

Went to the memory dump and it said that a file named ntoskrnl.exe was to blame. Replaced this from another computer yet there was no change. Tried loading up the windows recovery console, but I constantly get another BSOD with the error message BAD_POOL_HEADER.

Can I get a little help, as i'm losing all my hair over this one!
0
Comment
Question by:UltHybrid
  • 11
  • 11
  • 3
  • +3
32 Comments
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18834292
IRQL is usually indicative of a driver issue.  Have you installed or updated any drivers recently?  Particularly with respect to your game or video card?

You will probably want to run an sfc /scannow to replace the ntoskrnl file...

Reboot to safe mode, insert your WinXP Cd, from a command prompt run "sfc /scannow"
0
 

Author Comment

by:UltHybrid
ID: 18834368
No, I haven't.

The only driver changes i've made were after these errors occured when i found out that they might be related to my video card. I tried updating my drivers and using previous ones, all to no avail.

For some reason, I cannot enter safe mode. After selecting Safe Mode from the advanced startup screen, the screen fills up with lines like : multi(0)partiton(1)c:\windows\system32\ntoskrnl.exe. but these can also reference different files from the same folder.

I attempted running that command in normal mode, where a progress bar filled up, but simply exited without prompting or making any changes.
0
 
LVL 3

Expert Comment

by:TheTechGuysNYC
ID: 18834383
Read:

Warning! Side affects of computer misuse include insomnia, loss of appetite, BALDNESS, and incredible amounts of diarrhea.

But I digress.

IRQL can also be an indication of bad hardware and considering that you have upgraded recently, that could be an issue.

www.memtest86.com and test your ram Sam.

How many sticks of Ram? Can you test one at a time? Can you test the different slots?

It can also be the video drivers. Try uninstall and reinstall from safe mode. I have also seen cases where the video driver and a Joystick were conflicting. Or at least the possiblity existed.

These are a few possiblities, in respective order of relevance.
0
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18834384
Hmmm.. interesting.  It usually just runs and exit without prompting or saying anything (kind of weird).  Are you still having the BSOD?  Can you post the entire contents of the STOP code?  Should help in debugging.
0
 

Author Comment

by:UltHybrid
ID: 18834409
TechGuys:

Heh. Well its causing Baldness in my case.
I've run several memory tests, and verified on other computers that these ram chips are working. (No hardware upgrades)
2 Sticks of ram, both tested. Also have spares, tried those. Same problem.
Have also tried uninstalling, reinstalling, updating, rolling back, physically removing video card etc.

I think its safe to say neither the RAM or video card are the culprits here.

Anthony:

Yes, the BSOD is still occuring. Must have 100 or so minidumps stored, just waiting for the next BSOD where i'll jot the code down.

Appreciate the help guys.

0
 

Author Comment

by:UltHybrid
ID: 18834451
Code from my last BSOD was: 0x0000000A (0xFFFE8080, 0x00000002, 0x00000001, 0x806EE2DC)
0
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18835813
Have you tries using LKG Configuration?  http://support.microsoft.com/kb/307852/

If that doesn't work you may have to do an XP repair (http://support.microsoft.com/kb/314063):

1.      Disable any antivirus program and BIOS-level antivirus protection. For help, see the relevant software manual or online help.
2.      Make sure that the CD-ROM or DVD-ROM drive is the first priority startup device. See your computer documentation for information about how to do this.
3.      Insert the Windows XP CD into the CD-ROM or DVD-ROM drive, and then restart your computer.
4.      When the instruction to "Press any key to boot from CD" appears, press a key. Your computer starts from the Windows XP CD.
5.      When the computer starts from the CD, the system verifies your hardware, and then prompts you to select one of the following options:
•      To set up Windows XP now, press ENTER.
•      To repair a Windows XP installation using Recovery Console, press R.
•      To quit Setup without installing Windows XP, press F3.
6.      Press ENTER.
7.      Press F8 to accept the Licensing Agreement.
8.      A box lists your current Windows XP installation, and then the computer prompts you to select one of the following options:
•      To repair the selected Windows XP installation, press R.
•      To continue installing a fresh copy of Windows XP without repairing, press ESC.
9.      Press R. After you repair Windows XP, you may have to reactivate Windows XP if you changed some hardware.

WARNING: With the repair option you may have to reinstall some of your software.  I would use this as a last-ditch effort.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18838659
Can you post the minidump files for us to review?
http://www.ee-stuff.com, and follow the directions....Zip them first though....
0
 

Author Comment

by:UltHybrid
ID: 18839641
https://filedb.experts-exchange.com/incoming/ee-stuff/3067-Minidumps.zip
I've zipped 3 of the minidumps into a file there.

Have also tried LKG, no change.
Cannot start XP from the CD, as when I reach Step 5, the computer will either crash or display another BSOD with BAD_POOL_HEADER 0x00000019 (0x00000020, 0x823E870, 0x823E83F0, 0x0A700001) being the most common error message.
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18839749
1st one indicates mouclass.sys

f794afd0 804dbbd4 82f54230 82f54020 00000000 mouclass!MouseClassReadCopyData+0x49 (FPO: [Non-Fpo])
f794aff4 804db89e b9d94680 00000000 00000000 nt!KiRetireDpcList+0x46 (FPO: [0,0,0])
f794aff8 b9d94680 00000000 00000000 00000000 nt!KiDispatchInterrupt+0x2a (FPO: [Uses EBP] [0,0,1])
WARNING: Frame IP not in any known module. Following frames may be wrong.
804db89e 00000000 00000009 bb835675 00000128 0xb9d94680
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18839815
2nd one indicates nv4_disp.dll Explorer.exe made a bad call to the Nvidia driver....

STACK_TEXT:  
9dff3630 804e39ce f795ab40 f795ab70 00000000 nt!KiUnlockDispatcherDatabase+0x77
9dff3644 f7857a67 f795ab94 00000000 00000000 nt!KeSetEvent+0x74
9dff3938 804f0282 f795ab40 9dff3984 9dff3978 watchdog!WatchdogKernelApc+0x13b
9dff3988 804f02c1 00000000 00000000 00000000 nt!KiDeliverApc+0xb3
9dff39a0 804dc143 00000000 e3906010 00000000 nt!KiSwapThread+0x64
9dff39c8 bf857779 00000000 00000000 00000000 nt!KeWaitForSingleObject+0x1c2
9dff39e4 bf9f371d 826f6e30 9dff3a0c 00008000 win32k!EngWaitForSingleObject+0x23
WARNING: Stack unwind information not available. Following frames may be wrong.
9dff3a50 bf857318 00000001 03000400 003c0020 nv4_disp+0x1f71d
9dff3b28 bf85729e 0b400000 e3906010 00000000 win32k!EngDeviceIoControl+0x1f
9dff3b70 00000000 9dff3bb0 00000000 bfa08d0c win32k!GreDeviceIoControl+0x93
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18839844
3rd indicates the process  AV Music Morphe
"ReadMemory error: Cannot get nt!KeMaximumIncrement value."

STACK TEXT
kd> kb
ChildEBP RetAddr  Args to Child              
WARNING: Frame IP not in any known module. Following frames may be wrong.
0004331c 00000000 00000000 00000000 00000000 0x4331d

almost non existent.....




0
 

Author Comment

by:UltHybrid
ID: 18839859
Guessing this isn't much of a help?

Would more dumps be of any use?
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18839869
First of all, I am by no means an expert in reading these things. I have learned a good bit along the way on how to interprete besides the basic....

RAM and possibly even a motherboard CPU problem. Definately HW related though....

Memtest86+ - Advanced Memory Diagnostic Tool
http://www.memtest.org/

MG| Free Download - Hot CPU Tester Pro 4.3
http://majorgeeks.com/download273.html

Definately take the case off of the system, and visually inspect the mobo for blown caps. And let the RAM test run for several hours, the longer the more accurate.
0
Why spend so long doing email signature updates?

Do you spend loads of your time carrying out email signature updates? Not very interesting are they? Don’t let signature updates get you down. Let Exclaimer Cloud - Signatures for Office 365 make managing email signatures a breeze.

 
LVL 66

Expert Comment

by:johnb6767
ID: 18839874
More recent ones might be ok.....They are all random though. Normally, on a consistent S/W problem, you can see patterns. Usually, a good rule of thumb is the more the merrier....
0
 

Author Comment

by:UltHybrid
ID: 18839880
Have previously run the Memtest program for over 24 hours without any errors. Have inspected both sides of the Motherboard and there is no sign of any damage.

Will try the second link.

Thanks.
0
 

Author Comment

by:UltHybrid
ID: 18839913
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18840140
Still working on them, but still not much consistency....Looking deeper into the stack as welll...please bear with us.....

Have you trioed to eliminate your swap file, and recreate a little larger? System managed, or hard coded?

How much physical RAM do you have also?
0
 
LVL 13

Expert Comment

by:AngryBinary
ID: 18840458
BAD_POOL_HEADER can be caused by a borked wireless networking card/driver. Have you tried removing the card and uninstalling the driver? Also, some forums point to Indexing service as culprit. Make sure that's not running on Auto via services.msc.

Just a silly question, but did you remove the old vid drivers before updating? I'm guilty of being lazy in that respect, and it did indeed cause me a world of blue screen hurt.

randall
0
 

Author Comment

by:UltHybrid
ID: 18841329
johnb6767:
Sorry, but I haven't a clue what a swap file is, so there's very little chance in me changing it!
I'm running off a 256mb ram chip.
After six hours, the Hot CPU Tester Pro 4.3 program detected no errors.

AngryBinary:
I'll check out my wireless card and its drivers.
I'm pretty sure I did remove the drivers before updating at least a couple of times, as i've messed around with the video card and its drivers 20+ times since this problem occured. Will give it a go again though, just to be sure.

Thanks again for the help guys.





0
 
LVL 66

Accepted Solution

by:
johnb6767 earned 65 total points
ID: 18843332
Rt click My computer>Properties>Advanced>Performance Tab>Settings>Advanced>and Set the Swap File to No swap file....Reboot, (might be painfully slow in booting), Delete pagefile.sys if it is still present, then go back and reset the Paging file to system managed.

How often are these reboots?
0
 
LVL 4

Assisted Solution

by:AndrewCink
AndrewCink earned 65 total points
ID: 18848842
In my experience IRQL_NOT_LESS_THAN_OR_EQUAL has usually been a RAM issue. In particular, on AMD boards on some implementations if you used a RAM that was too fast for the CPU, it would crash like crazy giving that message. What kind of CPU / Motherboard and RAM do you have? I would strongly recommend another stick of RAM, preferably a 512mb of the right speed (tell us your hardware or PC model so we can help) and maybe even in a different RAM slot.

The other issue could be heat related. What kind of video card do you have? Does the system only have problems when it's been running a while, or even when it starts up cold can it do the same things? In my experience I've had memory problems even if a tester runs clean...
0
 

Author Comment

by:UltHybrid
ID: 18850994
Crashes and reboots are infrequent when idle, maybe every 5 hours or so.
When running apps, games in particular it'll die almost instantly.

I have had heat issues with this comp before as its always on, and as such have purchased a large deal of cooling equipment which has been working fine to date.  Have stuck in a 512 stick of ram i found lying about.

I'm running an Nvidia Geforce 6200 256mb card.
ASRock K7VM4 Motherboard
Athlon XP 2800+ Processor.




0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18851270
I was seeing alot of random errors in the dumps, but one thing stands out....

kd> !process
GetPointerFromAddress: unable to read from 8055ee34
PROCESS 82876020  SessionId: none  Cid: 0518    Peb: 7ffde000  ParentCid: 06a4
    DirBase: 12628000  ObjectTable: e1136cd0  HandleCount: <Data Not Accessible>
    Image: FIFAWC06.exe
    VadRoot 8282cc30 Vads 618 Clone 0 Private 19898. Modified 19072. Locked 22.
    DeviceMap e2589bc8
    Token                             e113e2a0
    ReadMemory error: Cannot get nt!KeMaximumIncrement value.
ffdf0000: Unable to get shared data
    ElapsedTime                       00:00:00.000
    UserTime                          00:00:00.000
    KernelTime                        00:00:00.000
    QuotaPoolUsage[PagedPool]         569612
    QuotaPoolUsage[NonPagedPool]      25816
    Working Set Sizes (now,min,max)  (35827, 50, 345) (143308KB, 200KB, 1380KB)
    PeakWorkingSetSize                36487
    VirtualSize                       663 Mb
    PeakVirtualSize                   665 Mb
    PageFaultCount                    2625228
    MemoryPriority                    BACKGROUND
    BasePriority                      8
    CommitCharge                      25592
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18851280
Consistent in the last dumps, is this module, and look at the Virtual size. It is incredibly high. With only 256 MB RAM, and a VM size around 385 or so, thats way too high. I am hoping that adding the RAM has helped  some. But please go back and set the Virtual memnory to system managed if you havent done so after adding the RAM....
0
 

Author Comment

by:UltHybrid
ID: 18851303
I've had that since yesterday, and crashes are far more infrequent now. I do get the odd crash but no BSOD's yet. I'll leave it til tomorrow before I'll check again.

Thanks :)
0
 
LVL 66

Expert Comment

by:johnb6767
ID: 18851322
Also, a few other common ones besides the majority....

kmixer.sys
Av Music Morphe

Have you tried uninstalling/reinstalling your sound card with the latest drivers?
0
 

Author Comment

by:UltHybrid
ID: 18851339
I don't think i've touched my sound card since I first installed it, will give it a go.
Thanks.
0
 
LVL 13

Expert Comment

by:AngryBinary
ID: 18853635
Are you running a temperature monitor? Heating problem sounds a tad dubious since you've probably got the thing more or less uncased 50% of the time with all the swapping in and out of cards and chips and whatnot, but if that was a problem before, it may be work investigating again. Is your RAM cooled as well?

Your comp doesn't crash while idle, and crashes when under heavy load... maybe heat related, but then most problems can be summed up as "It works until I do something".

Are you keeping tabs on what hardware components you have and haven't swapped out yet?
0

Featured Post

Threat Intelligence Starter Resources

Integrating threat intelligence can be challenging, and not all companies are ready. These resources can help you build awareness and prepare for defense.

Join & Write a Comment

Recently Microsoft released a brand new function called CONCAT. It's supposed to replace its predecessor CONCATENATE. But how does it work? And what's new? In this article, we take a closer look at all of this - we even included an exercise file for…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
In this video, we discuss why the need for additional vertical screen space has become more important in recent years, namely, due to the transition in the marketplace of 4x3 computer screens to 16x9 and 16x10 screens (so-called widescreen format). …
This Micro Tutorial will give you a basic overview of Windows DVD Burner through its features and interface. This will be demonstrated using Windows 7 operating system.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now