?
Solved

MS Access constantly switch keyboard input from English to Chinese every new line

Posted on 2007-04-02
5
Medium Priority
?
361 Views
Last Modified: 2008-01-09
Hello,
I am having a really hard time with MS Access. Every time after I enter the first line information and enter to the next new line, it keeps changes the keyboard input to Chinese. And I  have to keep switching it to English. But it switches back to Chinese again when a new line appears.
I have changed in Access Option fonts all to Tahoma. And my default keyboard input is English.
Though my computer setting is Chinese. Would that be the reason that cause it?
All my data informations are in English, so it is really annoying when I  have to keep switching it every new line. (Considering there will be more than 300 more new lines to be entered.)
Please help.
Thanks in advance.
0
Comment
Question by:Yukimin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
5 Comments
 
LVL 39

Expert Comment

by:stevbe
ID: 18836255
<Would that be the reason that cause it? >
Yes, Access is trying to be *smart* and detect you computer settings, the same way it does for Tinme, Currency, etc. I'm not sure there is anything you can do, but let me take a look around to see what I can find.
0
 
LVL 39

Accepted Solution

by:
stevbe earned 2000 total points
ID: 18836284
Have you set the  KeyboardLanguage property to 9 (english) for all your textbox and combobox controls?

I know next to nothing about switch languages, have you looked at the  
0
 
LVL 39

Expert Comment

by:stevbe
ID: 18836309
oops ...
KeyboardLanguage Property
LanguageSettings Property

if you type Language into help there is a fair listing of the various properties, settings, funcxtions an methods that can help you determine what is going on.

Steve
0
 
LVL 63

Expert Comment

by:☠ MASQ ☠
ID: 18836330
Have you tried using the SETLANG.EXE tool?
It's usually here:
C:\Program Files\Microsoft Office\Office
0
 

Author Comment

by:Yukimin
ID: 18836664
I tried the SETLANG.EXE and removed Chinese (It listed Chinese and English as enabled editting type) But that didn't fix it :( It still kept switching =s

I don't see KeyboardLanguage for the textbox or combo box, but from the field property I do see 'IME Mode' which is the Chinese typing language. I set it off. And that fixed the problem :] I only need to turn the IME mode off in the every field and that will fix the whole columns. Which  is a whole lot better than keep switching the input type for 300+ types.

Thank you very much for your helps =)!
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s the first day of March, the weather is starting to warm up and the excitement of the upcoming St. Patrick’s Day holiday can be felt throughout the world.
AutoNumbers should increment automatically, without duplicates.  But sometimes something goes wrong, and the next AutoNumber value is a duplicate.  This article shows how to recover from this problem.
In Microsoft Access, learn the trick to repeating sub-report headings at the top of each page. The problem with sub-reports and headings: Add a dummy group to the sub report using the expression =1: Set the “Repeat Section” property of the dummy…
Notifications on Experts Exchange help you keep track of your activity and updates in one place. Watch this video to learn how to use them on the site to quickly access the content that matters to you.
Suggested Courses

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question