C Run-Time Error R6034

Hello,

Im trying to make a C++ project that was created and runs perfectly in VS2003 work in VS2005.

Any idea how I can fix this?

Thanks.
GsteingrAsked:
Who is Participating?
 
jkrConnect With a Mentor Commented:
>>warning LNK4098: defaultlib 'libcmt.lib'

Remove that lib from your settings, it is not needed with /MD anyway.

>>HEAP[adx.exe]: Invalid Address specified to RtlFreeHeap( 00BA0000,
>>0178BC60 )

Make sure to revuild all modules in your project using the same CRT settings (that is /MD)
0
 
mrwad99Commented:
One of the big differences in 2005 is that you have to use Manifest files.  This error is described and resolved at http://msdn2.microsoft.com/en-us/library/ms235560.aspx.

HTH
0
 
jkrCommented:
Actually, VS2005 will turn on manifest generation for converted solutions by default. Any chance you are using a 3rd party module where that does not apply?
0
Cloud Class® Course: Certified Penetration Testing

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

 
GsteingrAuthor Commented:
Hi again just to give you more information.
I have been trying to run this project in /MD and /MT, in the VS2003 it was /MD.
I tried it in /MTand then after many including and exluding it finally worked but the minute the application starts i got that C Run-Time Error R6034 popup window.

So then I ended up doing it in /MD again, now I get these errors (I use another library too, which i compile everytime with the same settings as i change the projects, im also using c)
These are the errors with /MD:

1) 1>DecodeAsterixCat021.lib(Cat021Interface.obj) : error LNK2001: unresolved external symbol __imp__memmove_s

2) 1>DataReader.obj : error LNK2001: unresolved external symbol __imp__memmove_s

3) 1>Plot.obj : error LNK2001: unresolved external symbol __imp__memmove_s

4)  1>adxconfig.obj : error LNK2019: unresolved external symbol __imp__printf referenced in function "public: int __thiscall ADXConfig::readSettings(class QString const &)" (?readSettings@ADXConfig@@QAEHABVQString@@@Z)


looks like i need to include other libraries???
Thank you so much in advance.
0
 
jkrCommented:
When building with /MD, your code will be linked with msvcrt.lib and this one should contain these functions. Make sure though that your LIB environment variable does not contain paths with older versions of that library.
0
 
GsteingrAuthor Commented:
I was excluding msvcrt.lib and including libcmt.lib when doing /MD...
so now i removed those exclude and include in /MD and build again
Now I get 0 errors and:
MSVCRT.lib(cinitexe.obj) : warning LNK4098: defaultlib 'libcmt.lib' conflicts with use of other libs; use /NODEFAULTLIB:library
1>Embedding manifest...


But when the application window starts then:
'adx.exe': Loaded 'C:\WINDOWS\system32\xpsp2res.dll', Binary was not built with debug information.
HEAP[adx.exe]: Invalid Address specified to RtlFreeHeap( 00BA0000, 0178BC60 )
Windows has triggered a breakpoint in adx.exe.
This may be due to a corruption of the heap, and indicates a bug in adx.exe or any of the DLLs it has loaded.

Any Idea? thank you all.
0
 
GsteingrAuthor Commented:
hi jkr, i did the same things you said above...

but i still get the same problem.
0
 
jkrCommented:
When debugging that, what call is ftrying to free memory and where and how was that memory allocated?
0
 
itsmeandnobodyelseCommented:
Put the libcmt into the 'ignore libraries'. You need to get rid of the standard runtime libraries in the main project and all other dll projects. VS 2005 uses a runtime library which is *not* compatible with the lib you used, e. g. for the memmove_s function which is proprietary to VS. The heap error most likely occurs cause you try to delete memory that was allocated by a different heap management in another dll. All apps and dlls need to have the same (multi-threaded) model in C++ code generation. Delete precompiled header files (explicitly).

Regards, Alex
0
 
itsmeandnobodyelseCommented:
As a last resort, you might move your project directories to a different location and create *all* projects from scratch using the old names and locations. Make sure that include and library paths of VS 2003 were *not* be used when building the VS 2005 projects.

0
 
GsteingrAuthor Commented:
oh i rebuilt the other dlls again, they might have been old builds, the Qt was an old build i forgot about. then it worked. thanx all :)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.