DNS issues with Directway Satalite and DNS on Server 2003

I’m having a DNS issue with on of my clients and I’m not quite sure I know what to do about it. This client is in a remote location so Satellite Internet is all that is available. I will explain the issue below.

I have a windows 2003 SBS running as the DC and it handles my DNS as well. My server IP is My internet connection is a Directway 6000 Satellite internet connection. It’s handing out DHCP schema and it’s handing out its internal DNS server for the DNS for the clients.

The issue is if I allow the Directway 6000 to handle my DHCP the internet works fine but then my clients have issues loosing connections to the server and the DNS does not resolve correctly for the internal network. I tried to get around this by statically assigning IP’s to my client and using the server as the primary DNS and the Directway 6000 as the secondary DNS but when I do that most WebPages will not load. In the Directway 6000 configuration there is no way to turn off the DHCP for the router.

The first thing I tried was to setup a firewall router to let the Directway 6000 hand out the external address to the router at then set the internal router to be my gateway. This does not seem to work as it will not hand out an address to my firewall. I tried to set the external side of the firewall to as the IP and the gateway to be and use it DNS (I’m not on site so I don’t remember the exact number) but I can’t get past the firewall. I really don’t want to change my addressing schema because I have several UNIX devices on this network ( they have nothing to do with this problem) but they are a pain to hook up terminals to and change the schema on it. I need help fast on this issue as I’m scheduled to be on site tonight and look at this problem.

Thanks in advance.

Who is Participating?
NJComputerNetworksConnect With a Mentor Commented:
To get your SBS server to resolve internet conenctions, configure forwading...

Go into the DNS console on the SBs server...  Right click the server name and choose PROPERTIES from the drop down box.  Click the FORWARDS tab... and the IP address of your ISP DNS servers (or if you are using a firewall that gets a DHCP address from the ISP, use the internal IP address of your Firewall/router)
You can let you Directway hand out DHCP.  However, in the DHCP options, you need to configure DNS for your client to (no secondary is needed if you have SBS with one DC).

You will also need to make sure that the DHCP client computers are using the DNS suffix of your internal domain name.  So, if your domain name is SBScompany.local, you will want to make sure that your client computers are using this as thier DNS suffix too.

You can test DNS resolution using the NSLOOKUP command....
SPAADMINAuthor Commented:

I could have sworn I tried this. But then I get no internet what so ever. Is their something I need to point my DNS setting on the server to allow the internet to resolve through this I will link my original question before. The previous answer said I needed to insure that my (DC) pointed back to itself inorder to fix the original.

If I’m reading you correctly my primary DNS on should point to my Directway connection and my clients should point their DNS to
Then set the DNS suffix to SBScompany.local
Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

SPAADMINAuthor Commented:
I forgot to provide the link where it talks about pointing back to itself sorry.
"If I’m reading you correctly my primary DNS on should point to my Directway connection and my clients should point their DNS to
Then set the DNS suffix to SBScompany.local"   Nope, this is not what I am saying here...

Server must point to itelf for DNS... so use  (or LOCAL IP)

Clients must point to the Windows 2003 SBS server for DNS (not ot ISP)...

Your SBS server should forward DNS requests to the Internet on behalf of your clients...

SPAADMINAuthor Commented:
I will try it tonight and let you know thanks for the help.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.