Solved

Web page showing question marks (?) instead of bullets or apostrophes

Posted on 2007-04-02
6
450 Views
Last Modified: 2008-02-01
I am not sure what is going on exactly but there is a web server (apache 2.2.3 + php 4.4.4) which is displaying some characters (specifically apostrophes ' and bullets •) as question marks instead of the appropriate character.  The pages have the bullet (•) character in them instead of using •  I know I can change it to • instead of specifically using the bullet (•) character, but the page was exported from PowerPoint as a HTML document so the next time it gets created I would have to manually edit each slide by hand.  I am guessing that there is something wrong with the encoding, but I am not sure what.  I have a development web server (apache 2.0.50 + php 4.3.8) that displays the characters correctly.

Any ideas?
0
Comment
Question by:bdhtechnology
6 Comments
 
LVL 29

Accepted Solution

by:
TeRReF earned 400 total points
ID: 18839244
Compare the apache config files of the 2 servers and see if this directive is set
AddDefaultCharset

If so, do they differ?
0
 
LVL 1

Author Comment

by:bdhtechnology
ID: 18839320
Server that is working has:
AddDefaultCharset Off

Server that isn't working had a line in the config file for it, but commented out.  So I added:
AddDefaultCharset Off

Restarted apache2 and still the same thing.  Any other ideas?
0
 
LVL 19

Expert Comment

by:BrianGEFF719
ID: 18840499
add this line to your <head> section in the file.

<meta http-equiv="content-type" content="text/html; charset=UTF-8">
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 
LVL 15

Assisted Solution

by:samri
samri earned 100 total points
ID: 18841565
bdhtechnology,

after you had changed the config, and restarted the server --- sometimes when you refresh the page from the web browser, it may still got the content from cache.  try to clear your browse cache, or hit shift-refresh.

just some thought.
0
 
LVL 1

Author Comment

by:bdhtechnology
ID: 18845505
So it apparently just needed 'AddDefaultCharset Off' set, even though it wasn't set before and is suppose to default to off.  Once I cleared the cache, the question marks went away.  I figured refreshing the page would have been good enough, but I guess not.  Thanks for the help!
0
 
LVL 29

Expert Comment

by:TeRReF
ID: 18846412
You're welcome :)
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Join & Write a Comment

"In order to have an organized way for empathy mapping, we rely on a psychological model and trying to model it in a simple way, so we will split the board to three section for each persona and a scenario and try to see what those personas would Do,…
Boost your ability to deliver ambitious and competitive web apps by choosing the right JavaScript framework to best suit your project’s needs.
The viewer will learn how to dynamically set the form action using jQuery.
Any person in technology especially those working for big companies should at least know about the basics of web accessibility. Believe it or not there are even laws in place that require businesses to provide such means for the disabled and aging p…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

13 Experts available now in Live!

Get 1:1 Help Now