need to get LTP installed - edit makefile install cc gcc no KEY for RPM , however

Posted on 2007-04-02
Last Modified: 2013-12-15
I just want to install and use LTP / DOTS (  when I run make, I get a message that I dont have cc...

[root@acpsvsvr05 ltp-full-20070228]# make
make[1]: Entering directory `/ltp-full-20070228/lib'
cc -Wall  -I../include  -Wall    -c -o dataascii.o dataascii.c
make[1]: cc: Command not found
make[1]: *** [dataascii.o] Error 127
make[1]: Leaving directory `/ltp-full-20070228/lib'
make: *** [libltp.a] Error 2
[root@acpsvsvr05 ltp-full-20070228]# which cc
/usr/bin/which: no cc in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/X11R6/bin:/opt/avaya/1xp/weblm/tomcat5/_jvm/bin:/root/bin)
[root@acpsvsvr05 ltp-full-20070228]#

I have this, I think it's c++ ??  ...
[root@acpsvsvr05 ltp-full-20070228]# locate cc1

I tried to edit makefile with cc1 to get LTP installed but no luck, it is running with different options cc1 doesnt have...

[root@acpsvsvr05 ltp-full-20070228]# cat Makefile
# To cross compile, override one or more of CC, AR, CROSS_CFLAGS,
# LOADLIBES, LDFLAGS, & LIB_DIR and be sure to always build from the top level.
# To override them from the make commandline, do something like this:
# $ CROSS_COMPILER=/opt/cegl-1.4/hardhat/devkit/ppc/405/bin/powerpc-linux-
# $ make \
#     CROSS_CFLAGS="-mcpu=403 -D__PPC405__" \
#     LDFLAGS=-static \
#     LOADLIBES="-lpthread -lc -lresolv -lnss_dns -lnss_files -lm -lc"
# Alternately, to override them by editing this file, uncomment the
# following lines:
#   CROSS_COMPILER=/opt/ppc64/powerpc64-linux/bin/powerpc64-linux-
#   CROSS_COMPILER=/usr/libexec/gcc/i386-redhat-linux/3.4.3/cc1
#   CROSS_CFLAGS= -mpowerpc64
#   LDFLAGS=-static
#   LOADLIBES=-lpthread -lc -lresolv -lnss_dns -lnss_files -lm -lc
#   LIB_DIR=/lib64
# Or, you can save all your settings into the local '' file.
# Just use the same syntax as above for the Makefile.
# uClinux Users: make sure you add -DUCLINUX to your CFLAGS
# Note: If you override a variable from the commandline all
# assignments to it in the Makefiles will be ignored. To set it both
# in the commandline and in the Makefiles use a dummy variable like in


Do I have cc?  How can I get it and install it?  I tried some of these but dont have a KEY?
[root@acpsvsvr05 /]# ls *rpm
compat-gcc-32-3.2.3-47.3.src.rpm  compat-glibc-2.3.2-95.30.src.rpm  gcc4-4.0.0-0.14.EL4.src.rpm

[root@acpsvsvr05 /]# rpm -i gcc4-4.0.0-0.14.EL4.src.rpm
warning: gcc4-4.0.0-0.14.EL4.src.rpm: V3 DSA signature: NOKEY, key ID db42a60e
[root@acpsvsvr05 /]#

 Just help me get the LTP installed whatever is the easiest way!

[root@acpsvsvr05 /]# cat /etc/issue
Red Hat Enterprise Linux ES release 4 (Nahant Update 4)
Kernel \r on an \m

[root@acpsvsvr05 /]# uname -a
Linux 2.6.9-42.ELsmp #1 SMP Wed Jul 12 23:27:17 EDT 2006 i686 i686 i386 GNU/Linux
Question by:sillygoose
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
LVL 24

Expert Comment

ID: 18840021
> Do I have cc?  How can I get it and install it?  I tried some of these but dont have a KEY?
> [root@acpsvsvr05 /]# ls *rpm
> compat-gcc-32-3.2.3-47.3.src.rpm  compat-glibc-2.3.2-95.30.src.rpm  gcc4-4.0.0-0.14.EL4.src.rpm

You need gcc, the above packages are src.rpm they are not the binary rpms.  Use up2date if possible, that's the easier way:

# up2date -i gcc

then try to make again.

Author Comment

ID: 18851237
I tried it, Apparently I don't have a subscription # for redhat.

Is there another way?

Author Comment

ID: 18853764
Ahh, I got the CDs so I think I can just add it
LVL 24

Accepted Solution

slyong earned 500 total points
ID: 18854903
Sorry for the late reply.  Seems that you can get the RPMs from the CD, if you are still having problem, leave me a message.

Author Comment

ID: 18858846
sweet.  it's working now

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
The purpose of this article is to fix the unknown display problem in Linux Mint operating system. After installing the OS if you see Display monitor is not recognized then we can install "MESA" utilities to fix this problem or we can install additio…
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial

761 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question