Problem Changing Com Port Assignments

I recently had to reinstall Windows XP Professional (SP2) onto a Dell Dimension 8250.  I am slowly adding back all the software and hardware that was running on the machine.  I just installed my PCI Serial card that gives me a couple of serial com ports.  It installed just fine using the attached installation disk.  However, the devices I connect to the serial ports only have options to select Com ports 1-4.  Consequently, when I connect the external devices to the Com ports, the computer does not "see" them.  So, I accessed the Device Manager, Ports and selected the NetMos PCI Serial Port.  I selected Properties, Port Settings, Advanced.  An information box pops up informing me that I must have write privileges to the registry for this device in order to  modify this device's advanced features.  I am logged in as Administrator on my machine and should have full access (there are no other users).   I'm hopeful someone can help me gain access to the Advanced features of the card so I can change Com Port assignments.
banethkAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rindiCommented:
To get administrative rights to registry settings (the admin doesn't always have all rights, as some are just assigned to the system and no real user) you can right click that key and then select the security option. Now, if you can't add the admin account here already you can take ownership, similar to what you do in the ntfs filesystem. Once the admin is owner, you can also add users to the key.
0
banethkAuthor Commented:
Rindi,
Thanks for responding.  I am by no means a computer expert.  Can you translate your advice so a dummy like me can understand?  I'm hopeful you can provide more specific advice.
0
rindiCommented:
If you open regedit and navigate to the key you want to change but don't have enough rights on, then right click that key, select the "Security" or "Permissions" option (I'm not sure what it is called, as I'm not using an english version at the moment), you should see a list of users which have what type of rights on that object. If you select the "advanced" option, you should have an "owner" tab. In there add yourself as Owner (take ownership), then you have enough rights to also add yourself in the previous list of users with enough rights so you can change or edit the object.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Redefine Your Security with AI & Machine Learning

The implications of AI and machine learning in cyber security are massive and constantly growing, creating both efficiencies and new challenges across the board. Check out our on-demand webinar to learn more about how AI can help your organization!

banethkAuthor Commented:
Thanks Rindi.  I tried to find the right Key in the Registry.  HKEY_LOCAL_MACHINE.  I selected Hardware and right-clicked MultifunctionAdapter.  I selected Permissions and selected Advanced.  I set the owner to me.  Still no luck.  I get the same warning in Device Manager when I try to chang Port assignments.
0
rindiCommented:
After setting the owner to yourself you also have to add yourself to those permitted. Making yourself owner only only allows you to add and change permissions. So when you right click "MultifunctionAdapter" and select "Permissions" and you aren't in the list, click on add and then add yourself. If you are in the list already, select yourself and then make sure everything in the "Allow" row is ticked. You might have to repeat this for the keys within that key too.
0
banethkAuthor Commented:
Rindi,
Thanks again.  I just set myself up in the list as you suggested and then made sure that the Permissions were set as you suggested earlier.  Still no luck.  I'm beginning to think I have a bad driver (or bad install).  When I get some extra time later tonight, I will try to reinstall the MultifunctionAdapter card and drivers.  Thanks so much for your guidance.
0
rindiCommented:
Maybe you can also change the port settings directly in the registry and not via the device manager. A further thing that you should check or which could cause problems, the mainboard, if it isn't to new, probably has 2 builtin serial ports too. These could interfere with the port settings. You can often turn off the board's internal serial ports in the BIOS, or change their irq and address settings if they conflict with something else.
0
banethkAuthor Commented:
Rindi,
I really hate opening up the computer case, so I sure appreciate your advice.  I was hopeful you could  provide some advice on how/where to find the specific registry key(s) to change Port assignments.  Also, I will check the BIOS to see if I can change IRQ and port setting of internal serial Com  ports.
0
banethkAuthor Commented:
Rindi,
I had a chance to expand a little on your suggestion from earlier.  I went sequentially to each of the major Keys, including HKEY_CLASSES_ROOT as well as HARDWARE.  On the edit menu, I clicked on Permissions.  In the Groups box, I made sure both System and Administrator showed up.  I then clicked on Administrator.  I made sure that Read and Full Control were both checked in the box.  I did the same thing for System.  For System, I then clicked on Advanced.  I checked the box for Replace permission entries on all child...  I unchecked the Inherit from parent the permission entries...  As I mentioned before I did this sequentially for all the major Key categories.  IFor some reason, it was not enough just to correct Permissions in the Hardware Key.  Next, I rebooted.  Now, I am able to access Advanced Port settings.  Thanks for steering me in the right direction.
0
rindiCommented:
Your welcome.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Utilities

From novice to tech pro — start learning today.