Solved

SUSE Linux 10.2 widescreen resolution on a laptop.

Posted on 2007-04-03
7
593 Views
Last Modified: 2013-12-15
I am having problems with Suse 10.2 and my laptop screen resolution (widescreen)
The native resolution is 1440x900 @ 60Hz, but the max res i can select in Configure Desktop is 1024x768. Now, i have checked xorg.conf, and the res i need is listed. Also, "hwinfo --monitor" shows all the info for the screen.
Incidently, its a Fujitzu Siemens li1818
i really need as much help as i can on this, as i am very very new to Linux.
0
Comment
Question by:Bunzl_it
7 Comments
 

Expert Comment

by:t20suzukiman
ID: 18845937
Hi there

Open Yast and click on Hardware>Graphics card and Monitor

You'll see that you can change the selected monitor.  My guess is that your monitor hasn't been recognised, so Suse has 'chosen' one that works. See if your exact monitor is in this list. If not, try the option LCD and then choose the correct setting for your screen.

That should do it!
0
 
LVL 1

Author Comment

by:Bunzl_it
ID: 18848862
ok, that is showing as 1440x900, which is good...
BUT, when i rightclick the desktop -> Configure Desktop -> Display, the res is still stuck at 1024x768...
0
 

Expert Comment

by:t20suzukiman
ID: 18854055
You should be able to choose the correct resolution in Yast.  Did you try choosing the LCD option of 1440x 900???
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 1

Author Comment

by:Bunzl_it
ID: 18856225
Unfortunatly, none of these solutions worked, but thanks for taking the time to try and help.
It turns out that my xorg.conf file did not have the correct modeline specified.
This is why i could select the correct res in YaST, but the monitor always defaulted to 1024x768.
Running a system update corrected this.

Thanks again.
0
 
LVL 5

Accepted Solution

by:
juanfermin earned 500 total points
ID: 21019944
Hopefully, you have either an Nvidia or ATI card, preferably Nvidia.  If so, go to the website and download the commercial drivers for your card. (They're non-GPL but who cares).  If it's Nvidia, follow the special instructions for SUSE users to use YAST to install, and you should be good.  Once you've done this, you may need to update your Monitor driver, and you should be able to adjust the resolution from there.
0
 
LVL 1

Expert Comment

by:Computer101
ID: 21250257
Forced accept.

Computer101
EE Admin
0

Featured Post

Master Your Team's Linux and Cloud Stack

Come see why top tech companies like Mailchimp and Media Temple use Linux Academy to build their employee training programs.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Many people tend to confuse the function of a virus with the one of adware, this misunderstanding of the basic of what each software is and how it operates causes users and organizations to take the wrong security measures that would protect them ag…
#Citrix #POC #XenDesktop #vCenter #VMware #ESX
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…

776 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question