Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4156
  • Last Modified:

How to creat a SMB share on Windows 2003

I am trying to get a device to auto backup. It uses SMB share that I have created on the server. I created a share on the server but it will not connect to it. The share permissions are correct. When I create a share on Windows 2003 server, does it auttomatically make it a SMB share or do I have to do something else?
0
dsheltzel
Asked:
dsheltzel
1 Solution
 
LauraEHunterMVPCommented:
All Windows file shares communicate over SMB, there is not anything different you need to do to configure an SMB share.

Depending on the rror that you're receiving, you should check the permissions on the share, as well as whether the Windows Firewall is blocking the SMB ports which would prevent a remote user/device from connecting to a share - you can open the "File and Printer Sharing Exception" on the Windows Firewall applet in Control Panel if this is the case, though I would recommend setting the Scope of that exception to only the IP of the device that needs to connect to it. (You'll find a tutorial on this here: http://www.windowsecurity.com/articles/Customizing-Windows-Firewall.html)

Hope this helps.

Laura E. Hunter - Microsoft MVP: Windows Server - Networking
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
SMB = Server Message Block - this is standard Windows Networking.  Any share created on a Windows machine is an SMB share.  

You've otherwise provided limited information - "a device" - we have to take your word that the permissions are correct... No error messages provided...
0
 
KCTSCommented:
Make sure the share permissions are correct, in Windows 2003 when you create a share is is shared with read-only pemission assigned to the everyone group. If the share permissions are OK then make sure that the NTFS permissions are sufficient for you needs. Remember that when there is a combination of NFTS and Share permissions the most restrictive combination applies.
See http://technet2.microsoft.com/WindowsServer/en/library/86987829-3f74-412f-abb8-c8b22b07257d1033.mspx?mfr=true
0
Keep up with what's happening at Experts Exchange!

Sign up to receive Decoded, a new monthly digest with product updates, feature release info, continuing education opportunities, and more.

 
dsheltzelAuthor Commented:
The share permissions are correct as I said above.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
Yes, you've said it... now prove it - what are they?
0
 
dsheltzelAuthor Commented:
Mr. Genious leew, no reason to have your attitude.

As I said, my share permissions are correct - share permissions are full control and NTFS permissions domain admins full control. I am using a domain admin test account to access the share from a Spam Applicance that needs an SMB share setup to dump its config files.

When I test it from the SPAM appliance, this is the error I get -

"Could not mount SMB share.  Please check your setting again, and ensure that the SMB server is running on the host machine."

The SPAM Applicane is a Linux based box.
0
 
Lee W, MVPTechnology and Business Process AdvisorCommented:
I'm sorry if you perceive an attitude, perhaps you are correct... but I did ask and suggest multiple times that you post what your settings were and yet you still hadn't.  I also asked what the application was you were trying to use and you did not respond with that information before.  So based on your comments, I perceive and unwillingness to work with us when we're trying to help you.  

Now that you've actually provided information on what the application is, I can tell you the next thing I would look into is SMB signing which is used on domain controllers by default (not sure about Windows Servers that are not domain controllers).  SMB signing will prevent non-Windows clients (clients that don't understand SMB signing) from connecting to a Windows share.

You can disable SMB signing (or confirm it's disabled) and see if that works.  If not, I would next suggest you provide your Samba config file as you are almost certainly using Samba from the linux system to connect to the Windows share.  Though I will say, I'm not well versed in linux-to-windows networking (or at least not as well as I'd like to be), so I'm not certain I can help you beyond this suggestion.

http://windows.stanford.edu/docs/SMBSign.html
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Tackle projects and never again get stuck behind a technical roadblock.
Join Now