SQL Server Does Not Allow Remote Connections When Using sqlcmd on Local Machine

I am trying to backup databases in SQL 2005 Express on SBS 2K3 SP1, which doesn't have the SQL Agent. I am attempting to access the database directly from the server it is installed on. I want to use a batch file to access the database and run the backup T-SQL command, but it tells me the SQL server does not allow remote connections. I have verified that remote connections was enabled in the Surface Area Configuration, and also double-checked that the SQL Server Browser process is running. I am pretty sure that the server has been rebooted since those settings were enabled. I have tried using sqlcmd and osql, but neither is successful. Actually, osql gives me doesn't exist or access denied errors. Any help would be greatly appreciated.

Biziteks
BiziteksAsked:
Who is Participating?
 
abhijit_kCommented:
Go to Start-Control Panel-Administrative TOOLs-Component Services
Right CLick and go to Security Configuration and Check the Boxes allow inbound Connections
0
 
davidsperlingCommented:
Guess you've read a similar instruction like this:
http://www.datamasker.com/SSE2005_NetworkCfg.htm

For me it didn't work until I checked "Using both TCP/IP and named pipes" in surfice area configurator. -And rebooted, I guess.

(My problem was that I couldn't connect from visual studio. Using sqlserver2k5 express.)
 
0
 
BiziteksAuthor Commented:
Yeah, I did see that article and a couple other ones, including a KB from Microsoft, I think. The option for both was already checked when I went in Surface Area Configuration. If all else fails I will reboot the server tonight for kicks and giggles, and hopefully fix this. Any additional suggestions are always welcome.

Biziteks
0
Cloud Class® Course: MCSA MCSE Windows Server 2012

This course teaches how to install and configure Windows Server 2012 R2.  It is the first step on your path to becoming a Microsoft Certified Solutions Expert (MCSE).

 
dqmqCommented:
The remote connections message is a red herring. You are simply not passing the correct server name or do not have the right permissions.

Try using '.' to identify the server when connecting or append /SqlExpress to the real server name.
0
 
BiziteksAuthor Commented:
When I use Management Studio, I see <servername>\<databasename> in the Server name field. I can login this way using either sa or Windows Authentication. I have given the Windows domain user (also a domain admin acct) access to all the Server Roles and went in User Mapping and selected the user to have all roles for the db. I still cannot get it to run.

An error that I missed earlier pops up before the remote connections error and reads: HResult 0x15, Level 16, State 1  Encryption not supported on the client.

Biziteks
0
 
nakul_vachhrajaniCommented:
Try installing latest version of the SQL 2005 feature pack - that will give you support for osql commands (however, I doubt they will be of much help on SQL 2005 Express).
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.