Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 741
  • Last Modified:

URGENT !!!!!! AJAX ASP.NET Configuration Error in Web.Config

I created a ASP.NET Application using AJAX TookKit Website Template and i developed a Ajax based Website..
It works great on my local machine.. However when i deploy the application on a Different machine(a Web server) i get the following error

Parser Error Message: Unrecognized attribute 'type'.

on line
<sectionGroup name="system.web.extensions" type="System.Web.Configuration.SystemWebExtensionsSectionGroup, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35">

in web.config file...

Any idea how to resolve this error??

Please help!!!
0
Collindsouza
Asked:
Collindsouza
  • 6
  • 6
1 Solution
 
dstanley9Commented:
SectionGroup is new to .NET 2.0.  Is the virtual directory you are using on the web server configured to use asp.net 2.0 in IIS?
0
 
CollindsouzaAuthor Commented:
Hi,
could you please explain this further...

0
 
dstanley9Commented:
Go to IIS Admin on the server.  Look for the virtual directory you are publishing to. Look as the Properties.  Under the ASP.NET tab, make sure it's set to 2.0.50727
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

 
CollindsouzaAuthor Commented:
yes i am using version 2.0 of .NET Framework... i.e 2.0.50727

What could be the problem?

It works seemlessly on my local machine.... but fails on the server
0
 
dstanley9Commented:
Every time I've seen this it's because the virtual dir on the server was set to .NET 1.1
0
 
dstanley9Commented:
The virutal dir it will use is the dir that web.config is in.  It also has to be set up as an application in IIS - if the dir is not set as an application the "Application Name" text box in IIS will be grayed out.
0
 
CollindsouzaAuthor Commented:
Yes,
I have set the Virtual Directory by clicking on the create button...

If the virtual directory was not created then it wouldnt go as far as the web.config file in the application...

it would simple give an /Application error
0
 
dstanley9Commented:
And the ASP.NET tab for that virtual dir shows version 2.0?
0
 
CollindsouzaAuthor Commented:
yes it does...
0
 
dstanley9Commented:
Can you run aspnet_regiis -lk on the server and post the results?  You can remove references to paths that are not part of your deployment.
0
 
CollindsouzaAuthor Commented:
Setting environment to use Microsoft .NET Framework v2.0 SDK tools.
For a list of SDK tools, see the 'StartTools.htm' file in the bin folder.

C:\Program Files\Microsoft.NET\SDK\v2.0>aspnet_regiis -lk
W3SVC/  1.1.4322.2300
W3SVC/1/ROOT/crystalreportviewers115/   1.1.4322.2300
W3SVC/1/ROOT/IP/        2.0.50727.0
W3SVC/1/ROOT/NiceContacts/      2.0.50727.0
W3SVC/1269410064/root/  2.0.50727.0
W3SVC/1269410064/root/IP/       2.0.50727.0
W3SVC/1269410064/root/NiceContacts/     2.0.50727.0
W3SVC/1269410064/root/Contacts/ 2.0.50727.0
W3SVC/999596315/root/   2.0.50727.0

C:\Program Files\Microsoft.NET\SDK\v2.0>
0
 
CollindsouzaAuthor Commented:
it works..............
Horray!!!!!!!!!!!!!!!!!!!!!!

There was a problem with the IIS Version....

So i took a cue from your query and re registered IIS on the server using aspreg_iis -i

Thanks a million for your help!!!!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 6
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now