Solved

Email Address Not Automatically Created when Creating Excahnge Users

Posted on 2007-04-03
8
295 Views
Last Modified: 2012-08-14
I'm running mixed windows 2000 and win2k3 servers as my domain controllers. I also running mixed exchange 2000 and exchange 2k3 servers. All server OS are standard edition while all exchange servers are enterprise edition. All servers are divided to two sites with permanent 4MB leased line. dc01,dc02, dc03 and exch03 (back end-exch2k) are at site A while dc04, exch01 (frontend-exch2k3) and exch02 (backend-exch2k3) are at site B. All are running in single domain  and both site was configured in th Active Directory Site and Services.

I'm facing this scenario
1.  There is no problem when creating windows user, all newly created user are propagate to all domain controllers
2. When creating exchange users, the newly created users are not automatically propagate with the E-mail address (General tab and E-mail Addresses tab (proxy addresses)). So I have to create it manually
3. The Mailbox Store Location at the Exchange General tab is propagated, but when I check at the Exchange Advanced tab under Mailbox Rights, there is only SELF in the group or user names box. I have to move the mailbox to different mailbox store to 'activate' the user mailbox ( Only after move the mailbox, I can see others (default) entries in the group or user names box)

Anyone can advice
0
Comment
Question by:aihaiai
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
8 Comments
 
LVL 18

Expert Comment

by:amaheshwari
ID: 18848520
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 18849053
0
 

Author Comment

by:aihaiai
ID: 18862625
Is there any impact if I rerrun the domainprep.
0
Easy, flexible multimedia distribution & control

Coming soon!  Ideal for large-scale A/V applications, ATEN's VM3200 Modular Matrix Switch is an all-in-one solution that simplifies video wall integration. Easily customize display layouts to see what you want, how you want it in 4k.

 

Author Comment

by:aihaiai
ID: 18862655
I have no problem with the address list but the email address is not stamp
0
 
LVL 18

Expert Comment

by:amaheshwari
ID: 18874174
there will not be any issue with domainprep here.
0
 

Author Comment

by:aihaiai
ID: 18874824
I think so, I went through all the articles, the only errors were related to unable to generate 3rd party (XFAX)proxyaddress which is no longer in used. The article options is to copy the .dll file and paste it to the spesific directory (by recreating back the directory) or  to disable the 3rd party proxy address at the recipient policy. I did it but still not working

I just realised the stamping email address works today after I click the 'update the policy now' at the default recipent policies. Now the only thing is, I still got the event id 2027, 2037 and 8231even though I was disable it.
0
 
LVL 18

Accepted Solution

by:
amaheshwari earned 500 total points
ID: 18879506
Have you checked this:

Exchange Recipient Update Service does not stamp proxy addresses in Exchange 2000 Server and in Exchange Server 2003

http://support.microsoft.com/kb/286356/en-us
0
 

Author Comment

by:aihaiai
ID: 18879591
Yes, I already read the article. The email address stamping was OK now . As I mentioned, the event idsrelated to 3'rd party proxy address still generated even though I was disable it at recipient policy. Is there anything to do at the registry?
(Event Id 2027) Unable to generate the e-mail address. Unable to load address module 'E:\program files\exchsrvr\address\XFAX\i386\proxygen.dll' for address type 'XFAX'. Error 0x007007e]

(Event Id 2037) The file version of '\address\XFAX\i386\proxygen.dll' installed on the local serveris not current. Unable to locate a correct version of any server in the site.

(Event Id 8231) Permanent failure reported by policy group provider for 'CN=Recipient Policies, CN=My org,Cn=Microsoft Exchange,CN=Services,CN=Configuration,DC=mydom,DC=com':'MAD.EXE', error=8000ffff.Taking provider offline.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Read this checklist to learn more about the 15 things you should never include in an email signature.
A list of top three free exchange EDB viewers that helps the user to extract a mailbox from an unmounted .edb file and get a clear preview of all emails & other items with just a single click on mailboxes.
This is used to tweak the memory usage for your computer, it is used for servers more so than workstations but just be careful editing registry settings as it may cause irreversible results. I hold no responsibility for anything you do to the regist…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

726 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question