Email Address Not Automatically Created when Creating Excahnge Users

I'm running mixed windows 2000 and win2k3 servers as my domain controllers. I also running mixed exchange 2000 and exchange 2k3 servers. All server OS are standard edition while all exchange servers are enterprise edition. All servers are divided to two sites with permanent 4MB leased line. dc01,dc02, dc03 and exch03 (back end-exch2k) are at site A while dc04, exch01 (frontend-exch2k3) and exch02 (backend-exch2k3) are at site B. All are running in single domain  and both site was configured in th Active Directory Site and Services.

I'm facing this scenario
1.  There is no problem when creating windows user, all newly created user are propagate to all domain controllers
2. When creating exchange users, the newly created users are not automatically propagate with the E-mail address (General tab and E-mail Addresses tab (proxy addresses)). So I have to create it manually
3. The Mailbox Store Location at the Exchange General tab is propagated, but when I check at the Exchange Advanced tab under Mailbox Rights, there is only SELF in the group or user names box. I have to move the mailbox to different mailbox store to 'activate' the user mailbox ( Only after move the mailbox, I can see others (default) entries in the group or user names box)

Anyone can advice
aihaiaiAsked:
Who is Participating?
 
amaheshwariConnect With a Mentor Commented:
Have you checked this:

Exchange Recipient Update Service does not stamp proxy addresses in Exchange 2000 Server and in Exchange Server 2003

http://support.microsoft.com/kb/286356/en-us
0
 
amaheshwariCommented:
0
 
amaheshwariCommented:
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
aihaiaiAuthor Commented:
Is there any impact if I rerrun the domainprep.
0
 
aihaiaiAuthor Commented:
I have no problem with the address list but the email address is not stamp
0
 
amaheshwariCommented:
there will not be any issue with domainprep here.
0
 
aihaiaiAuthor Commented:
I think so, I went through all the articles, the only errors were related to unable to generate 3rd party (XFAX)proxyaddress which is no longer in used. The article options is to copy the .dll file and paste it to the spesific directory (by recreating back the directory) or  to disable the 3rd party proxy address at the recipient policy. I did it but still not working

I just realised the stamping email address works today after I click the 'update the policy now' at the default recipent policies. Now the only thing is, I still got the event id 2027, 2037 and 8231even though I was disable it.
0
 
aihaiaiAuthor Commented:
Yes, I already read the article. The email address stamping was OK now . As I mentioned, the event idsrelated to 3'rd party proxy address still generated even though I was disable it at recipient policy. Is there anything to do at the registry?
(Event Id 2027) Unable to generate the e-mail address. Unable to load address module 'E:\program files\exchsrvr\address\XFAX\i386\proxygen.dll' for address type 'XFAX'. Error 0x007007e]

(Event Id 2037) The file version of '\address\XFAX\i386\proxygen.dll' installed on the local serveris not current. Unable to locate a correct version of any server in the site.

(Event Id 8231) Permanent failure reported by policy group provider for 'CN=Recipient Policies, CN=My org,Cn=Microsoft Exchange,CN=Services,CN=Configuration,DC=mydom,DC=com':'MAD.EXE', error=8000ffff.Taking provider offline.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.