Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

VPN Change ASA5500

Posted on 2007-04-04
7
Medium Priority
?
431 Views
Last Modified: 2010-04-09
OK the config below works fine all clients behind the ASA can FTP to the FTP server at the other end. (TargetFTPServer)
Now it needs to be changed so that only 192.168.1.34 can get out to the target FTP server over FTP and the Target FTP server can only get back in to 192.168.1.34 via FTP.

The VPN was set up specifically to allow trafic without checking ACLS but I dont see a "sysopt connection permit-ipsec" command (im guessing thats not a valid command on PIXv7?)

I know this has to come out "access-list outbound extended permit ip any any "

But is it just a matter of changing

access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer

to

access-list outside_20_cryptomap extended permit tcp 192.168.1.0 255.255.255.0 host TargetFTPServer eq ftp
access-list inside_nat0_outbound extended permit tcp 192.168.1.0 255.255.255.0 host TargetFTPServer eq tfp


-----------------------------------------------------------------------------------------------------------------------------------------------
: Saved
: Written by enable_15 at 07:04:49.016 UTC Tue Apr 3 2007
!
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password XXXXXXXXXXXXXXXX encrypted
names
name 10.1.0.1 TargetFTPServer
name 456.456.456.456 TargetVPNConcentrator
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.243 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 123.123.123.123 255.255.255.240
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd ZXXXXXXXXXXXXXXXXXX encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list outbound extended permit ip any any
access-list inbound extended permit icmp any any echo-reply
access-list inbound extended permit icmp any any time-exceeded
access-list inbound extended permit icmp any any unreachable
access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 62.255.170.174 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer TargetVPNConcentrator
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
tunnel-group 456.456.456.456 type ipsec-l2l
tunnel-group 456.456.456.456 ipsec-attributes
 pre-shared-key XXXXXXXXXXXXXXXXXXXXXXX
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.244-192.168.1.254 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9525e007b49c75b4969465063f37e85a
: end
0
Comment
Question by:Pete Long
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 32

Expert Comment

by:rsivanandan
ID: 18851890
Yes, the sysopt command is not there in 7.x

You could control that by changing the acl to as below (note that both entries you have made in the question are the same :-))

access-list outside_20_cryptomap extended permit tcp host 192.168.1.34 host TargetFTPServer eq ftp
access-list inside_nat0_outbound extended permit tcp host 192.168.1.3 host TargetFTPServer eq tfp

Cheers,
Rajesh
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18852510
Hi Rajesh

Yeah I tried that - and nothing :( I added ftp and ftp-data - still nothing, it works with IP but try and lock it down it fails.

Do you think it could be an active passive FTP problem and the FTP server is talking back on strange port numbers?
0
 
LVL 32

Accepted Solution

by:
rsivanandan earned 2000 total points
ID: 18854808
Can you try with the following instead;

access-list outside_20_cryptomap extended permit tcp 192.168.1.0 255.255.255.0 host TargetFTPServer eq ftp
access-list inside_nat0_outbound extended permit tcp host 192.168.1.3 host TargetFTPServer eq tfp

Active/Passive should not be a problem, isn't the ftp fixup enabled on the ASA ?

Cheers,
Rajesh
0
Building an interactive eFuture classroom

Watch and learn how ATEN provided a total control system solution including seamless switching matrix switch, HDBaseT extenders, PDU, lighting control to build an interactive eFuture classroom.

 
LVL 57

Author Comment

by:Pete Long
ID: 18857730
Think I might have tried that hang on...

I'll give it a shot

>>Active/Passive should not be a problem, isn't the ftp fixup enabled on the ASA

  ftp mode passive
and
  inspect ftp

is in the config?
0
 
LVL 57

Author Comment

by:Pete Long
ID: 18857800
nope no, joy as soon as I introduce "eq ftp" the thing stops working.

0
 
LVL 57

Author Comment

by:Pete Long
ID: 18863918
ah Well - the client is happy to leave it as it is, with IP open - so I'll close this one down, still perplexing though =/
0
 
LVL 32

Expert Comment

by:rsivanandan
ID: 18886613
:-) Thats strange.

Cheers,
Rajesh
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Concerto Cloud Services, a provider of fully managed private, public and hybrid cloud solutions, announced today it was named to the 20 Coolest Cloud Infrastructure Vendors Of The 2017 Cloud  (http://www.concertocloud.com/about/in-the-news/2017/02/0…
WARNING:   If you follow the instructions here, you will wipe out your VTP and VLAN configurations.  Make sure you have backed up your switch!!! I recently had some issues with a few low-end Cisco routers (RV325) and I opened a case with Cisco TA…
Windows 10 is mostly good. However the one thing that annoys me is how many clicks you have to do to dial a VPN connection. You have to go to settings from the start menu, (2 clicks), Network and Internet (1 click), Click VPN (another click) then fi…
Both in life and business – not all partnerships are created equal. Spend 30 short minutes with us to learn:   • Key questions to ask when considering a partnership to accelerate your business into the cloud • Pitfalls and mistakes other partners…
Suggested Courses

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question