VPN Change ASA5500

OK the config below works fine all clients behind the ASA can FTP to the FTP server at the other end. (TargetFTPServer)
Now it needs to be changed so that only 192.168.1.34 can get out to the target FTP server over FTP and the Target FTP server can only get back in to 192.168.1.34 via FTP.

The VPN was set up specifically to allow trafic without checking ACLS but I dont see a "sysopt connection permit-ipsec" command (im guessing thats not a valid command on PIXv7?)

I know this has to come out "access-list outbound extended permit ip any any "

But is it just a matter of changing

access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer

to

access-list outside_20_cryptomap extended permit tcp 192.168.1.0 255.255.255.0 host TargetFTPServer eq ftp
access-list inside_nat0_outbound extended permit tcp 192.168.1.0 255.255.255.0 host TargetFTPServer eq tfp


-----------------------------------------------------------------------------------------------------------------------------------------------
: Saved
: Written by enable_15 at 07:04:49.016 UTC Tue Apr 3 2007
!
ASA Version 7.2(2)
!
hostname ciscoasa
domain-name default.domain.invalid
enable password XXXXXXXXXXXXXXXX encrypted
names
name 10.1.0.1 TargetFTPServer
name 456.456.456.456 TargetVPNConcentrator
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.1.243 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 123.123.123.123 255.255.255.240
!
interface Vlan3
 no forward interface Vlan1
 nameif dmz
 security-level 50
 no ip address
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd ZXXXXXXXXXXXXXXXXXX encrypted
ftp mode passive
dns server-group DefaultDNS
 domain-name default.domain.invalid
access-list outbound extended permit ip any any
access-list inbound extended permit icmp any any echo-reply
access-list inbound extended permit icmp any any time-exceeded
access-list inbound extended permit icmp any any unreachable
access-list outside_20_cryptomap extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer
access-list inside_nat0_outbound extended permit ip 192.168.1.0 255.255.255.0 host TargetFTPServer
pager lines 24
logging asdm informational
mtu outside 1500
mtu inside 1500
mtu dmz 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-522.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
access-group outbound in interface inside
route outside 0.0.0.0 0.0.0.0 62.255.170.174 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 20 match address outside_20_cryptomap
crypto map outside_map 20 set pfs
crypto map outside_map 20 set peer TargetVPNConcentrator
crypto map outside_map 20 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
 authentication pre-share
 encryption 3des
 hash sha
 group 2
 lifetime 86400
tunnel-group 456.456.456.456 type ipsec-l2l
tunnel-group 456.456.456.456 ipsec-attributes
 pre-shared-key XXXXXXXXXXXXXXXXXXXXXXX
telnet 192.168.1.0 255.255.255.0 inside
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd auto_config outside
!
dhcpd address 192.168.1.244-192.168.1.254 inside
!

!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny
  inspect sunrpc
  inspect xdmcp
  inspect sip
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9525e007b49c75b4969465063f37e85a
: end
LVL 58
Pete LongTechnical ConsultantAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

rsivanandanCommented:
Yes, the sysopt command is not there in 7.x

You could control that by changing the acl to as below (note that both entries you have made in the question are the same :-))

access-list outside_20_cryptomap extended permit tcp host 192.168.1.34 host TargetFTPServer eq ftp
access-list inside_nat0_outbound extended permit tcp host 192.168.1.3 host TargetFTPServer eq tfp

Cheers,
Rajesh
0
Pete LongTechnical ConsultantAuthor Commented:
Hi Rajesh

Yeah I tried that - and nothing :( I added ftp and ftp-data - still nothing, it works with IP but try and lock it down it fails.

Do you think it could be an active passive FTP problem and the FTP server is talking back on strange port numbers?
0
rsivanandanCommented:
Can you try with the following instead;

access-list outside_20_cryptomap extended permit tcp 192.168.1.0 255.255.255.0 host TargetFTPServer eq ftp
access-list inside_nat0_outbound extended permit tcp host 192.168.1.3 host TargetFTPServer eq tfp

Active/Passive should not be a problem, isn't the ftp fixup enabled on the ASA ?

Cheers,
Rajesh
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Determine the Perfect Price for Your IT Services

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden with our free interactive tool and use it to determine the right price for your IT services. Download your free eBook now!

Pete LongTechnical ConsultantAuthor Commented:
Think I might have tried that hang on...

I'll give it a shot

>>Active/Passive should not be a problem, isn't the ftp fixup enabled on the ASA

  ftp mode passive
and
  inspect ftp

is in the config?
0
Pete LongTechnical ConsultantAuthor Commented:
nope no, joy as soon as I introduce "eq ftp" the thing stops working.

0
Pete LongTechnical ConsultantAuthor Commented:
ah Well - the client is happy to leave it as it is, with IP open - so I'll close this one down, still perplexing though =/
0
rsivanandanCommented:
:-) Thats strange.

Cheers,
Rajesh
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware Firewalls

From novice to tech pro — start learning today.