Solved

Tired of "Internal Server Error"

Posted on 2007-04-04
11
203 Views
Last Modified: 2010-04-20
Every once in a while I go to start debugging an .ASP application that can be nothing more than a simple syntax error (forgot an end if or something) and rather than getting a nice error message that tells me where the problem is, I get "Internal server error".  I have to futz with it, delete the file, move it, edit it, put it back until eventually it actually reports the error.

Does anyone know why this might happen?

Thanks
0
Comment
Question by:jglazer63
  • 3
  • 2
  • 2
  • +2
11 Comments
 
LVL 50

Expert Comment

by:Ryan Chong
ID: 18850901
try do this to debug your script..

1. If you're using IE browser, go to Menu Tools > Internet Options > Advanced Tab, make sure the "Show friendly HTTP error messages" is unchecked.

2. For your ASP scripts, remark all "On Error Resume Next" that available and change it to "On Error Goto 0"
0
 

Author Comment

by:jglazer63
ID: 18851193
1. of course its checked (otherwise I would NEVER get a friendly error message)
2. thats not the issue

You don't understand.  The asp code could be simply:

response.write("hello world)

Missing the ending quote.  And I get the error I mention.  If I go in, delete the the .asp (cut into clipboard the code blanking the file), refresh, get a blank page, the paste it back in, sometimes this will start the debugger and I'll get the error message I was looking for.
0
 
LVL 50

Expert Comment

by:Ryan Chong
ID: 18851255
0
Migrating Your Company's PCs

To keep pace with competitors, businesses must keep employees productive, and that means providing them with the latest technology. This document provides the tips and tricks you need to help you migrate an outdated PC fleet to new desktops, laptops, and tablets.

 
LVL 4

Expert Comment

by:ETA-TECHNICIANS
ID: 18851300
Are you using any of the error handling with On Error Resume Next?
(E.G.,
If Err.Number <> 0 Then
      Response.Write Err.Number & ": " & Err.Source & " | " & Err.Description & "<br />" & vbCrLf
End If
).
These are not usually the most descriptive, but can be another clue.

But, back to your original question, i have run into situations where I get a nondescript error, but after i either comment and then uncomment, I get the more descriptive ASP error.
I cannot explain why this happens.  I find when i simpify the page (cut it down to the code bare minimums) i tend to get the more descriptive error messages rather then the ambiguous 'Server Error' message.  But again, i cannot tell you why.  perhaps an error with too much content following causes ASP to choke out the generic message?

anyways, nothing definitive here, but thought I would give my $0.02.
0
 

Author Comment

by:jglazer63
ID: 18851696
No on the first part, exactly on the second.  This is my issue.  Just tired of having to futz with removing/commenting/tweaking code just to get the error message I need to fix the problem.

Anyone have any other clues to this?
0
 
LVL 4

Expert Comment

by:nstand
ID: 18852147
Yep - I've seen this issue a few times, can be very frustrating.

Do you see the same behavoiur in IE & Firefox or just in IE?

Under IE Tools Internet Options > General > Temporray Internet Files is this set to 'Automatic' or 'Every time I visit the webpage'?

Do you use a proxy server?

Any special caching set on IIS?
0
 

Author Comment

by:jglazer63
ID: 18852156
I have only tried in IE.  No proxy or special caching.  
0
 
LVL 4

Accepted Solution

by:
nstand earned 125 total points
ID: 18852907
I'd be tempted to install a 2nd browser to see if you can replicate, that should highlight whether the problem is with IIS or the browser. Ensure "Every time I visit the webpage" is alsoselected in IE.

Am fairly certain when I saw this issue it was a problem with IIS and to do with IIS Caching of cetain files.

Take a look at this doc:
http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/a0483502-c6da-486a-917a-586c463b7ed6.mspx

Good luck
0
 
LVL 11

Assisted Solution

by:AnthonyP9618
AnthonyP9618 earned 125 total points
ID: 18854314
Turn off Friendly IE Error Messages...

http://support.microsoft.com/kb/294807
0
 
LVL 11

Expert Comment

by:AnthonyP9618
ID: 18854320
Preferably Method 1...

Method 1
1.      Turn off the friendly error message option in the browser as follows:
a.       In Internet Explorer 5.x and 6.x, on the Tools menu, click Internet Options.
b.       On the Advanced tab, under the Browsing section, click to clear the Show friendly HTTP error messages check box, and then click OK.
c.       Close the browser.
0

Featured Post

Gigs: Get Your Project Delivered by an Expert

Select from freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely and get projects done right.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This demonstration started out as a follow up to some recently posted questions on the subject of logging in: http://www.experts-exchange.com/Programming/Languages/Scripting/JavaScript/Q_28634665.html and http://www.experts-exchange.com/Programming/…
Lync server 2013 or Skype for business Backup Service Error ID 4049 – After File Share Migration
This Micro Tutorial will teach you how to censor certain areas of your screen. The example in this video will show a little boy's face being blurred. This will be demonstrated using Adobe Premiere Pro CS6.
In this video I am going to show you how to back up and restore Office 365 mailboxes using CodeTwo Backup for Office 365. Learn more about the tool used in this video here: http://www.codetwo.com/backup-for-office-365/ (http://www.codetwo.com/ba…

816 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now